summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-02-03 14:47:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-02-03 14:47:45 +0000
commitced29f0de7bf372d721ebd47b469b2d0b4b09ef3 (patch)
treeae6573d065759a3b8205508e616c5452166632bb /sci-libs
parentSmall cleanup. (diff)
downloadgentoo-2-ced29f0de7bf372d721ebd47b469b2d0b4b09ef3.tar.gz
gentoo-2-ced29f0de7bf372d721ebd47b469b2d0b4b09ef3.tar.bz2
gentoo-2-ced29f0de7bf372d721ebd47b469b2d0b4b09ef3.zip
Initial import from sunrise, thanks to Christian Helbling and all contributors in bug #146028
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libticables2/ChangeLog51
-rw-r--r--sci-libs/libticables2/files/libticables2-1.2.0-locale.patch11
-rw-r--r--sci-libs/libticables2/libticables2-1.2.0.ebuild48
-rw-r--r--sci-libs/libticables2/metadata.xml11
4 files changed, 121 insertions, 0 deletions
diff --git a/sci-libs/libticables2/ChangeLog b/sci-libs/libticables2/ChangeLog
new file mode 100644
index 000000000000..74e21c8cb2e4
--- /dev/null
+++ b/sci-libs/libticables2/ChangeLog
@@ -0,0 +1,51 @@
+# ChangeLog for sci-libs/libticables2
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables2/ChangeLog,v 1.1 2009/02/03 14:47:38 bicatali Exp $
+
+*libticables2-1.2.0 (03 Feb 2009)
+
+ 03 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/libticables2-1.2.0-locale.patch, +metadata.xml,
+ +libticables2-1.2.0.ebuild:
+ Initial import from sunrise, thanks to Christian Helbling and all
+ contributors in bug #146028
+
+ 15 Jan 2008; Christian Helbling <helch@gmx.ch> -libticables2-1.0.9.ebuild,
+ +libticables2-1.2.0.ebuild:
+ Version bump
+
+ 05 Jan 2008; Jakub Moc <jakub@gentoo.org> libticables2-1.0.9.ebuild:
+ pam_console is dead and burried
+
+ 22 Sep 2007; Christian Helbling <helch@gmx.ch> -libticables2-1.0.5.ebuild,
+ +libticables2-1.0.9.ebuild:
+ version bump
+
+ 15 Jun 2007; Christian Helbling <helch@gmx.ch> +libticables2-1.0.5.ebuild,
+ -libticables2-20061030.ebuild:
+ Version bump. Better version numbers.
+
+ 03 Dec 2006; Stefan Schweizer <genstef@gentoo.org>
+ -libticables2-20060723.ebuild, libticables2-20061030.ebuild:
+ fix whitespace, remove old
+
+ 02 Dec 2006; Christian Helbling <helch@gmx.ch>
+ +libticables2-20061030.ebuild:
+ Version bump
+
+ 11 Nov 2006; Jakub Moc <jakub@gentoo.org> libticables2-20060723.ebuild:
+ Quoting, fix RDEPEND on gettext, cosmetics
+
+ 10 Nov 2006; Christian Helbling <helch@gmx.ch>
+ +files/60-libticables.perms, libticables2-20060723.ebuild,
+ +files/60-libticables.rules:
+ Added pam_console use flag
+
+ 11 Sep 2006; Stefan Schweizer <genstef@gentoo.org>
+ libticables2-20060723.ebuild:
+ useflags only work when it is possible to disable linking while compiling
+
+ 04 Sep 2006; Christian Helbling <helch@gmx.ch>
+ +libticables2-20060723.ebuild, +metadata.xml:
+ New ebuild for bug 146028
+
diff --git a/sci-libs/libticables2/files/libticables2-1.2.0-locale.patch b/sci-libs/libticables2/files/libticables2-1.2.0-locale.patch
new file mode 100644
index 000000000000..4602dfdba3da
--- /dev/null
+++ b/sci-libs/libticables2/files/libticables2-1.2.0-locale.patch
@@ -0,0 +1,11 @@
+--- src/gettext.h~ 2007-02-23 16:05:21.000000000 +0000
++++ src/gettext.h 2009-02-03 12:41:31.584312058 +0000
+@@ -24,7 +24,7 @@
+
+ /* Get declarations of GNU message catalog functions. */
+ # include <libintl.h>
+-
++# include <locale.h>
+ #else
+
+ /* Solaris /usr/include/locale.h includes /usr/include/libintl.h, which
diff --git a/sci-libs/libticables2/libticables2-1.2.0.ebuild b/sci-libs/libticables2/libticables2-1.2.0.ebuild
new file mode 100644
index 000000000000..ac2e590807d1
--- /dev/null
+++ b/sci-libs/libticables2/libticables2-1.2.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libticables2/libticables2-1.2.0.ebuild,v 1.1 2009/02/03 14:47:38 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Library to handle different link cables for TI calculators"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/gtktiemu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc nls threads usb"
+
+RDEPEND=">=dev-libs/glib-2
+ usb? ( dev-libs/libusb )
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-locale.patch
+}
+
+src_configure() {
+ econf \
+ --disable-rpath \
+ $(use_enable nls) \
+ $(use_enable usb libusb) \
+ $(use_enable threads)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS LOGO NEWS README ChangeLog docs/api.txt
+ if use doc; then
+ dohtml docs/html/*
+ fi
+}
+
+pkg_postinst() {
+ elog "Please read README in /usr/share/doc/${PF}"
+ elog "if you encounter any problem with a link cable"
+}
diff --git a/sci-libs/libticables2/metadata.xml b/sci-libs/libticables2/metadata.xml
new file mode 100644
index 000000000000..e44d875ab898
--- /dev/null
+++ b/sci-libs/libticables2/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ This library provides functions to use Texas Instruments link cables
+ for TI calculators. It currently supports all cables on i386,
+ including the USB one. Supported cables may vary depending on your
+ architecture.
+</longdescription>
+</pkgmetadata>