summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-04-16 07:35:35 +0000
committerJustin Lecher <jlec@gentoo.org>2011-04-16 07:35:35 +0000
commitc86dd7c0e50d2fb2f32c9d49c0ade43bd13b9f26 (patch)
treecc2615ae67e0e024eed40df8bb332bf94a3c1019 /sci-libs
parentVersion Bump (diff)
downloadgentoo-2-c86dd7c0e50d2fb2f32c9d49c0ade43bd13b9f26.tar.gz
gentoo-2-c86dd7c0e50d2fb2f32c9d49c0ade43bd13b9f26.tar.bz2
gentoo-2-c86dd7c0e50d2fb2f32c9d49c0ade43bd13b9f26.zip
Version Bump
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gamer/ChangeLog9
-rw-r--r--sci-libs/gamer/gamer-1.5.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/sci-libs/gamer/ChangeLog b/sci-libs/gamer/ChangeLog
index 27691c8025fd..084787899ac5 100644
--- a/sci-libs/gamer/ChangeLog
+++ b/sci-libs/gamer/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gamer
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/ChangeLog,v 1.2 2010/11/02 08:19:02 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/ChangeLog,v 1.3 2011/04/16 07:35:35 jlec Exp $
+
+*gamer-1.5 (16 Apr 2011)
+
+ 16 Apr 2011; Justin Lecher <jlec@gentoo.org> +gamer-1.5.ebuild:
+ Version Bump
02 Nov 2010; Justin Lecher <jlec@gentoo.org> +files/1.4-doc.patch,
gamer-1.4.ebuild:
diff --git a/sci-libs/gamer/gamer-1.5.ebuild b/sci-libs/gamer/gamer-1.5.ebuild
new file mode 100644
index 000000000000..47963e2b1b94
--- /dev/null
+++ b/sci-libs/gamer/gamer-1.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gamer/gamer-1.5.ebuild,v 1.1 2011/04/16 07:35:35 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils multilib
+
+DESCRIPTION="Geometry-preserving Adaptive MeshER"
+HOMEPAGE="http://fetk.org/codes/gamer/index.html"
+SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-2"
+IUSE="doc"
+
+RDEPEND=">=dev-libs/maloc-1.4"
+DEPEND="
+ ${RDEPEND}
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen )"
+
+S="${WORKDIR}"/${PN}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/1.4-multilib.patch \
+ "${FILESDIR}"/1.4-doc.patch
+ eautoreconf
+}
+
+src_configure() {
+ local fetk_include
+ local fetk_lib
+ local myconf
+
+ use doc || myconf="${myconf} --with-doxygen= --with-dot="
+
+ fetk_include="${EPREFIX}"/usr/include
+ fetk_lib="${EPREFIX}"/usr/$(get_libdir)
+ export FETK_INCLUDE="${fetk_include}"
+ export FETK_LIBRARY="${fetk_lib}"
+
+ econf \
+ --docdir="${EPREFIX}"/usr/share/doc/${PF} \
+ --disable-triplet \
+ --enable-shared \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+}