summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-09-07 15:38:21 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-09-07 15:38:21 +0000
commitc14b75dcafa24b06477a7bfb6a17adf848c0eeca (patch)
tree7d781713fe8d6d19628c088094be86f27bda8774 /sci-libs
parentAdded ~sparc keyword as it went missing many moons ago in the version bump. (diff)
downloadgentoo-2-c14b75dcafa24b06477a7bfb6a17adf848c0eeca.tar.gz
gentoo-2-c14b75dcafa24b06477a7bfb6a17adf848c0eeca.tar.bz2
gentoo-2-c14b75dcafa24b06477a7bfb6a17adf848c0eeca.zip
Use autotooled libtool from lapack rather than the one from /usr/bin to pick up the proper fortran compiler. This fixes bug #146512.
(Portage version: 2.1.1_rc1-r3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/lapack-atlas/ChangeLog8
-rw-r--r--sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.156
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.7.15.ebuild9
3 files changed, 15 insertions, 8 deletions
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index b8d2b8b4a4d4..62807f9b5af6 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 2004-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.25 2006/09/04 22:59:37 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.26 2006/09/07 15:38:21 markusle Exp $
+
+ 07 Sep 2006; Markus Dittrich <markusle@gentoo.org>
+ lapack-atlas-3.7.15.ebuild:
+ Use autotooled libtool from lapack rather than the one from
+ /usr/bin to pick up the proper fortran compiler. This fixes
+ bug #146512.
04 Sep 2006; Stephanie Lockwood-Childs <wormo@gentoo.org>
lapack-atlas-3.7.11.ebuild:
diff --git a/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.15 b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.15
index db16c7a64d5b..7e9f4bc482aa 100644
--- a/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.15
+++ b/sci-libs/lapack-atlas/files/digest-lapack-atlas-3.7.15
@@ -1,6 +1,6 @@
-MD5 2beee32a6b3aeadfeb2b2ea74cdefe12 atlas-3.7.15-shared-libs.patch.bz2 6775
-RMD160 c1c254af3e89da40fab884bc90958093bd61b6fa atlas-3.7.15-shared-libs.patch.bz2 6775
-SHA256 528df817139056a0cb721436f4474bb26e8d986845b9cbb558abb19def7d4b19 atlas-3.7.15-shared-libs.patch.bz2 6775
+MD5 4d85e976f592f02afa54a82d3890ff22 atlas-3.7.15-shared-libs.patch.bz2 6769
+RMD160 6c9922e4c6236a1c6bb07af3862d023678d86a31 atlas-3.7.15-shared-libs.patch.bz2 6769
+SHA256 6539ea2ecff0e7d84d1968fb9cf9a60e1300e505dd1882f74c386e3dd63baa6d atlas-3.7.15-shared-libs.patch.bz2 6769
MD5 6fdfd37faaed7047e7a781a09fd050e9 atlas3.7.15.tar.bz2 1728282
RMD160 7965ee554d197ce07bca68805cd7ed126b5abb0a atlas3.7.15.tar.bz2 1728282
SHA256 33c461a3e34b26e6b2aa7414d2fd52a1d7dc9e7f9ec5513969aeb36d80b3c27b atlas3.7.15.tar.bz2 1728282
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.7.15.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.7.15.ebuild
index 5430a9c4930e..7f68a2ce292d 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.7.15.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.7.15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.15.ebuild,v 1.3 2006/09/03 18:16:10 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.15.ebuild,v 1.4 2006/09/07 15:38:21 markusle Exp $
inherit eutils flag-o-matic toolchain-funcs fortran
@@ -104,8 +104,8 @@ src_compile() {
libs="${LDFLAGS} -lpthread -lg2c"
fi
- libtool --mode=link --tag=F77 ${FORTRANC} -o liblapack.la *.lo \
- -rpath "${RPATH}" -lblas -lcblas -latlas ${libs} \
+ ../libtool --mode=link --tag=F77 ${FORTRANC} -lblas -lcblas \
+ -latlas ${libs} -o liblapack.la *.lo -rpath "${RPATH}" \
|| die "Failed to create liblapack.la"
}
@@ -113,7 +113,8 @@ src_install () {
dodir "${RPATH}"
cd "${S_LAPACK}"/SRC
- libtool --mode=install install -s liblapack.la "${D}/${RPATH}" \
+ ../libtool --mode=install install -s liblapack.la \
+ "${D}/${RPATH}" \
|| die "Failed to install lapack-atlas library"
eselect lapack add $(get_libdir) ${FILESDIR}/eselect.lapack atlas