summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-05-06 12:56:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-05-06 12:56:09 +0000
commitbeee8327085d5995562bb4d163ee94c954a04f6a (patch)
tree509663b5dc30a7df82da87307f4b06b2bd5cd4f7 /sci-libs
parentalpha/ia64/sparc stable wrt #210564 (diff)
downloadgentoo-2-beee8327085d5995562bb4d163ee94c954a04f6a.tar.gz
gentoo-2-beee8327085d5995562bb4d163ee94c954a04f6a.tar.bz2
gentoo-2-beee8327085d5995562bb4d163ee94c954a04f6a.zip
Version bump with important security fix (bug #220391). Also fixed patch for testing. Restricting mirroring for now.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cdf/ChangeLog12
-rw-r--r--sci-libs/cdf/cdf-3.2.1.ebuild (renamed from sci-libs/cdf/cdf-3.2.ebuild)24
-rw-r--r--sci-libs/cdf/files/cdf-3.2-soname.patch4
3 files changed, 26 insertions, 14 deletions
diff --git a/sci-libs/cdf/ChangeLog b/sci-libs/cdf/ChangeLog
index 29753f34cb3b..ef7f650f1a76 100644
--- a/sci-libs/cdf/ChangeLog
+++ b/sci-libs/cdf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/cdf
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cdf/ChangeLog,v 1.10 2007/12/03 18:41:01 bicatali Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cdf/ChangeLog,v 1.11 2008/05/06 12:56:08 bicatali Exp $
+
+*cdf-3.2.1 (06 May 2008)
+
+ 06 May 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/cdf-3.2-soname.patch, -cdf-3.2.ebuild, +cdf-3.2.1.ebuild:
+ Version bump with important security fix (bug #220391). Also fixed patch
+ for testing. Since upstream did not change names, restricting mirroring
+ for now.
*cdf-3.2 (03 Dec 2007)
diff --git a/sci-libs/cdf/cdf-3.2.ebuild b/sci-libs/cdf/cdf-3.2.1.ebuild
index 9a8262d60618..6c926ef21211 100644
--- a/sci-libs/cdf/cdf-3.2.ebuild
+++ b/sci-libs/cdf/cdf-3.2.1.ebuild
@@ -1,15 +1,16 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cdf/cdf-3.2.ebuild,v 1.1 2007/12/03 18:41:01 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cdf/cdf-3.2.1.ebuild,v 1.1 2008/05/06 12:56:08 bicatali Exp $
-inherit eutils toolchain-funcs multilib
+inherit eutils toolchain-funcs multilib versionator
-MY_P="${P/-}"
-MY_P="${MY_P/.}"
+MY_P="${PN}$(get_version_component_range 1)$(get_version_component_range 2)"
+MY_HP="${MY_P}$(get_version_component_range 3)"
DESCRIPTION="Common Data Format I/O library for multi-dimensional data sets"
HOMEPAGE="http://cdf.gsfc.nasa.gov/"
-SRC_BASE="ftp://cdaweb.gsfc.nasa.gov/pub/${PN}/dist/${MY_P}/unix"
+SRC_BASE="ftp://cdaweb.gsfc.nasa.gov/pub/${PN}/dist/${MY_HP}/unix"
+
SRC_URI="${SRC_BASE}/${MY_P}-dist-${PN}.tar.gz
java? ( ${SRC_BASE}/${MY_P}-dist-java.tar.gz )
doc? ( ${SRC_BASE}/${MY_P}_documentation/${MY_P}crm.pdf
@@ -28,14 +29,16 @@ RDEPEND="ncurses? ( sys-libs/ncurses )"
DEPEND="${RDEPEND}
java? ( virtual/jdk dev-java/java-config )"
-S="${WORKDIR}/${MY_P}-dist-readonly"
+RESTRICT="mirror"
+
+S="${WORKDIR}/${MY_P}-dist"
src_unpack() {
unpack ${A}
cd "${S}"
# respect cflags, remove useless scripts
- epatch "${FILESDIR}"/${P}-Makefile.patch
- epatch "${FILESDIR}"/${P}-soname.patch
+ epatch "${FILESDIR}"/${PN}-3.2-Makefile.patch
+ epatch "${FILESDIR}"/${PN}-3.2-soname.patch
# use proper lib dir
sed -i \
-e "s:\$(INSTALLDIR)/lib:\$(INSTALLDIR)/$(get_libdir):g" \
@@ -110,7 +113,8 @@ src_install() {
if use java; then
cd cdfjava
dolib.so jni/libcdfNativeLibrary.so.${PV_SO}
- dosym libcdfNativeLibrary.so.${PV_SO} /usr/$(get_libdir)/libcdfNativeLibrary.so
+ dosym libcdfNativeLibrary.so.${PV_SO} \
+ /usr/$(get_libdir)/libcdfNativeLibrary.so
insinto /usr/share/cdf
doins */*.jar
if use examples; then
diff --git a/sci-libs/cdf/files/cdf-3.2-soname.patch b/sci-libs/cdf/files/cdf-3.2-soname.patch
index d0357bc23f5a..e4f28617faca 100644
--- a/sci-libs/cdf/files/cdf-3.2-soname.patch
+++ b/sci-libs/cdf/files/cdf-3.2-soname.patch
@@ -15,8 +15,8 @@
else \
- echo $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS); \
- $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS); \
-+ echo $(LD) $(LDFLAGS) -Wl,-soname,libdf.$(SHAREDEXT) -o $@ $(OBJs) $(SYSLIBS); \
-+ $(LD) $(LDFLAGS) -Wl,-soname,libdf.$(SHAREDEXT) -o $@ $(OBJs) $(SYSLIBS); \
++ echo $(LD) $(LDFLAGS) -Wl,-soname,libcdf.$(SHAREDEXT) -o $@ $(OBJs) $(SYSLIBS); \
++ $(LD) $(LDFLAGS) -Wl,-soname,libcdf.$(SHAREDEXT) -o $@ $(OBJs) $(SYSLIBS); \
fi
libcdf.o: $(OBJs)