summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-13 20:33:42 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-13 20:33:42 +0000
commitbcf27da3ed7950754e79590e42212ed1ce9f6337 (patch)
tree2ae59f035a75e285661f15ee2757c70f6b10c1c6 /sci-libs
parentAdd ~sparc (diff)
downloadgentoo-2-bcf27da3ed7950754e79590e42212ed1ce9f6337.tar.gz
gentoo-2-bcf27da3ed7950754e79590e42212ed1ce9f6337.tar.bz2
gentoo-2-bcf27da3ed7950754e79590e42212ed1ce9f6337.zip
Version Bump per 184500
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/torch/ChangeLog9
-rw-r--r--sci-libs/torch/torch-3.1.ebuild54
2 files changed, 61 insertions, 2 deletions
diff --git a/sci-libs/torch/ChangeLog b/sci-libs/torch/ChangeLog
index 3a72ef27f51f..ecefabf2432a 100644
--- a/sci-libs/torch/ChangeLog
+++ b/sci-libs/torch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/torch
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/ChangeLog,v 1.6 2009/09/23 20:09:57 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/ChangeLog,v 1.7 2010/02/13 20:33:42 jlec Exp $
+
+*torch-3.1 (13 Feb 2010)
+
+ 13 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org> +torch-3.1.ebuild:
+ Version Bump per 184500
23 Sep 2009; Patrick Lauer <patrick@gentoo.org> torch-3.ebuild:
Remove virtual/libc
diff --git a/sci-libs/torch/torch-3.1.ebuild b/sci-libs/torch/torch-3.1.ebuild
new file mode 100644
index 000000000000..93019bfb629e
--- /dev/null
+++ b/sci-libs/torch/torch-3.1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/torch/torch-3.1.ebuild,v 1.1 2010/02/13 20:33:42 jlec Exp $
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="machine-learning library, written in simple C++"
+HOMEPAGE="http://www.torch.ch/"
+SRC_URI="http://www.torch.ch/archives/Torch${PV%.1}src.tgz
+ doc? ( http://www.torch.ch/archives/Torch3doc.tgz )"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug doc examples"
+
+S=${WORKDIR}/Torch${PV%.1}
+
+TORCH_PACKAGES="convolutions datasets decoder distributions gradients kernels matrix nonparametrics speech"
+
+src_compile() {
+ local shalldebug="OPT"
+ use debug && shalldebug="DBG"
+ # -malign-double makes no sense on a 64-bit arch
+ use amd64 || extraflags="-malign-double"
+ cp config/Makefile_options_Linux .
+ sed -i \
+ -e "s:^PACKAGES.*:PACKAGES = ${TORCH_PACKAGES}:" \
+ -e "s:^DEBUG.*:DEBUG = ${shalldebug}:" \
+ -e "s:^CFLAGS_OPT_FLOAT.*:CFLAGS_OPT_FLOAT = ${CFLAGS} -ffast-math ${extraflags}:" \
+ Makefile_options_Linux
+
+ emake -j1 depend || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dolib lib/*/*.a || die
+ insinto /usr/include/torch
+ for directory in core ${torch_packages}; do
+ doins ${directory}/*.h || die
+ done
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die
+ fi
+
+ if use doc; then
+ cd "${WORKDIR}"/docs
+ doins *.pdf || die
+ dohtml -r manual/. || die
+ fi
+}