summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-04-24 21:14:14 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-04-24 21:14:14 +0000
commitb52a4eefe92196048f5c76945f1d0b3ab34506b0 (patch)
tree6e50c7273afc54e1acb332bcccc1c27f1ea8741c /sci-libs
parentAt some point upstream changed to libtool building, and dobin/dosbin breaks t... (diff)
downloadgentoo-2-b52a4eefe92196048f5c76945f1d0b3ab34506b0.tar.gz
gentoo-2-b52a4eefe92196048f5c76945f1d0b3ab34506b0.tar.bz2
gentoo-2-b52a4eefe92196048f5c76945f1d0b3ab34506b0.zip
Version bump
(Portage version: 2.1.10.56/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/armadillo/ChangeLog7
-rw-r--r--sci-libs/armadillo/armadillo-3.0.2.ebuild62
2 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index b7103d4d5a70..f5eff4dec30c 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/armadillo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.10 2012/04/13 01:07:46 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.11 2012/04/24 21:14:14 bicatali Exp $
+
+*armadillo-3.0.2 (24 Apr 2012)
+
+ 24 Apr 2012; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-3.0.2.ebuild:
+ Version bump
*armadillo-3.0.1 (13 Apr 2012)
diff --git a/sci-libs/armadillo/armadillo-3.0.2.ebuild b/sci-libs/armadillo/armadillo-3.0.2.ebuild
new file mode 100644
index 000000000000..9966390f75fd
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-3.0.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-3.0.2.ebuild,v 1.1 2012/04/24 21:14:14 bicatali Exp $
+
+EAPI=4
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas blas doc lapack"
+
+RDEPEND=">=dev-libs/boost-1.34
+ atlas? ( sci-libs/lapack-atlas )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ )
+ fi
+ if use atlas; then
+ mycmakeargs=(
+ -DCBLAS_FOUND=ON
+ -DCLAPACK_FOUND=ON
+ -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+ -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+ -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*pdf
+}