summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-12-16 12:15:21 +0000
committerJustin Lecher <jlec@gentoo.org>2011-12-16 12:15:21 +0000
commitad540ba24c5fb2ff691a32e6bfffe05b6955c194 (patch)
tree4749f0b1d36203c94ba62175862df36734cf9e20 /sci-libs
parentStable for AMD64, wrt bug #393791 (diff)
downloadgentoo-2-ad540ba24c5fb2ff691a32e6bfffe05b6955c194.tar.gz
gentoo-2-ad540ba24c5fb2ff691a32e6bfffe05b6955c194.tar.bz2
gentoo-2-ad540ba24c5fb2ff691a32e6bfffe05b6955c194.zip
Moved to autotools-utils.eclass in order to handle .a/.la correctly
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/ccolamd/ChangeLog5
-rw-r--r--sci-libs/ccolamd/ccolamd-2.7.3.ebuild16
2 files changed, 13 insertions, 8 deletions
diff --git a/sci-libs/ccolamd/ChangeLog b/sci-libs/ccolamd/ChangeLog
index 1b9a4e758786..3161462175f0 100644
--- a/sci-libs/ccolamd/ChangeLog
+++ b/sci-libs/ccolamd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/ccolamd
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ChangeLog,v 1.17 2011/06/26 13:17:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ChangeLog,v 1.18 2011/12/16 12:15:21 jlec Exp $
+
+ 16 Dec 2011; Justin Lecher <jlec@gentoo.org> ccolamd-2.7.3.ebuild:
+ Moved to autotools-utils.eclass in order to handle .a/.la correctly
26 Jun 2011; Justin Lecher <jlec@gentoo.org> ccolamd-2.7.1.ebuild,
ccolamd-2.7.3.ebuild, metadata.xml:
diff --git a/sci-libs/ccolamd/ccolamd-2.7.3.ebuild b/sci-libs/ccolamd/ccolamd-2.7.3.ebuild
index a018ec7fe656..49814270668f 100644
--- a/sci-libs/ccolamd/ccolamd-2.7.3.ebuild
+++ b/sci-libs/ccolamd/ccolamd-2.7.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ccolamd-2.7.3.ebuild,v 1.2 2011/06/26 13:17:19 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ccolamd/ccolamd-2.7.3.ebuild,v 1.3 2011/12/16 12:15:21 jlec Exp $
EAPI=4
-inherit autotools eutils
+inherit autotools-utils
MY_PN=CCOLAMD
@@ -24,11 +24,13 @@ DOCS="README.txt Doc/ChangeLog"
S="${WORKDIR}/${MY_PN}"
+AUTOTOOLS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.7.1-autotools.patch
+ )
+
src_prepare() {
- epatch "${FILESDIR}"/${PN}-2.7.1-autotools.patch
+ autotools-utils_src_prepare
eautoreconf
}
-
-src_configure() {
- econf $(use_enable static-libs static)
-}