summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-09-12 12:26:04 +0000
committerJustin Lecher <jlec@gentoo.org>2010-09-12 12:26:04 +0000
commita8251cf02244e6f52101deeb6e9829105c76527a (patch)
treefb04248341f0d9de618779dec5fa1a9e0ae813f2 /sci-libs
parentAdd ree18. Remove early-beta support for rspec-2 which no longer works. (diff)
downloadgentoo-2-a8251cf02244e6f52101deeb6e9829105c76527a.tar.gz
gentoo-2-a8251cf02244e6f52101deeb6e9829105c76527a.tar.bz2
gentoo-2-a8251cf02244e6f52101deeb6e9829105c76527a.zip
Switched to tc-has-openmp and remove built_with_use
(Portage version: 2.2_rc79/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cctbx/ChangeLog7
-rw-r--r--sci-libs/cctbx/cctbx-2009.11.01.0123-r1.ebuild10
-rw-r--r--sci-libs/cctbx/cctbx-2010.03.29.2334-r1.ebuild10
-rw-r--r--sci-libs/cctbx/cctbx-2010.03.29.2334-r2.ebuild10
4 files changed, 15 insertions, 22 deletions
diff --git a/sci-libs/cctbx/ChangeLog b/sci-libs/cctbx/ChangeLog
index 0df8b98f4c55..5715421c5003 100644
--- a/sci-libs/cctbx/ChangeLog
+++ b/sci-libs/cctbx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/cctbx
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.7 2010/09/12 08:44:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/ChangeLog,v 1.8 2010/09/12 12:26:04 jlec Exp $
+
+ 12 Sep 2010; Justin Lecher <jlec@gentoo.org>
+ cctbx-2009.11.01.0123-r1.ebuild, cctbx-2010.03.29.2334-r1.ebuild,
+ cctbx-2010.03.29.2334-r2.ebuild:
+ Switched to tc-has-openmp and remove built_with_use
*cctbx-2010.03.29.2334-r2 (12 Sep 2010)
diff --git a/sci-libs/cctbx/cctbx-2009.11.01.0123-r1.ebuild b/sci-libs/cctbx/cctbx-2009.11.01.0123-r1.ebuild
index a74437ccd4da..519260f31e40 100644
--- a/sci-libs/cctbx/cctbx-2009.11.01.0123-r1.ebuild
+++ b/sci-libs/cctbx/cctbx-2009.11.01.0123-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2009.11.01.0123-r1.ebuild,v 1.4 2010/06/16 07:03:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2009.11.01.0123-r1.ebuild,v 1.5 2010/09/12 12:26:04 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -32,12 +32,8 @@ MY_S="${WORKDIR}"/cctbx_sources
MY_B="${WORKDIR}"/cctbx_build
pkg_setup() {
- if use openmp &&
- [[ $(tc-getCC)$ == *gcc* ]] &&
- ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
- ! built_with_use sys-devel/gcc openmp )
- then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ if use openmp && ! tc-has-openmp; then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 and icc"
ewarn "If you want to build ${PN} with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
fi
diff --git a/sci-libs/cctbx/cctbx-2010.03.29.2334-r1.ebuild b/sci-libs/cctbx/cctbx-2010.03.29.2334-r1.ebuild
index df4d0ca01aba..26792e157934 100644
--- a/sci-libs/cctbx/cctbx-2010.03.29.2334-r1.ebuild
+++ b/sci-libs/cctbx/cctbx-2010.03.29.2334-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r1.ebuild,v 1.1 2010/07/03 07:16:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r1.ebuild,v 1.2 2010/09/12 12:26:04 jlec Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -32,12 +32,8 @@ MY_S="${WORKDIR}"/cctbx_sources
MY_B="${WORKDIR}"/cctbx_build
pkg_setup() {
- if use openmp &&
- [[ $(tc-getCC)$ == *gcc* ]] &&
- ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
- ! built_with_use sys-devel/gcc openmp )
- then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ if use openmp && ! tc-has-openmp; then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 and icc"
ewarn "If you want to build ${PN} with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
fi
diff --git a/sci-libs/cctbx/cctbx-2010.03.29.2334-r2.ebuild b/sci-libs/cctbx/cctbx-2010.03.29.2334-r2.ebuild
index ebc1b2b4849a..6e6353eff59a 100644
--- a/sci-libs/cctbx/cctbx-2010.03.29.2334-r2.ebuild
+++ b/sci-libs/cctbx/cctbx-2010.03.29.2334-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r2.ebuild,v 1.1 2010/09/12 08:44:48 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cctbx/cctbx-2010.03.29.2334-r2.ebuild,v 1.2 2010/09/12 12:26:04 jlec Exp $
EAPI="3"
@@ -33,12 +33,8 @@ MY_S="${WORKDIR}"/cctbx_sources
MY_B="${WORKDIR}"/cctbx_build
pkg_setup() {
- if use openmp &&
- [[ $(tc-getCC)$ == *gcc* ]] &&
- ( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
- ! built_with_use sys-devel/gcc openmp )
- then
- ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
+ if use openmp && ! tc-has-openmp; then
+ ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 and icc"
ewarn "If you want to build ${PN} with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
fi