summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-12-11 00:09:50 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-12-11 00:09:50 +0000
commita4d2e5b507652e07dbbda5ea564e759ce372b623 (patch)
tree78c26b0135f7e0491bb80c4c752383095b0593c4 /sci-libs
parentEnable libdrm uncondionally, bug #439138. (diff)
downloadgentoo-2-a4d2e5b507652e07dbbda5ea564e759ce372b623.tar.gz
gentoo-2-a4d2e5b507652e07dbbda5ea564e759ce372b623.tar.bz2
gentoo-2-a4d2e5b507652e07dbbda5ea564e759ce372b623.zip
Version bump. Tests respect user settings
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/dlib/ChangeLog8
-rw-r--r--sci-libs/dlib/dlib-17.48.ebuild (renamed from sci-libs/dlib/dlib-17.46.ebuild)22
-rw-r--r--sci-libs/dlib/files/dlib-17.48-makefile-test.patch35
3 files changed, 55 insertions, 10 deletions
diff --git a/sci-libs/dlib/ChangeLog b/sci-libs/dlib/ChangeLog
index 64588037294f..58e03e203e78 100644
--- a/sci-libs/dlib/ChangeLog
+++ b/sci-libs/dlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/dlib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/dlib/ChangeLog,v 1.2 2012/08/02 22:16:36 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dlib/ChangeLog,v 1.3 2012/12/11 00:09:49 bicatali Exp $
+
+*dlib-17.48 (11 Dec 2012)
+
+ 11 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> +dlib-17.48.ebuild,
+ +files/dlib-17.48-makefile-test.patch, -dlib-17.46.ebuild:
+ Version bump. Tests respect user settings
*dlib-17.47 (02 Aug 2012)
diff --git a/sci-libs/dlib/dlib-17.46.ebuild b/sci-libs/dlib/dlib-17.48.ebuild
index 2eb1ac69c395..80a24515bf58 100644
--- a/sci-libs/dlib/dlib-17.46.ebuild
+++ b/sci-libs/dlib/dlib-17.48.ebuild
@@ -1,37 +1,41 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/dlib/dlib-17.46.ebuild,v 1.1 2012/06/07 19:55:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/dlib/dlib-17.48.ebuild,v 1.1 2012/12/11 00:09:49 bicatali Exp $
EAPI=4
+inherit flag-o-matic toolchain-funcs
+
DESCRIPTION="Numerical and networking C++ library"
HOMEPAGE="http://dlib.net/"
SRC_URI="mirror://sourceforge/dclib/${P}.tar.bz2"
LICENSE="Boost-1.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="blas doc examples jpeg lapack png X"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="blas doc examples jpeg lapack png test X"
-RDEPEND="blas? ( virtual/blas )
+RDEPEND="
+ blas? ( virtual/blas )
jpeg? ( virtual/jpeg )
lapack? ( virtual/lapack )
png? ( media-libs/libpng )
X? ( x11-libs/libX11 )"
-DEPEND="${DEPEND}
- virtual/pkgconfig"
+DEPEND="test? ( ${RDEPEND} )"
-S="${WORKDIR}/${P}"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile-test.patch
+}
src_test() {
cd dlib/test
- emake
+ emake CXX="$(tc-getCXX)" CXXFLAGS="${CXXFLAGS}"
./test --runall || die
}
src_install() {
dodoc dlib/README.txt
- rm -r dlib/{README,LICENSE}.txt dlib/test
+ rm -r dlib/{README,LICENSE}.txt dlib/test || die
insinto /usr/include
doins -r dlib
use doc && dohtml docs/*
diff --git a/sci-libs/dlib/files/dlib-17.48-makefile-test.patch b/sci-libs/dlib/files/dlib-17.48-makefile-test.patch
new file mode 100644
index 000000000000..81aed4431954
--- /dev/null
+++ b/sci-libs/dlib/files/dlib-17.48-makefile-test.patch
@@ -0,0 +1,35 @@
+--- dlib/test/makefile.orig 2012-12-10 23:56:00.000000000 +0000
++++ dlib/test/makefile 2012-12-10 23:59:07.000000000 +0000
+@@ -5,14 +5,15 @@
+ TARGET = test
+
+ # these are the compile time flags passed to gcc
+-CFLAGS = -ggdb -DDEBUG -DDLIB_NO_GUI_SUPPORT -I ../.. -Wall
++CPPFLAGS := -DDEBUG -DDLIB_NO_GUI_SUPPORT -I../..
++CXXFLAGS := -ggdb -Wall
+
+ # These are the link time flags passed to gcc
+ LFLAGS = -lpthread -lnsl
+
+ # The name of the compiler. If you only have one version of
+ # gcc installed then you probably want to change this to just g++
+-CC = nice g++
++CXX := nice g++
+
+ ####################################################
+ ####################################################
+@@ -146,13 +147,9 @@
+
+ $(TARGET): $(OBJ)
+ @echo Linking $@
+- @$(CC) $(OBJ) $(LFLAGS) -o $@
++ @$(CXX) $(LDFLAGS) $(OBJ) $(LFLAGS) -o $@
+ @echo Build Complete
+
+-.cpp.o: $<
+- @echo Compiling $<
+- @$(CC) -c $(CFLAGS) $< -o $@
+-
+ clean:
+ @rm -f $(OBJ) $(TARGET)
+ @echo All object files and binaries removed