summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-07-03 20:12:55 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-07-03 20:12:55 +0000
commit9976b7575c92f35d2af0e4411ab34f9a23aa82be (patch)
treed3cacbd087ee4b31c0bf4fb3bc787b428c11675b /sci-libs
parentstable on ppc64 (diff)
downloadgentoo-2-9976b7575c92f35d2af0e4411ab34f9a23aa82be.tar.gz
gentoo-2-9976b7575c92f35d2af0e4411ab34f9a23aa82be.tar.bz2
gentoo-2-9976b7575c92f35d2af0e4411ab34f9a23aa82be.zip
update to latest release (fixes bug 182306)
(Portage version: 2.1.3_rc6)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/ChangeLog9
-rw-r--r--sci-libs/gdal/files/digest-gdal-1.4.23
-rw-r--r--sci-libs/gdal/files/gdal-1.4.2-datadir.patch11
-rw-r--r--sci-libs/gdal/files/gdal-1.4.2-ruby-install.patch24
-rw-r--r--sci-libs/gdal/gdal-1.4.2.ebuild145
5 files changed, 191 insertions, 1 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 866dfd7c8bc5..a0829d813fc9 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.31 2007/01/05 09:08:46 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.32 2007/07/03 20:12:55 nerdboy Exp $
+
+*gdal-1.4.2 (02 Jul 2007)
+
+ 02 Jul 2007; Steve Arnold <nerdboy@gentoo.org>
+ +files/gdal-1.4.2-datadir.patch, +files/gdal-1.4.2-ruby-install.patch,
+ +gdal-1.4.2.ebuild:
+ Update to latest release (fixes bug 182306). Test away...
05 Jan 2007; Diego Pettenò <flameeyes@gentoo.org> gdal-1.2.6-r4.ebuild,
gdal-1.3.0-r1.ebuild, gdal-1.3.1.ebuild, gdal-1.3.2.ebuild:
diff --git a/sci-libs/gdal/files/digest-gdal-1.4.2 b/sci-libs/gdal/files/digest-gdal-1.4.2
new file mode 100644
index 000000000000..ed44e919cd42
--- /dev/null
+++ b/sci-libs/gdal/files/digest-gdal-1.4.2
@@ -0,0 +1,3 @@
+MD5 dedf5ff6a766e85b9a2b5c54c1c59221 gdal-1.4.2.tar.gz 7457778
+RMD160 d4e2c09b4ec4ef3eb6a4da0e832168ef89878860 gdal-1.4.2.tar.gz 7457778
+SHA256 ee6e74cb80f47929fcfe8426fb024c2b195d237612be4d9a0795e9e353f588ee gdal-1.4.2.tar.gz 7457778
diff --git a/sci-libs/gdal/files/gdal-1.4.2-datadir.patch b/sci-libs/gdal/files/gdal-1.4.2-datadir.patch
new file mode 100644
index 000000000000..95cd058256a1
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.4.2-datadir.patch
@@ -0,0 +1,11 @@
+--- GDALmake.opt.in.orig 2006-05-21 14:59:21.000000000 -0700
++++ GDALmake.opt.in 2006-05-21 15:13:22.000000000 -0700
+@@ -54,7 +54,7 @@
+ exec_prefix = @exec_prefix@
+ INST_PREFIX = @exec_prefix@
+ INST_INCLUDE = @includedir@
+-INST_DATA = @datadir@
++INST_DATA = @datadir@/gdal
+ INST_LIB = @libdir@
+ INST_BIN = @bindir@
+ INST_PYMOD = @pymoddir@
diff --git a/sci-libs/gdal/files/gdal-1.4.2-ruby-install.patch b/sci-libs/gdal/files/gdal-1.4.2-ruby-install.patch
new file mode 100644
index 000000000000..3aea3e26ea48
--- /dev/null
+++ b/sci-libs/gdal/files/gdal-1.4.2-ruby-install.patch
@@ -0,0 +1,24 @@
+--- swig/ruby/RubyMakefile.mk.orig 2007-07-01 18:15:18.000000000 -0700
++++ swig/ruby/RubyMakefile.mk 2007-07-01 18:18:47.000000000 -0700
+@@ -22,7 +22,7 @@
+ RUBY_LIB_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['libdir']")
+ RUBY_SO_NAME := $(shell ruby -rrbconfig -e "puts Config::CONFIG['RUBY_SO_NAME']")
+ RUBY_EXTENSIONS_DIR := $(shell ruby -rrbconfig -e "puts Config::CONFIG['sitearchdir']")
+-INSTALL_DIR := $(RUBY_EXTENSIONS_DIR)/gdal
++INSTALL_DIR := $(DESTDIR)$(RUBY_EXTENSIONS_DIR)/gdal
+
+ RUBY_INCLUDE = -I$(RUBY_INCLUDE_DIR)
+ LDFLAGS += -shared -L$(RUBY_LIB_DIR)
+@@ -39,10 +39,10 @@
+ rm -frd $(INSTALL_DIR)
+
+ $(INSTALL_DIR):
+- mkdir -p $(DESTDIR)$(INSTALL_DIR)
++ mkdir -p $(INSTALL_DIR)
+
+ install: $(INSTALL_DIR)
+- $(INSTALL) $(RUBY_MODULES) $(DESTDIR)$(INSTALL_DIR)
++ $(INSTALL) $(RUBY_MODULES) $(INSTALL_DIR)
+
+ $(RUBY_MODULES): %.so: %_wrap.o
+ $(LD) $(LDFLAGS) $(LIBS) $(GDAL_SLIB_LINK) $(RUBY_LIB) $< -o $@
diff --git a/sci-libs/gdal/gdal-1.4.2.ebuild b/sci-libs/gdal/gdal-1.4.2.ebuild
new file mode 100644
index 000000000000..2823886a107a
--- /dev/null
+++ b/sci-libs/gdal/gdal-1.4.2.ebuild
@@ -0,0 +1,145 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.4.2.ebuild,v 1.1 2007/07/03 20:12:55 nerdboy Exp $
+
+inherit eutils libtool distutils toolchain-funcs
+
+IUSE="jpeg png geos gif jpeg2k netcdf hdf hdf5 python ruby postgres \
+ odbc sqlite ogdi fits gml doc debug"
+
+DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
+HOMEPAGE="http://www.gdal.org/"
+SRC_URI="http://download.osgeo.org/gdal/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+# need to get these arches updated on several libs first
+#KEYWORDS="~alpha ~hppa"
+
+DEPEND=">=sys-libs/zlib-1.1.4
+ >=media-libs/tiff-3.7.0
+ sci-libs/libgeotiff
+ jpeg? ( media-libs/jpeg )
+ gif? ( media-libs/giflib )
+ png? ( media-libs/libpng )
+ python? ( dev-lang/python )
+ ruby? ( >=dev-lang/ruby-1.8.4.20060226
+ >=dev-lang/swig-1.3.28 )
+ fits? ( sci-libs/cfitsio )
+ ogdi? ( sci-libs/ogdi )
+ gml? ( dev-libs/xerces-c )
+ hdf5? ( >=sci-libs/hdf5-1.6.4 )
+ postgres? ( dev-db/postgresql )
+ || (
+ netcdf? ( sci-libs/netcdf )
+ hdf? ( sci-libs/hdf )
+ )
+ jpeg2k? ( media-libs/jasper )
+ odbc? ( dev-db/unixODBC )
+ geos? ( >=sci-libs/geos-2.2.1 )
+ sqlite? ( >=dev-db/sqlite-3 )
+ doc? ( app-doc/doxygen )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-datadir.patch || die "epatch failed"
+ epatch ${FILESDIR}/${P}-ruby-install.patch || die "epatch failed"
+
+ elibtoolize --patch-only
+
+ if useq netcdf && useq hdf; then
+ einfo "Checking if HDF4 is compiled with szip..."
+ if built_with_use sci-libs/hdf szip ; then
+ einfo "Found HDF4 compiled with szip. Nice."
+ else
+ ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
+ einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
+ die "HDF4 not merged with szip use flag"
+ fi
+ fi
+}
+
+src_compile() {
+ distutils_python_version
+
+ pkg_conf="--enable-static=no --enable-shared=yes --with-pic \
+ --with-libgrass=no"
+
+ use_conf="$(use_with jpeg) $(use_with png) $(use_with ruby) \
+ $(use_with postgres pg) $(use_with fits cfitsio) \
+ $(use_with netcdf) $(use_with hdf hdf4) $(use_with geos) \
+ $(use_with sqlite) $(use_with jpeg2k jasper) $(use_with odbc) \
+ $(use_with gml xerces) $(use_with hdf5) $(use_with mysql)"
+
+ # It can't find this
+ if useq ogdi ; then
+ use_conf="--with-ogdi=/usr/$(get_libdir) ${use_conf}"
+ fi
+
+ if useq mysql ; then
+ use_conf="--with-mysql=/usr/bin/mysql_config ${use_conf}"
+ fi
+
+ if useq gif ; then
+ use_conf="--with-gif=internal ${use_conf}"
+ else
+ use_conf="--with-gif=no ${use_conf}"
+ fi
+
+ if useq debug ; then
+ export CFG=debug
+ fi
+
+ if useq python ; then
+ use_conf="--with-pymoddir=/usr/$(get_libdir)/python${PYVER}/site-packages \
+ ${use_conf}"
+ else
+ use_conf="--with-python=no ${use_conf}"
+ fi
+
+ # Fix doc path just in case
+ sed -i -e "s:@exec_prefix@/doc:/usr/share/doc/${PF}/html:g" GDALmake.opt.in
+
+ econf ${pkg_conf} ${use_conf} || die "econf failed"
+ # parallel makes fail on the ogr stuff (C++, what can I say?)
+ # also failing with gcc4 in libcsf
+ make || die "make failed"
+ if useq ruby ; then
+ cd ${S}/swig
+ make build || die "make ruby failed"
+ cd ${S}
+ fi
+ if useq doc ; then
+ make docs || die "make docs failed"
+ fi
+}
+
+src_install() {
+ # einstall causes sandbox violations on /usr/lib/libgdal.so
+ make DESTDIR=${D} install || die "make install failed"
+ dodoc Doxyfile.man Doxyfile HOWTO-RELEASE NEWS
+ if useq doc ; then
+ dohtml html/* || die "install html failed"
+ docinto ogr
+ dohtml ogr/html/* || die "install ogr html failed"
+ fi
+}
+
+pkg_postinst() {
+ einfo "GDAL is most useful with full graphics support enabled via various"
+ einfo "USE flags: png, jpeg, gif, jpeg2k, etc. Also python, fits, ogdi,"
+ einfo "geos, and support for either netcdf or HDF4 is available, as well as"
+ einfo "grass, and mysql, sqlite, or postgres (grass support requires grass 6"
+ einfo "and the new gdal-grass ebuild). HDF5 support is now included."
+ ewarn
+ einfo "Note: tiff and geotiff are now hard depends, so no USE flags."
+ einfo "Also, this package will check for netcdf before hdf, so if you"
+ einfo "prefer hdf, please emerge hdf with USE=szip prior to emerging"
+ einfo "gdal. Detailed API docs require doxygen (man pages are free)."
+ einfo ""
+ einfo "Check available image and data formats after building with"
+ einfo "gdalinfo and ogrinfo (using the --formats switch)."
+}