summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-01-10 00:34:41 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-01-10 00:34:41 +0000
commit877deae048bedc56575873d43e4979ab5d639dc1 (patch)
tree3cf3d9d5f94a91ffaad24a598a6eb98349f667ac /sci-libs
parentAdd some custom init.d options by Hubert MERCIER #118399. (diff)
downloadgentoo-2-877deae048bedc56575873d43e4979ab5d639dc1.tar.gz
gentoo-2-877deae048bedc56575873d43e4979ab5d639dc1.tar.bz2
gentoo-2-877deae048bedc56575873d43e4979ab5d639dc1.zip
Bump to the latest development snapshot.
(Portage version: 2.1_pre3-r1)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog8
-rw-r--r--sci-libs/blas-atlas/Manifest4
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild168
-rw-r--r--sci-libs/blas-atlas/files/digest-blas-atlas-3.7.112
4 files changed, 180 insertions, 2 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index c480754b5885..0dca70be2e81 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.9 2006/01/09 19:54:40 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.10 2006/01/10 00:34:41 markusle Exp $
+
+*blas-atlas-3.7.11 (09 Jan 2006)
+
+ 09 Jan 2006; Markus Dittrich <markusle@gentoo.org>
+ +blas-atlas-3.7.11.ebuild:
+ Bump to the latest development snapshot.
*blas-atlas-3.6.0-r1 (09 Jan 2006)
diff --git a/sci-libs/blas-atlas/Manifest b/sci-libs/blas-atlas/Manifest
index e212c15b2049..49c25f96662c 100644
--- a/sci-libs/blas-atlas/Manifest
+++ b/sci-libs/blas-atlas/Manifest
@@ -1,12 +1,14 @@
-MD5 8ec351e220a0df458a7ce5f14bdedcc9 ChangeLog 4399
+MD5 13af25055d986174334ca29e51e3a0ed ChangeLog 4559
MD5 defd5bd5a227cd968970790598a7ee98 blas-atlas-3.6.0-r1.ebuild 4271
MD5 a03adf0e7bb8af668f84c7fc7b2b9760 blas-atlas-3.6.0.ebuild 4255
MD5 8c1cc8c544ae94b121fba5560e828448 blas-atlas-3.7.10.ebuild 4167
+MD5 a67106636ad85d5113ba072babd83ac4 blas-atlas-3.7.11.ebuild 4343
MD5 73bb69e091e5629e3d47ec813d560223 files/c-ATLAS 497
MD5 869c65bd1672b6bea4f03520e7e1cdf9 files/c-threaded-ATLAS 563
MD5 c1c57e922c1763ddde357504442e94c4 files/digest-blas-atlas-3.6.0 139
MD5 e49de689884ec7c24e160930c9080466 files/digest-blas-atlas-3.6.0-r1 141
MD5 e092f2baac7a6c4e34591acb77552017 files/digest-blas-atlas-3.7.10 140
+MD5 a6af76cda41e7c5e32e14e29d6e186e1 files/digest-blas-atlas-3.7.11 142
MD5 646c8df3efa24d6573a870dbb0f5fc8d files/f77-ATLAS 457
MD5 c0a79db6ec6fb95a56ce677107f08c01 files/f77-threaded-ATLAS 492
MD5 e362a664ac2e543545706b85664af921 files/unbuffered.patch 497
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
new file mode 100644
index 000000000000..6fefcf291d96
--- /dev/null
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
@@ -0,0 +1,168 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild,v 1.1 2006/01/10 00:34:41 markusle Exp $
+
+inherit eutils toolchain-funcs fortran
+
+DESCRIPTION="Automatically Tuned Linear Algebra Software BLAS implementation"
+HOMEPAGE="http://math-atlas.sourceforge.net/"
+MY_PN=${PN/blas-/}
+MY_PV=3.6.0
+SRC_URI="mirror://sourceforge/math-atlas/${MY_PN}${PV}.tar.bz2
+ mirror://gentoo/atlas${MY_PV}-shared-libs.1.patch.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~ppc ~ppc64 ~sparc ~alpha"
+IUSE="doc"
+
+DEPEND="app-admin/eselect
+ >=sys-devel/libtool-1.5"
+RDEPEND="app-admin/eselect"
+PROVIDE="virtual/blas"
+
+
+S="${WORKDIR}/ATLAS"
+RPATH="${DESTTREE}/$(get_libdir)/blas"
+FORTRAN="g77"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}"/unbuffered.patch
+ epatch "${DISTDIR}"/atlas3.6.0-shared-libs.1.patch.bz2
+ sed -i \
+ -e "s:ASM:ASM VOLATILE:" \
+ include/contrib/camm_dpa.h \
+ || die "sed failed to fix clobbering"
+
+ cp "${FILESDIR}"/war "${S}"
+ chmod a+x "${S}"/war
+}
+
+atlas_fail() {
+ eerror
+ eerror "ATLAS auto-config failed."
+ eerror "Please run 'interactive=1 emerge blas-atlas' to configure manually."
+ eerror
+ die "ATLAS auto-config failed."
+}
+
+# Added to allow compilation on sparc architecture. The default CCFLAG0
+# and MMFLAGS are *bad*.
+# Danny van Dyk <kugelfang@gentoo.org> 2004/07/02
+#
+reconfigure() {
+ case "`uname -p`" in
+ "sun4m")
+ MY_CCFLAGS="-O3 -mcpu=v8"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=v8"
+ MY_LDFLAGS=""
+ ;;
+ "sun4u")
+ MY_CCFLAGS="-O3 -mcpu=ultrasparc"
+ MY_CXXFLAGS="${MY_CCFLAGS}"
+ MY_MMFLAGS="-O -mcpu=ultrasparc"
+ MY_LDFLAGS=""
+ ;;
+ *)
+ MY_CCFLAGS="${CFLAGS}"
+ MY_CXXFLAGS="${CXXFLAGS}"
+ MY_MMFLAGS="${CFLAGS}"
+ MY_LDFLAGS="${LDFLAGS}"
+ ;;
+ esac
+
+ MY_FILE="`find -name Make.Linux*`"
+
+ sed -i -e "s/CCFLAG0 =.*/CCFLAG0 = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CCFLAGS =.*/CCFLAGS = \$(CDEFS) ${MY_CCFLAGS}/" \
+ -e "s/CLINKFLAGS =.*/CLINKFLAGS =\$(CDEFS) ${MY_LDFLAGS}/" \
+ -e "s/XCCFLAGS =.*/XCCFLAGS =\$(CDEFS) ${MY_CXXFLAGS}/" \
+ -e "s/MMFLAGS =.*/MMFLAGS = ${MY_MMFLAGS}/" \
+ ${MY_FILE} || die "sed didnt complete"
+}
+
+src_compile() {
+ if [ -n "${interactive}" ]
+ then
+ echo "${interactive}"
+ make config CC="$(tc-getCC) -DUSE_LIBTOOL -DINTERACTIVE" || die
+ else
+ # Use ATLAS defaults for all questions:
+ (echo | make config CC="$(tc-getCC) -DUSE_LIBTOOL") || atlas_fail
+ fi
+
+ reconfigure
+
+ TMPSTR=$(ls Make.Linux*)
+ ATLAS_ARCH=${TMPSTR#'Make.'}
+
+ make install arch=${ATLAS_ARCH} || \
+ die "Failed to install blas-atlas"
+
+ make shared-strip arch=${ATLAS_ARCH} RPATH=${RPATH}/atlas || \
+ die "Failed to build shared libraries"
+
+ # Build shared versions of the threaded libs.
+ # ATLAS only compiles threaded libs on multiprocessor machines.
+ if [ -d gentoo/libptf77blas.a ]
+ then
+ make ptshared-strip \
+ arch=${ATLAS_ARCH} RPATH=${RPATH}/threaded-atlas || die
+ fi
+}
+
+src_install () {
+ dodir "${RPATH}"/atlas
+ cd "${S}"/gentoo/libs
+ cp -P libatlas* "${D}/${DESTTREE}/$(get_libdir)" || \
+ die "Failed to install libatlas"
+ cp -P *blas* "${D}/${RPATH}"/atlas || \
+ die "Failed to install blas/cblas"
+
+ insinto "${RPATH}"
+ doins "${FILESDIR}"/c-ATLAS "${FILESDIR}"/f77-ATLAS
+
+ if [ -d "${S}"/gentoo/threaded-libs ]
+ then
+ dodir "${RPATH}"/threaded-atlas
+ cd "${S}"/gentoo/threaded-libs
+ cp -P * "${D}/${RPATH}"/threaded-atlas || \
+ die "Failed to install threaded atlas"
+ doins "${FILESDIR}"/c-threaded-ATLAS \
+ "${FILESDIR}"/f77-threaded-ATLAS
+ fi
+
+ insinto "${DESTTREE}"/include/atlas
+ doins "${S}"/include/cblas.h "${S}"/include/atlas_misc.h
+ doins "${S}"/include/atlas_enum.h
+
+ # These headers contain the architecture-specific
+ # optimizations determined by ATLAS. The atlas-lapack build
+ # is much shorter if they are available, so save them:
+ doins "${S}/include/${ATLAS_ARCH}"/*.h
+
+ #some docs
+ cd "${S}"
+ dodoc README doc/{AtlasCredits.txt,ChangeLog}
+ use doc && dodoc doc/*.ps
+}
+
+pkg_postinst() {
+ if [ -d "${RPATH}"/threaded-atlas ]
+ then
+ "${DESTTREE}"/bin/blas-config threaded-ATLAS
+ else
+ "${DESTTREE}"/bin/blas-config ATLAS
+ fi
+
+ einfo
+ einfo "Fortran users link using -lblas"
+ einfo
+ einfo "C users compile against the header /usr/include/atlas/cblas.h and"
+ einfo "link using -lcblas"
+ einfo
+}
diff --git a/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.11 b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.11
new file mode 100644
index 000000000000..cebee8fc9d23
--- /dev/null
+++ b/sci-libs/blas-atlas/files/digest-blas-atlas-3.7.11
@@ -0,0 +1,2 @@
+MD5 d2940721d6592f43a5d2e7740d13076d atlas3.6.0-shared-libs.1.patch.bz2 5148
+MD5 ccde41dd4f41c47e16ebfa8e6dfd1117 atlas3.7.11.tar.bz2 2032724