summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-05-29 00:15:37 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-05-29 00:15:37 +0000
commit73f7cd492831591bea2f40f7b332839119060770 (patch)
tree9862a6c46b5714f0d96e4be2cb61523a9e0599d6 /sci-libs
parentBump patchset with patch to fix bug #134666. Thanks to cuicui for reporting. (diff)
downloadgentoo-2-73f7cd492831591bea2f40f7b332839119060770.tar.gz
gentoo-2-73f7cd492831591bea2f40f7b332839119060770.tar.bz2
gentoo-2-73f7cd492831591bea2f40f7b332839119060770.zip
Bump to autotool the package, which makes the build work much better in parallel and with gcc4.
(Portage version: 2.1_rc1-r3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cblas-reference/ChangeLog10
-rw-r--r--sci-libs/cblas-reference/cblas-reference-20030223-r1.ebuild54
-rw-r--r--sci-libs/cblas-reference/files/cblas-reference-20030223-autotool.patch407
-rw-r--r--sci-libs/cblas-reference/files/digest-cblas-reference-20030223-r13
4 files changed, 473 insertions, 1 deletions
diff --git a/sci-libs/cblas-reference/ChangeLog b/sci-libs/cblas-reference/ChangeLog
index 8cbb0a5b9d0b..d7748ee1b35e 100644
--- a/sci-libs/cblas-reference/ChangeLog
+++ b/sci-libs/cblas-reference/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/cblas-reference
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cblas-reference/ChangeLog,v 1.4 2006/05/17 00:29:04 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cblas-reference/ChangeLog,v 1.5 2006/05/29 00:15:37 spyderous Exp $
+
+*cblas-reference-20030223-r1 (29 May 2006)
+
+ 29 May 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/cblas-reference-20030223-autotool.patch,
+ +cblas-reference-20030223-r1.ebuild:
+ Bump to autotool the package, which makes the build work much better in
+ parallel and with gcc4.
17 May 2006; Donnie Berkholz <spyderous@gentoo.org>;
cblas-reference-20030223.ebuild:
diff --git a/sci-libs/cblas-reference/cblas-reference-20030223-r1.ebuild b/sci-libs/cblas-reference/cblas-reference-20030223-r1.ebuild
new file mode 100644
index 000000000000..591947dbcf76
--- /dev/null
+++ b/sci-libs/cblas-reference/cblas-reference-20030223-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cblas-reference/cblas-reference-20030223-r1.ebuild,v 1.1 2006/05/29 00:15:37 spyderous Exp $
+
+inherit autotools eutils fortran multilib
+
+MyPN="${PN/-reference/}"
+
+DESCRIPTION="C interface to the BLAS"
+LICENSE="public-domain"
+HOMEPAGE="http://www.netlib.org/blas/"
+SRC_URI="http://www.netlib.org/blas/blast-forum/${MyPN}.tgz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="virtual/blas
+ sci-libs/blas-config"
+DEPEND="${RDEPEND}"
+
+FORTRAN="gfortran g77 ifc"
+
+S="${WORKDIR}/CBLAS"
+
+src_unpack() {
+ unpack ${A}
+ # Must patch before changing to S. Patches that create new files
+ # will happily apply anywhere.
+ epatch "${FILESDIR}"/${P}-autotool.patch
+ cd "${S}"
+ eautoreconf
+}
+
+src_install() {
+ TOP_PATH="${DESTTREE}/$(get_libdir)/blas"
+ RPATH="${TOP_PATH}/reference"
+
+ make DESTDIR="${D}" install || die "install failed"
+
+ # Fix for switching
+ dodir ${RPATH}
+ mv ${D}/usr/$(get_libdir)/libcblas* ${D}/${RPATH}
+
+ dodoc "${S}"/README || die "failed to install docs"
+
+ insinto "${TOP_PATH}"
+ doins "${FILESDIR}"/c-reference || \
+ die "failed to install blas-config file"
+}
+
+pkg_postinst() {
+ blas-config c-reference
+}
diff --git a/sci-libs/cblas-reference/files/cblas-reference-20030223-autotool.patch b/sci-libs/cblas-reference/files/cblas-reference-20030223-autotool.patch
new file mode 100644
index 000000000000..cf8b25c7aeaf
--- /dev/null
+++ b/sci-libs/cblas-reference/files/cblas-reference-20030223-autotool.patch
@@ -0,0 +1,407 @@
+diff -urN CBLAS.orig/configure.ac CBLAS/configure.ac
+--- CBLAS.orig/configure.ac 1969-12-31 16:00:00.000000000 -0800
++++ CBLAS/configure.ac 2006-05-17 00:06:17.000000000 -0700
+@@ -0,0 +1,65 @@
++# -*- Autoconf -*-
++# Process this file with autoconf to produce a configure script.
++
++AC_PREREQ(2.59)
++AC_INIT(cblas, 20030223, lapack@cs.utk.edu)
++AC_CONFIG_SRCDIR([cblas_example2.c])
++AC_CONFIG_HEADER([config.h])
++AM_INIT_AUTOMAKE([foreign])
++
++# Checks for programs.
++AC_PROG_CC
++AC_PROG_F77
++AC_PROG_LIBTOOL
++AC_PROG_MAKE_SET
++
++# Needed when mixing Fortran and C in the same program/library
++AC_F77_LIBRARY_LDFLAGS
++
++AC_ARG_ENABLE(single-real, AS_HELP_STRING([--disable-single-real],
++ [Enable single real precision (default: enabled)]),
++ [S=$enableval], [S=yes SINGLE=yes])
++
++AC_ARG_ENABLE(double-real, AS_HELP_STRING([--disable-double-real],
++ [Enable double real precision (default: enabled)]),
++ [D=$enableval], [D=yes])
++
++AC_ARG_ENABLE(single-complex, AS_HELP_STRING([--disable-single-complex],
++ [Enable single complex precision (default: enabled)]),
++ [C=$enableval], [C=yes SINGLE=yes])
++
++AC_ARG_ENABLE(double-complex, AS_HELP_STRING([--disable-double-complex],
++ [Enable double complex precision (default: enabled)]),
++ [Z=$enableval], [Z=yes])
++
++AC_ARG_ENABLE(examples, AS_HELP_STRING([--enable-examples],
++ [Build example programs (default: disabled)]),
++ [EXAMPLES=$enableval], [EXAMPLES=no])
++
++AC_ARG_ENABLE(tests, AS_HELP_STRING([--enable-tests],
++ [Build test programs (default: disabled)]),
++ [DO_TEST=$enableval], [DO_TEST=no])
++
++if test "x$S" = "xno" \
++ && test "x$D" = "xno" \
++ && test "x$C" = "xno" \
++ && test "x$Z" = "xno"; then
++ AC_MSG_ERROR([You must enable at least one precision!])
++fi
++
++if test "x$DO_TEST" = "xyes"; then
++ TESTING=testing
++fi
++
++AM_CONDITIONAL([SINGLE], [test "x$SINGLE" = "xyes"])
++AM_CONDITIONAL([S], [test "x$S" = "xyes"])
++AM_CONDITIONAL([D], [test "x$D" = "xyes"])
++AM_CONDITIONAL([C], [test "x$C" = "xyes"])
++AM_CONDITIONAL([Z], [test "x$Z" = "xyes"])
++AM_CONDITIONAL([EXAMPLES], [test "x$EXAMPLES" = "xyes"])
++AC_SUBST(TESTING)
++
++AC_CONFIG_FILES([Makefile
++ src/Makefile
++ testing/Makefile])
++AC_OUTPUT
+diff -urN CBLAS.orig/Makefile.am CBLAS/Makefile.am
+--- CBLAS.orig/Makefile.am 1969-12-31 16:00:00.000000000 -0800
++++ CBLAS/Makefile.am 2006-05-17 00:01:22.000000000 -0700
+@@ -0,0 +1,15 @@
++SUBDIRS = src $(TESTING)
++
++if EXAMPLES
++noinst_PROGRAMS = \
++ example1 \
++ example2
++endif
++
++LDADD = -lblas src/libcblas.la
++AM_CFLAGS = -I$(top_srcdir)/src -DADD_
++
++example1_SOURCES = cblas_example1.c
++example2_SOURCES = cblas_example2.c
++
++EXTRA_DIST = README
+diff -urN CBLAS.orig/src/Makefile.am CBLAS/src/Makefile.am
+--- CBLAS.orig/src/Makefile.am 1969-12-31 16:00:00.000000000 -0800
++++ CBLAS/src/Makefile.am 2006-05-16 23:05:41.000000000 -0700
+@@ -0,0 +1,238 @@
++lib_LTLIBRARIES = libcblas.la
++
++AM_CFLAGS = -DADD_
++
++ERRHAND_SOURCES = \
++ cblas_globals.c \
++ cblas_xerbla.c \
++ xerbla.c
++
++if SINGLE
++SINGLE_SOURCES = \
++ cblas_scasum.c \
++ cblas_scnrm2.c \
++ scasumsub.f \
++ scnrm2sub.f
++endif
++
++if S
++SLEV_SOURCES = \
++ isamaxsub.f \
++ sdotsub.f \
++ sdsdotsub.f \
++ snrm2sub.f \
++ sasumsub.f
++
++SLEV1_SOURCES = \
++ cblas_srotg.c \
++ cblas_srotmg.c \
++ cblas_srot.c \
++ cblas_srotm.c \
++ cblas_sswap.c \
++ cblas_sscal.c \
++ cblas_scopy.c \
++ cblas_saxpy.c \
++ cblas_sdot.c \
++ cblas_sdsdot.c \
++ cblas_snrm2.c \
++ cblas_sasum.c \
++ cblas_isamax.c
++
++SLEV2_SOURCES = \
++ cblas_sgemv.c \
++ cblas_sgbmv.c \
++ cblas_sger.c \
++ cblas_ssbmv.c \
++ cblas_sspmv.c \
++ cblas_sspr.c \
++ cblas_sspr2.c \
++ cblas_ssymv.c \
++ cblas_ssyr.c \
++ cblas_ssyr2.c \
++ cblas_stbmv.c \
++ cblas_stbsv.c \
++ cblas_stpmv.c \
++ cblas_stpsv.c \
++ cblas_strmv.c \
++ cblas_strsv.c
++
++SLEV3_SOURCES = \
++ cblas_sgemm.c \
++ cblas_ssymm.c \
++ cblas_ssyrk.c \
++ cblas_ssyr2k.c \
++ cblas_strmm.c \
++ cblas_strsm.c
++endif
++
++if D
++DLEV_SOURCES = \
++ ddotsub.f \
++ dsdotsub.f \
++ dnrm2sub.f \
++ dasumsub.f \
++ idamaxsub.f
++
++DLEV1_SOURCES = \
++ cblas_drotg.c \
++ cblas_drotmg.c \
++ cblas_drot.c \
++ cblas_drotm.c \
++ cblas_dswap.c \
++ cblas_dscal.c \
++ cblas_dcopy.c \
++ cblas_daxpy.c \
++ cblas_ddot.c \
++ cblas_dsdot.c \
++ cblas_dnrm2.c \
++ cblas_dasum.c \
++ cblas_idamax.c
++
++DLEV2_SOURCES = \
++ cblas_dgemv.c \
++ cblas_dgbmv.c \
++ cblas_dger.c \
++ cblas_dsbmv.c \
++ cblas_dspmv.c \
++ cblas_dspr.c \
++ cblas_dspr2.c \
++ cblas_dsymv.c \
++ cblas_dsyr.c \
++ cblas_dsyr2.c \
++ cblas_dtbmv.c \
++ cblas_dtbsv.c \
++ cblas_dtpmv.c \
++ cblas_dtpsv.c \
++ cblas_dtrmv.c \
++ cblas_dtrsv.c
++
++DLEV3_SOURCES = \
++ cblas_dgemm.c \
++ cblas_dsymm.c \
++ cblas_dsyrk.c \
++ cblas_dsyr2k.c \
++ cblas_dtrmm.c \
++ cblas_dtrsm.c
++endif
++
++if C
++CLEV_SOURCES = \
++ cdotcsub.f \
++ cdotusub.f \
++ icamaxsub.f
++
++CLEV1_SOURCES = \
++ cblas_cswap.c \
++ cblas_cscal.c \
++ cblas_csscal.c \
++ cblas_ccopy.c \
++ cblas_caxpy.c \
++ cblas_cdotu_sub.c \
++ cblas_cdotc_sub.c \
++ cblas_icamax.c
++
++CLEV2_SOURCES = \
++ cblas_cgemv.c \
++ cblas_cgbmv.c \
++ cblas_chemv.c \
++ cblas_chbmv.c \
++ cblas_chpmv.c \
++ cblas_ctrmv.c \
++ cblas_ctbmv.c \
++ cblas_ctpmv.c \
++ cblas_ctrsv.c \
++ cblas_ctbsv.c \
++ cblas_ctpsv.c \
++ cblas_cgeru.c \
++ cblas_cgerc.c \
++ cblas_cher.c \
++ cblas_cher2.c \
++ cblas_chpr.c \
++ cblas_chpr2.c
++
++CLEV3_SOURCES = \
++ cblas_cgemm.c \
++ cblas_csymm.c \
++ cblas_chemm.c \
++ cblas_cherk.c \
++ cblas_cher2k.c \
++ cblas_ctrmm.c \
++ cblas_ctrsm.c \
++ cblas_csyrk.c \
++ cblas_csyr2k.c
++endif
++
++if Z
++ZLEV_SOURCES = \
++ zdotcsub.f \
++ zdotusub.f \
++ dzasumsub.f \
++ dznrm2sub.f \
++ izamaxsub.f
++
++ZLEV1_SOURCES = \
++ cblas_zswap.c \
++ cblas_zscal.c \
++ cblas_zdscal.c \
++ cblas_zcopy.c \
++ cblas_zaxpy.c \
++ cblas_zdotu_sub.c \
++ cblas_zdotc_sub.c \
++ cblas_dznrm2.c \
++ cblas_dzasum.c \
++ cblas_izamax.c
++
++ZLEV2_SOURCES = \
++ cblas_zgemv.c \
++ cblas_zgbmv.c \
++ cblas_zhemv.c \
++ cblas_zhbmv.c \
++ cblas_zhpmv.c \
++ cblas_ztrmv.c \
++ cblas_ztbmv.c \
++ cblas_ztpmv.c \
++ cblas_ztrsv.c \
++ cblas_ztbsv.c \
++ cblas_ztpsv.c \
++ cblas_zgeru.c \
++ cblas_zgerc.c \
++ cblas_zher.c \
++ cblas_zher2.c \
++ cblas_zhpr.c \
++ cblas_zhpr2.c
++
++ZLEV3_SOURCES = \
++ cblas_zgemm.c \
++ cblas_zsymm.c \
++ cblas_zhemm.c \
++ cblas_zherk.c \
++ cblas_zher2k.c \
++ cblas_ztrmm.c \
++ cblas_ztrsm.c \
++ cblas_zsyrk.c \
++ cblas_zsyr2k.c
++endif
++
++libcblas_la_SOURCES = \
++ cblas_f77.h \
++ cblas.h \
++ $(ERRHAND_SOURCES) \
++ $(SINGLE_SOURCES) \
++ $(SLEV_SOURCES) \
++ $(DLEV_SOURCES) \
++ $(CLEV_SOURCES) \
++ $(ZLEV_SOURCES) \
++ $(SLEV1_SOURCES) \
++ $(DLEV1_SOURCES) \
++ $(CLEV1_SOURCES) \
++ $(ZLEV1_SOURCES) \
++ $(SLEV2_SOURCES) \
++ $(DLEV2_SOURCES) \
++ $(CLEV2_SOURCES) \
++ $(ZLEV2_SOURCES) \
++ $(SLEV3_SOURCES) \
++ $(DLEV3_SOURCES) \
++ $(CLEV3_SOURCES) \
++ $(ZLEV3_SOURCES)
++
++libcblas_la_LIBADD = $(FLIBS)
+diff -urN CBLAS.orig/testing/Makefile.am CBLAS/testing/Makefile.am
+--- CBLAS.orig/testing/Makefile.am 1969-12-31 16:00:00.000000000 -0800
++++ CBLAS/testing/Makefile.am 2006-05-16 23:59:08.000000000 -0700
+@@ -0,0 +1,73 @@
++noinst_PROGRAMS = \
++ xscblat1 \
++ xscblat2 \
++ xscblat3 \
++ xdcblat1 \
++ xdcblat2 \
++ xdcblat3 \
++ xccblat1 \
++ xccblat2 \
++ xccblat3 \
++ xzcblat1 \
++ xzcblat2 \
++ xzcblat3
++
++LDADD = -lblas $(top_builddir)/src/libcblas.la $(FLIBS)
++AM_CFLAGS = -I$(top_srcdir)/src -DADD_
++
++AUX_SOURCES = \
++ auxiliary.c \
++ c_xerbla.c
++
++xscblat1_SOURCES = \
++ c_sblas1.c \
++ c_sblat1.f
++xscblat2_SOURCES = \
++ c_sblas2.c \
++ c_s2chke.c \
++ c_sblat2.f \
++ $(AUX_SOURCES)
++xscblat3_SOURCES = \
++ c_sblas3.c \
++ c_s3chke.c \
++ c_sblat3.f \
++ $(AUX_SOURCES)
++xdcblat1_SOURCES = \
++ c_dblas1.c \
++ c_dblat1.f
++xdcblat2_SOURCES = \
++ c_dblas2.c \
++ c_d2chke.c \
++ c_dblat2.f \
++ $(AUX_SOURCES)
++xdcblat3_SOURCES = \
++ c_dblas3.c \
++ c_d3chke.c \
++ c_dblat3.f \
++ $(AUX_SOURCES)
++xccblat1_SOURCES = \
++ c_cblas1.c \
++ c_cblat1.f
++xccblat2_SOURCES = \
++ c_cblas2.c \
++ c_c2chke.c \
++ c_cblat2.f \
++ $(AUX_SOURCES)
++xccblat3_SOURCES = \
++ c_cblas3.c \
++ c_c3chke.c \
++ c_cblat3.f \
++ $(AUX_SOURCES)
++xzcblat1_SOURCES = \
++ c_zblas1.c \
++ c_zblat1.f
++xzcblat2_SOURCES = \
++ c_zblas2.c \
++ c_z2chke.c \
++ c_zblat2.f \
++ $(AUX_SOURCES)
++xzcblat3_SOURCES = \
++ c_zblas3.c \
++ c_z3chke.c \
++ c_zblat3.f \
++ $(AUX_SOURCES)
diff --git a/sci-libs/cblas-reference/files/digest-cblas-reference-20030223-r1 b/sci-libs/cblas-reference/files/digest-cblas-reference-20030223-r1
new file mode 100644
index 000000000000..823a069b1666
--- /dev/null
+++ b/sci-libs/cblas-reference/files/digest-cblas-reference-20030223-r1
@@ -0,0 +1,3 @@
+MD5 716329646ac933592a7cbdbeae9d3d06 cblas.tgz 197694
+RMD160 77bd5111659f55540c72f9fcd9277d97bd1ea33b cblas.tgz 197694
+SHA256 9b49d7177fda62b6141bf2ca29e475e86f0b12d8f72e0b944058d02b439dd52a cblas.tgz 197694