summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2014-08-31 23:37:54 +0000
committerChristoph Junghans <ottxor@gentoo.org>2014-08-31 23:37:54 +0000
commit6092a90909abf7bfbf982489b3d5c3b268f304fe (patch)
tree3fa54f7eff98f66a6a0eb6cdebeb088a9daa1588 /sci-libs
parentEAPI=5. Consolidate code for the live ebuild. (diff)
downloadgentoo-2-6092a90909abf7bfbf982489b3d5c3b268f304fe.tar.gz
gentoo-2-6092a90909abf7bfbf982489b3d5c3b268f304fe.tar.bz2
gentoo-2-6092a90909abf7bfbf982489b3d5c3b268f304fe.zip
version bump
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key C2000586)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/votca-tools/ChangeLog10
-rw-r--r--sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch24
-rw-r--r--sci-libs/votca-tools/votca-tools-1.2.4.ebuild (renamed from sci-libs/votca-tools/votca-tools-1.2.3-r3.ebuild)28
3 files changed, 14 insertions, 48 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index 608db6733e3c..629e9a41cffd 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/votca-tools
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.23 2013/07/02 14:15:12 ottxor Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.24 2014/08/31 23:37:54 ottxor Exp $
+
+*votca-tools-1.2.4 (31 Aug 2014)
+
+ 31 Aug 2014; Christoph Junghans <ottxor@gentoo.org> +votca-tools-1.2.4.ebuild,
+ -files/votca-tools-1.2.3-boost-1.53.patch, -votca-tools-1.2.3-r3.ebuild:
+ version bump
02 Jul 2013; Christoph Junghans <ottxor@gentoo.org>
votca-tools-1.2.3-r3.ebuild:
diff --git a/sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch b/sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch
deleted file mode 100644
index 4aa7adbf5641..000000000000
--- a/sci-libs/votca-tools/files/votca-tools-1.2.3-boost-1.53.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-# HG changeset patch
-# User Victor Ruehle <ruehle@votca.org>
-# Date 1359258783 25200
-# Branch stable
-# Node ID f26d7ee778d666babe7f58ae3770b4f3d997aa99
-# Parent d10dec78492a78ad6709e686416615fc8b43c896
-fix build with boost-1.53 (fixes issue 131)
-
-diff -r d10dec78492a -r f26d7ee778d6 include/votca/tools/tokenizer.h
---- a/include/votca/tools/tokenizer.h Sun Dec 02 21:09:27 2012 -0700
-+++ b/include/votca/tools/tokenizer.h Sat Jan 26 20:53:03 2013 -0700
-@@ -93,8 +93,10 @@
- std::vector<std::string> tmp;
- ToVector(tmp);
- v.resize(tmp.size());
-- transform(tmp.begin(), tmp.end(), v.begin(),
-- boost::lexical_cast<T, std::string>);
-+ typename std::vector<T>::iterator viter = v.begin();
-+ typename std::vector<std::string>::iterator iter;
-+ for(iter = tmp.begin(); iter!=tmp.end(); ++iter, ++viter)
-+ *viter = boost::lexical_cast<T, std::string>(*iter);
- }
-
- private:
diff --git a/sci-libs/votca-tools/votca-tools-1.2.3-r3.ebuild b/sci-libs/votca-tools/votca-tools-1.2.4.ebuild
index 0c1e50fe55e4..6866aee6d415 100644
--- a/sci-libs/votca-tools/votca-tools-1.2.3-r3.ebuild
+++ b/sci-libs/votca-tools/votca-tools-1.2.4.ebuild
@@ -1,15 +1,13 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.2.3-r3.ebuild,v 1.2 2013/07/02 14:15:12 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.2.4.ebuild,v 1.1 2014/08/31 23:37:54 ottxor Exp $
EAPI="5"
inherit cmake-utils eutils multilib
if [ "${PV}" != "9999" ]; then
- SRC_URI="system-boost? ( http://votca.googlecode.com/files/${P}_pristine.tar.gz )
- !system-boost? ( http://votca.googlecode.com/files/${P}.tar.gz )"
- RESTRICT="primaryuri"
+ SRC_URI="http://downloads.votca.googlecode.com/hg/${P}_pristine.tar.gz"
else
SRC_URI=""
inherit mercurial
@@ -22,12 +20,12 @@ HOMEPAGE="http://www.votca.org"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-macos"
-IUSE="doc +fftw +gsl sqlite +system-boost"
+IUSE="doc +fftw +gsl sqlite"
RDEPEND="fftw? ( sci-libs/fftw:3.0 )
dev-libs/expat
gsl? ( sci-libs/gsl )
- system-boost? ( dev-libs/boost:= )
+ dev-libs/boost:=
sqlite? ( dev-db/sqlite:3 )"
DEPEND="${RDEPEND}
@@ -37,26 +35,12 @@ DEPEND="${RDEPEND}
DOCS=( NOTICE )
-PATCHES=( "${FILESDIR}/${P}-boost-1.53.patch" )
-
-src_prepare() {
- use gsl || ewarn "Disabling gsl will lead to reduced functionality"
- use fftw || ewarn "Disabling fftw will lead to reduced functionality"
-
- cmake-utils_src_prepare
-
- #remove bundled libs
- if use system-boost; then
- rm -rf src/libboost
- fi
-}
-
src_configure() {
mycmakeargs=(
- $(cmake-utils_use system-boost EXTERNAL_BOOST)
$(cmake-utils_use_with gsl GSL)
$(cmake-utils_use_with fftw FFTW)
$(cmake-utils_use_with sqlite SQLITE3)
+ -DEXTERNAL_BOOST=ON
-DWITH_RC_FILES=OFF
-DLIB=$(get_libdir)
)