summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-11-16 08:44:11 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-11-16 08:44:11 +0000
commit5f9de0c023aa1ce04afbcb0a2675f19da3045458 (patch)
tree27929d3e7779e79bc177acf40bbee56e0c74a1fe /sci-libs
parentStable for sparc, wrt bug #490668 (diff)
downloadgentoo-2-5f9de0c023aa1ce04afbcb0a2675f19da3045458.tar.gz
gentoo-2-5f9de0c023aa1ce04afbcb0a2675f19da3045458.tar.bz2
gentoo-2-5f9de0c023aa1ce04afbcb0a2675f19da3045458.zip
Add USE dep instead of calling wxwidgets_pkg_setup.
Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mathgl/ChangeLog6
-rw-r--r--sci-libs/mathgl/mathgl-2.1.3.1.ebuild5
-rw-r--r--sci-libs/mathgl/mathgl-2.1.3.ebuild5
3 files changed, 9 insertions, 7 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index 9f5d33d48fbf..57a580b30f96 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.40 2013/10/29 02:28:11 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.41 2013/11/16 08:44:11 dirtyepic Exp $
+
+ 16 Nov 2013; Ryan Hill <dirtyepic@gentoo.org> mathgl-2.1.3.ebuild,
+ mathgl-2.1.3.1.ebuild:
+ Add USE dep instead of calling wxwidgets_pkg_setup.
29 Oct 2013; Patrick Lauer <patrick@gentoo.org> metadata.xml:
Remove unneeded useflag description from metadata.xml
diff --git a/sci-libs/mathgl/mathgl-2.1.3.1.ebuild b/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
index 7fd386e4e791..0c1e50837de6 100644
--- a/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
+++ b/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.1.ebuild,v 1.1 2013/10/28 16:46:23 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.1.ebuild,v 1.2 2013/11/16 08:44:11 dirtyepic Exp $
EAPI=5
@@ -39,7 +39,7 @@ RDEPEND="
png? ( media-libs/libpng )
python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
qt4? ( dev-qt/qtgui:4 )
- wxwidgets? ( x11-libs/wxGTK:2.8 )
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -56,7 +56,6 @@ REQUIRED_USE="
pkg_setup() {
use mpi && export CC=mpicc CXX=mpicxx
use python && python-single-r1_pkg_setup
- use wxwidgets && wxwidgets_pkg_setup
}
src_unpack() {
diff --git a/sci-libs/mathgl/mathgl-2.1.3.ebuild b/sci-libs/mathgl/mathgl-2.1.3.ebuild
index 8c5e6c89f5af..1cc9b11f2118 100644
--- a/sci-libs/mathgl/mathgl-2.1.3.ebuild
+++ b/sci-libs/mathgl/mathgl-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.ebuild,v 1.1 2013/10/15 15:00:27 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.ebuild,v 1.2 2013/11/16 08:44:11 dirtyepic Exp $
EAPI=5
@@ -39,7 +39,7 @@ RDEPEND="
png? ( media-libs/libpng )
python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
qt4? ( dev-qt/qtgui:4 )
- wxwidgets? ( x11-libs/wxGTK:2.8 )
+ wxwidgets? ( x11-libs/wxGTK:2.8[X] )
zlib? ( sys-libs/zlib )"
DEPEND="${RDEPEND}
@@ -56,7 +56,6 @@ REQUIRED_USE="
pkg_setup() {
use mpi && export CC=mpicc CXX=mpicxx
use python && python-single-r1_pkg_setup
- use wxwidgets && wxwidgets_pkg_setup
}
src_unpack() {