summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-01-23 02:25:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-01-23 02:25:43 +0000
commit4c446976f0548befd01b83094202f4fed41693a8 (patch)
tree0fd66acfce4bdc3fe7f80907bb09261d17935b62 /sci-libs
parentVersion bump. Rewritten for automagic and include more modules. Initial work ... (diff)
downloadgentoo-2-4c446976f0548befd01b83094202f4fed41693a8.tar.gz
gentoo-2-4c446976f0548befd01b83094202f4fed41693a8.tar.bz2
gentoo-2-4c446976f0548befd01b83094202f4fed41693a8.zip
Fixed collisions by not installing examples execs
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gts/ChangeLog8
-rw-r--r--sci-libs/gts/files/gts-20111025-autotools.patch32
-rw-r--r--sci-libs/gts/gts-20111025-r1.ebuild (renamed from sci-libs/gts/gts-20111025.ebuild)10
3 files changed, 26 insertions, 24 deletions
diff --git a/sci-libs/gts/ChangeLog b/sci-libs/gts/ChangeLog
index e760f0ab2be4..44d7aaccfa96 100644
--- a/sci-libs/gts/ChangeLog
+++ b/sci-libs/gts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gts
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.23 2012/01/21 16:06:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.24 2012/01/23 02:25:41 bicatali Exp $
+
+*gts-20111025-r1 (23 Jan 2012)
+
+ 23 Jan 2012; Sébastien Fabbro <bicatali@gentoo.org> -gts-20111025.ebuild,
+ +gts-20111025-r1.ebuild, files/gts-20111025-autotools.patch:
+ Fixed collisions by not installing examples execs
21 Jan 2012; Justin Lecher <jlec@gentoo.org> gts-20111025.ebuild,
files/gts-20111025-autotools.patch:
diff --git a/sci-libs/gts/files/gts-20111025-autotools.patch b/sci-libs/gts/files/gts-20111025-autotools.patch
index acc7605337cc..b7d5ad1bac2f 100644
--- a/sci-libs/gts/files/gts-20111025-autotools.patch
+++ b/sci-libs/gts/files/gts-20111025-autotools.patch
@@ -29,21 +29,6 @@ index ea9a468..9cd0341 100644
if ! test -d html ; then mkdir html ; fi
-cd html && gtkdoc-mkhtml $(DOC_MODULE) ../$(DOC_MAIN_SGML_FILE)
-diff --git a/examples/Makefile.am b/examples/Makefile.am
-index a4b2fc6..63646e8 100644
---- a/examples/Makefile.am
-+++ b/examples/Makefile.am
-@@ -16,9 +16,7 @@ endif
- bin_PROGRAMS = \
- transform \
- delaunay \
-- $(NETPBM_EXTRA)
--
--noinst_PROGRAMS = \
-+ $(NETPBM_EXTRA) \
- set \
- volume \
- cleanup \
diff --git a/src/Makefile.am b/src/Makefile.am
index 3e3c5b3..1b0f286 100644
--- a/src/Makefile.am
@@ -61,3 +46,20 @@ index 3e3c5b3..1b0f286 100644
CLEANFILES = $(BUILT_SOURCES)
+--- examples/Makefile.am.orig 2012-01-20 19:44:46.000000000 +0000
++++ examples/Makefile.am 2012-01-20 19:45:04.000000000 +0000
+@@ -13,12 +13,10 @@
+ NETPBM_EXTRA = happrox
+ endif
+
+-bin_PROGRAMS = \
++check_PROGRAMS = \
+ transform \
+ delaunay \
+- $(NETPBM_EXTRA)
+-
+-noinst_PROGRAMS = \
++ $(NETPBM_EXTRA) \
+ set \
+ volume \
+ cleanup \
diff --git a/sci-libs/gts/gts-20111025.ebuild b/sci-libs/gts/gts-20111025-r1.ebuild
index 346bdc00bb22..c21f82208823 100644
--- a/sci-libs/gts/gts-20111025.ebuild
+++ b/sci-libs/gts/gts-20111025-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/gts-20111025.ebuild,v 1.3 2012/01/21 16:06:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/gts-20111025-r1.ebuild,v 1.1 2012/01/23 02:25:43 bicatali Exp $
EAPI=4
@@ -10,15 +10,13 @@ DESCRIPTION="GNU Triangulated Surface Library"
LICENSE="LGPL-2"
HOMEPAGE="http://gts.sourceforge.net/"
SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
-# wget http://gts.sf.net/gts-snapshot.tar.gz and upload
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc examples static-libs test"
RDEPEND="virtual/fortran
- dev-libs/glib:2
- !<=sci-chemistry/ccp4-apps-6.1.3-r2"
+ dev-libs/glib:2"
DEPEND="${RDEPEND}
dev-util/pkgconfig
test? ( media-libs/netpbm )"
@@ -46,10 +44,6 @@ src_install() {
use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}"/doc/html/)
autotools-utils_src_install
- # rename to avoid collisions
- mv "${ED}"/usr/bin/{,gts-}split || die
- mv "${ED}"/usr/bin/{,gts-}merge || die
-
if use examples; then
insinto /usr/share/doc/${PF}/examples
doins examples/*.c