summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-02-18 04:03:47 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-02-18 04:03:47 +0000
commit3fbc59fd539f0d31dd6454ea1580a606c6643adf (patch)
treeff8830cc398944fb7c0277fe9d7d5cc43148ab43 /sci-libs
parentAdd kgcc64-4.3.3 and add ~mips keyword to it. We're not affected by header i... (diff)
downloadgentoo-2-3fbc59fd539f0d31dd6454ea1580a606c6643adf.tar.gz
gentoo-2-3fbc59fd539f0d31dd6454ea1580a606c6643adf.tar.bz2
gentoo-2-3fbc59fd539f0d31dd6454ea1580a606c6643adf.zip
updated pkg_setup logic to more explicitly handle hdf4 vs. netcdf
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/ChangeLog9
-rw-r--r--sci-libs/gdal/gdal-1.5.2.ebuild32
-rw-r--r--sci-libs/gdal/gdal-1.5.3.ebuild32
3 files changed, 45 insertions, 28 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index 1be4207ee68c..f2de87aa5bc0 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/gdal
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.53 2008/12/25 13:40:29 bluebird Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.54 2009/02/18 04:03:47 nerdboy Exp $
+
+ 18 Feb 2009; Steve Arnold <nerdboy@gentoo.org> gdal-1.5.3.ebuild,
+ gdal-1.5.2.ebuild:
+ Updated pkg_setup logic to more explicitly handle hdf4 vs. netcdf;
+ should fix bugs #256423 and #238999.
25 Dec 2008; Friedrich Oslage <bluebird@gentoo.org> gdal-1.5.2.ebuild:
Stable on sparc, bug #241500
diff --git a/sci-libs/gdal/gdal-1.5.2.ebuild b/sci-libs/gdal/gdal-1.5.2.ebuild
index 912c48e57780..19d647f13eb4 100644
--- a/sci-libs/gdal/gdal-1.5.2.ebuild
+++ b/sci-libs/gdal/gdal-1.5.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.2.ebuild,v 1.6 2008/12/25 13:40:29 bluebird Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.2.ebuild,v 1.7 2009/02/18 04:03:47 nerdboy Exp $
WANT_AUTOCONF="2.5"
inherit autotools distutils eutils perl-module toolchain-funcs
@@ -58,6 +58,23 @@ pkg_setup() {
elog "User-specified configure options are not set."
elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
fi
+
+ if useq hdf; then
+ einfo "Checking if HDF4 is compiled with szip..."
+ if built_with_use sci-libs/hdf szip ; then
+ einfo "Found HDF4 compiled with szip. Nice."
+ else
+ ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
+ einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
+ die "HDF4 not merged with szip use flag"
+ fi
+
+ if useq netcdf; then
+ ewarn "Netcdf and HDF4 are incompatible due to certain tools in"
+ ewarn "common; HDF5 is now the preferred choice for HDF data."
+ die "Please disable either the hdf or netcdf use flag."
+ fi
+ fi
}
src_unpack() {
@@ -72,17 +89,6 @@ src_unpack() {
"${FILESDIR}"/${PN}-1.5.0-makefile.patch \
"${FILESDIR}"/${PN}-1.5.1-python-install.patch \
"${FILESDIR}"/${P}-xerces-64-bit.patch
-
- if useq netcdf && useq hdf; then
- einfo "Checking if HDF4 is compiled with szip..."
- if built_with_use sci-libs/hdf szip ; then
- einfo "Found HDF4 compiled with szip. Nice."
- else
- ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
- einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
- die "HDF4 not merged with szip use flag"
- fi
- fi
}
src_compile() {
diff --git a/sci-libs/gdal/gdal-1.5.3.ebuild b/sci-libs/gdal/gdal-1.5.3.ebuild
index 66087deb7c52..03f9ff429c5c 100644
--- a/sci-libs/gdal/gdal-1.5.3.ebuild
+++ b/sci-libs/gdal/gdal-1.5.3.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.3.ebuild,v 1.2 2008/11/10 23:30:30 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.5.3.ebuild,v 1.3 2009/02/18 04:03:47 nerdboy Exp $
WANT_AUTOCONF="2.5"
inherit autotools distutils eutils perl-module toolchain-funcs
@@ -62,6 +62,23 @@ pkg_setup() {
elog "User-specified configure options are not set."
elog "If needed, set GDAL_CONFIGURE_OPTS to enable grass support."
fi
+
+ if useq hdf; then
+ einfo "Checking if HDF4 is compiled with szip..."
+ if built_with_use sci-libs/hdf szip ; then
+ einfo "Found HDF4 compiled with szip. Nice."
+ else
+ ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
+ einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
+ die "HDF4 not merged with szip use flag"
+ fi
+
+ if useq netcdf; then
+ ewarn "Netcdf and HDF4 are incompatible due to certain tools in"
+ ewarn "common; HDF5 is now the preferred choice for HDF data."
+ die "Please disable either the hdf or netcdf use flag."
+ fi
+ fi
}
src_unpack() {
@@ -76,17 +93,6 @@ src_unpack() {
"${FILESDIR}"/${PN}-1.5.0-makefile.patch \
"${FILESDIR}"/${PN}-1.5.1-python-install.patch \
"${FILESDIR}"/${PN}-1.5.2-xerces-64-bit.patch
-
- if useq netcdf && useq hdf; then
- einfo "Checking if HDF4 is compiled with szip..."
- if built_with_use sci-libs/hdf szip ; then
- einfo "Found HDF4 compiled with szip. Nice."
- else
- ewarn "HDF4 (sci-libs/hdf) must be compiled with the szip USE flag!"
- einfo "Please emerge hdf with szip USE flag and then emerge GDAL."
- die "HDF4 not merged with szip use flag"
- fi
- fi
}
src_compile() {