summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-15 13:57:49 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-15 13:57:49 +0000
commit2ae14a349b193853cde60149ff4d2d59916811da (patch)
tree9de235ee7c77b0448e5036ccb37349d6c14ff6d4 /sci-libs
parentapp-misc/byobu: Version Bump, #452140; move to python-single-r1.eclass (diff)
downloadgentoo-2-2ae14a349b193853cde60149ff4d2d59916811da.tar.gz
gentoo-2-2ae14a349b193853cde60149ff4d2d59916811da.tar.bz2
gentoo-2-2ae14a349b193853cde60149ff4d2d59916811da.zip
sci-libs/vtk: Better fix for tcl support
(Portage version: 2.2.0_alpha152/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/ChangeLog6
-rw-r--r--sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch40
-rw-r--r--sci-libs/vtk/vtk-5.10.1.ebuild5
3 files changed, 48 insertions, 3 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 7cba1ea58009..bcb146e1da6b 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.103 2013/01/14 10:10:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.104 2013/01/15 13:57:49 jlec Exp $
+
+ 15 Jan 2013; Justin Lecher <jlec@gentoo.org> vtk-5.10.1.ebuild,
+ +files/vtk-5.10.1-tcl8.6.patch:
+ Better fix for tcl support
14 Jan 2013; Justin Lecher <jlec@gentoo.org> vtk-5.10.1.ebuild:
Solve problems with USE=examples, #447146
diff --git a/sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch b/sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch
new file mode 100644
index 000000000000..85ba2b197b7f
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch
@@ -0,0 +1,40 @@
+ Common/vtkTclUtil.cxx | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/Common/vtkTclUtil.cxx b/Common/vtkTclUtil.cxx
+index 390b0a4..0a925ee 100644
+--- a/Common/vtkTclUtil.cxx
++++ b/Common/vtkTclUtil.cxx
+@@ -490,13 +490,13 @@ VTKTCL_EXPORT void vtkTclVoidFunc(void *arg)
+ vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
+ arg2->command << endl <<
+ Tcl_GetVar(arg2->interp,(char *)("errorInfo"),0) <<
+- " at line number " << arg2->interp->errorLine);
++ " at line number " << Tcl_GetErrorLine(arg2->interp));
+ }
+ else
+ {
+ vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
+ arg2->command << endl <<
+- " at line number " << arg2->interp->errorLine);
++ " at line number " << Tcl_GetErrorLine(arg2->interp));
+ }
+ }
+ }
+@@ -723,14 +723,14 @@ void vtkTclCommand::Execute(vtkObject *, unsigned long, void *)
+ vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
+ this->StringCommand << endl <<
+ Tcl_GetVar(this->Interp,(char *)("errorInfo"),0) <<
+- " at line number " << this->Interp->errorLine);
++ " at line number " << Tcl_GetErrorLine(this->Interp));
+ }
+ else
+ {
+ vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
+ this->StringCommand << endl <<
+ " at line number " <<
+- this->Interp->errorLine);
++ Tcl_GetErrorLine(this->Interp));
+ }
+ }
+ else if (res == -1)
diff --git a/sci-libs/vtk/vtk-5.10.1.ebuild b/sci-libs/vtk/vtk-5.10.1.ebuild
index d267c293748f..2f20984444b8 100644
--- a/sci-libs/vtk/vtk-5.10.1.ebuild
+++ b/sci-libs/vtk/vtk-5.10.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.10.1.ebuild,v 1.3 2013/01/14 10:10:15 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.10.1.ebuild,v 1.4 2013/01/15 13:57:49 jlec Exp $
EAPI=3
@@ -76,6 +76,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-5.6.0-odbc.patch
"${FILESDIR}"/${PN}-5.6.1-ffmpeg.patch
"${FILESDIR}"/${PN}-5.6.1-libav-0.8.patch
+ "${FILESDIR}"/${P}-tcl8.6.patch
)
pkg_setup() {
@@ -88,7 +89,7 @@ pkg_setup() {
java-pkg-opt-2_pkg_setup
use python && python_set_active_version 2
- append-cppflags -D__STDC_CONSTANT_MACROS -DUSE_INTERP_ERRORLINE
+ append-cppflags -D__STDC_CONSTANT_MACROS
}
src_configure() {