summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-12-19 13:03:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-12-19 13:03:51 +0000
commit2a0b3aedee67d796ce2b6b856d1c25d69f7dae82 (patch)
tree4445f09b8d6bf41386e163a7145f3a8f80d77c7e /sci-libs
parentVersion bump (diff)
downloadgentoo-2-2a0b3aedee67d796ce2b6b856d1c25d69f7dae82.tar.gz
gentoo-2-2a0b3aedee67d796ce2b6b856d1c25d69f7dae82.tar.bz2
gentoo-2-2a0b3aedee67d796ce2b6b856d1c25d69f7dae82.zip
Fixed directory for acml and forced dynamic linking with gfortran when selected, since it will fail without
(Portage version: 2.1.4_rc9)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/acml/ChangeLog6
-rw-r--r--sci-libs/acml/acml-4.0.1.ebuild7
2 files changed, 9 insertions, 4 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index de2d435062b0..14c606937bbc 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/acml
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.27 2007/12/19 02:19:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.28 2007/12/19 13:03:51 bicatali Exp $
+
+ 19 Dec 2007; Sébastien Fabbro <bicatali@gentoo.org> acml-4.0.1.ebuild:
+ Fixed directory for acml and forced dynamic linking with gfortran when
+ selected, since it will fail without
*acml-4.0.1 (19 Dec 2007)
diff --git a/sci-libs/acml/acml-4.0.1.ebuild b/sci-libs/acml/acml-4.0.1.ebuild
index 7dd177477d40..a1a80bc1e531 100644
--- a/sci-libs/acml/acml-4.0.1.ebuild
+++ b/sci-libs/acml/acml-4.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.1 2007/12/19 02:19:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.2 2007/12/19 13:03:51 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -114,9 +114,10 @@ src_install() {
ESELECT_PROF=${ESELECT_PROF}-int64
extflags="${extflags} -fdefault-integer-8"
fi
+ [[ ${fort} =~ gfortran ]] && extlibs="${extlibs} -lgfortran"
if [[ ${fort} =~ _mp ]]; then
ESELECT_PROF=${ESELECT_PROF}-openmp
- #extlibs=-lpthread
+ extlibs="${extlibs} -lpthread"
libname=${libname}_mp
extflags="${extflags} -fopenmp"
fi
@@ -124,7 +125,7 @@ src_install() {
# pkgconfig files
sed -e "s:@LIBDIR@:$(get_libdir):" \
-e "s:@PV@:${PV}:" \
- -e "s:@ACMLDIR@:${acmldir}:g" \
+ -e "s:@ACMLDIR@:${acmldir}/lib:g" \
-e "s:@EXTLIBS@:${extlibs}:g" \
-e "s:@EXTFLAGS@:${extflags}:g" \
"${FILESDIR}"/${l}.pc.in > ${l}.pc \