summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2013-02-19 11:27:09 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2013-02-19 11:27:09 +0000
commit19817c2c02bb81f535c3ddf10b363d5eceb0aef5 (patch)
tree32cc5cf5bbbce775920edd1180e9fa21445054b2 /sci-libs
parentVersion bump with new SRC_URI. Thanks to Jared in bug #455776. (diff)
downloadgentoo-2-19817c2c02bb81f535c3ddf10b363d5eceb0aef5.tar.gz
gentoo-2-19817c2c02bb81f535c3ddf10b363d5eceb0aef5.tar.bz2
gentoo-2-19817c2c02bb81f535c3ddf10b363d5eceb0aef5.zip
Version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/hdf/ChangeLog8
-rw-r--r--sci-libs/hdf/files/hdf-4.2.9-autotools.patch112
-rw-r--r--sci-libs/hdf/hdf-4.2.9.ebuild57
3 files changed, 176 insertions, 1 deletions
diff --git a/sci-libs/hdf/ChangeLog b/sci-libs/hdf/ChangeLog
index c0d3a3c4be92..e8f0925229b3 100644
--- a/sci-libs/hdf/ChangeLog
+++ b/sci-libs/hdf/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/hdf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/ChangeLog,v 1.34 2013/01/04 19:19:54 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/ChangeLog,v 1.35 2013/02/19 11:27:09 xarthisius Exp $
+
+*hdf-4.2.9 (19 Feb 2013)
+
+ 19 Feb 2013; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf-4.2.9-autotools.patch, +hdf-4.2.9.ebuild:
+ Version bump
04 Jan 2013; Agostino Sarubbo <ago@gentoo.org> hdf-4.2.8.ebuild:
Stable for ppc, wrt bug #449226
diff --git a/sci-libs/hdf/files/hdf-4.2.9-autotools.patch b/sci-libs/hdf/files/hdf-4.2.9-autotools.patch
new file mode 100644
index 000000000000..a31946a0dfee
--- /dev/null
+++ b/sci-libs/hdf/files/hdf-4.2.9-autotools.patch
@@ -0,0 +1,112 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -216,20 +216,6 @@ AC_SUBST([BUILD_FORTRAN])
+ ## Build static libraries by default. Furthermore, fortran shared libraries
+ ## are unsupported. Disallow a user from enabling both shared libraries and
+ ## fortran.
+-if test "X${enable_shared}" != "Xyes"; then
+- enable_shared="no"
+-fi
+-
+-if test "X${enable_shared}" = "Xyes"; then
+- if test "X${BUILD_FORTRAN}" = "Xyes"; then
+- AC_MSG_ERROR([Cannot build shared fortran libraries. Please configure with --disable-fortran flag.])
+- fi
+-fi
+-
+-AC_PROG_INSTALL
+-AC_PROG_LN_S
+-
+-AC_CHECK_PROGS([AR], [ar xar], [:], [$PATH])
+
+ AC_CHECK_PROGS([YACC], ['bison -y' byacc yacc], [none], [])
+
+@@ -261,7 +247,7 @@ AC_SUBST([LT_STATIC_EXEC])
+ ## ======================================================================
+ ## Libtool initialization
+ ## ======================================================================
+-LT_INIT([dlopen disable-shared])
++LT_INIT([dlopen])
+ LT_OUTPUT
+
+ ## ----------------------------------------------------------------------
+@@ -453,6 +439,8 @@ case "$withval" in
+
+ if test -z "$HAVE_SZIP"; then
+ AC_MSG_ERROR([couldn't find szlib library])
++ else
++ USE_COMP_SZIP="yes"
+ fi
+ ;;
+ no)
+@@ -496,7 +484,7 @@ case "$withval" in
+
+ AC_CHECK_LIB([sz], [SZ_BufftoBuffCompress],, [unset HAVE_SZIP])
+
+- if test -z "$HAVE_SZIP"; then
++ if test "X$HAVE_SZIP" != "Xyes"; then
+ AC_MSG_ERROR([couldn't find szlib library])
+ else
+ USE_COMP_SZIP="yes"
+@@ -837,11 +825,6 @@ done
+ ## ------------------------------------------------------------------------
+ ## Check to see if libtool has enabled shared libraries. Set a conditional
+ ## as some Makefiles will build based on availability of shared libraries.
+-if (./libtool --features | grep '^enable shared libraries' > /dev/null); then
+- enable_shared=yes
+-else
+- enable_shared=no
+-fi
+
+ ## ------------------------------------------------------------------------
+ ## Specify shared library extension the host machine should recognize.
+@@ -911,22 +894,7 @@ fi
+ ## name of the compiler and the reported version number.
+ AC_SUBST([F77_VERSION])
+ ## Strip anything that looks like a flag off of $F77
+-F77_NOFLAGS=`echo $F77 | sed 's/ -.*//'`
+-
+-if `echo $F77_NOFLAGS | grep ^/ >/dev/null 2>&1`; then
+- F77_VERSION="$F77"
+-else
+- F77_VERSION="$F77";
+- for x in `echo $PATH | sed -e 's/:/ /g'`; do
+- if test -x $x/$F77_NOFLAGS; then
+- F77_VERSION="$x/$F77"
+- break
+- fi
+- done
+-fi
+-if test -n "$fc_version_info"; then
+- F77_VERSION="$F77_VERSION ( $fc_version_info)"
+-fi
++F77_VERSION="$F77"
+
+ ## This part doesn't work yet since HDF4 config files do not contain
+ ## information for fortran_vendor and fortran_version.
+--- a/hdf/test/fortestF.f
++++ b/hdf/test/fortestF.f
+@@ -203,7 +203,7 @@ C Skip command
+
+ if (cmd .NE. 'Test' .AND. cmd .NE. 'test') then
+ print *, 'Unknown Command: ', cmd, param
+- print *, 'Try one of "Skip", "Test", "Verbosity" or "Cleanup"'
++ print *, 'Try one of Skip, Test, Verbosity or Cleanup'
+ retcode = -1
+ return
+ endif
+--- a/mfhdf/libsrc/Makefile.am
++++ b/mfhdf/libsrc/Makefile.am
+@@ -32,10 +32,11 @@ libmfhdf_la_SOURCES = $(CSOURCES) $(FSOURCES)
+ else
+ libmfhdf_la_SOURCES = $(CSOURCES)
+ endif
++libmfhdf_la_LIBADD = $(top_builddir)/hdf/src/libdf.la
+
+ if HDF_BUILD_XDR
+ XDRLIB = $(top_builddir)/mfhdf/xdr/libxdr.la
+-libmfhdf_la_LIBADD = $(XDRLIB)
++libmfhdf_la_LIBADD += $(XDRLIB)
+ endif
+
+ if HDF_BUILD_NETCDF
diff --git a/sci-libs/hdf/hdf-4.2.9.ebuild b/sci-libs/hdf/hdf-4.2.9.ebuild
new file mode 100644
index 000000000000..aa928acc72a5
--- /dev/null
+++ b/sci-libs/hdf/hdf-4.2.9.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf/hdf-4.2.9.ebuild,v 1.1 2013/02/19 11:27:09 xarthisius Exp $
+
+EAPI=4
+
+FORTRAN_NEEDED=fortran
+
+inherit eutils fortran-2 toolchain-funcs autotools flag-o-matic
+
+MYP=${P/_p/-patch}
+
+DESCRIPTION="General purpose library and format for storing scientific data"
+HOMEPAGE="http://www.hdfgroup.org/hdf4.html"
+SRC_URI="http://www.hdfgroup.org/ftp/HDF/HDF_Current/src/${MYP}.tar.bz2"
+
+SLOT="0"
+LICENSE="NCSA-HDF"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="fortran szip static-libs"
+
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg
+ szip? ( >=sci-libs/szip-2 )"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MYP}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch \
+ "${FILESDIR}"/${PN}-ppc.patch
+ sed -i -e 's/-R/-L/g' config/commence.am || die #rpath
+ eautoreconf
+ [[ $(tc-getFC) = *gfortran ]] && append-fflags -fno-range-check
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --enable-production=gentoo \
+ --disable-netcdf \
+ $(use_enable fortran) \
+ $(use_enable static-libs static) \
+ $(use_with szip szlib) \
+ CC="$(tc-getCC)"
+}
+
+src_install() {
+ default
+ dodoc release_notes/{RELEASE,HISTORY,bugs_fixed,misc_docs}.txt
+ cd "${ED}"usr
+ mv bin/ncgen{,-hdf} || die
+ mv bin/ncdump{,-hdf} || die
+ mv share/man/man1/ncgen{,-hdf}.1 || die
+ mv share/man/man1/ncdump{,-hdf}.1 || die
+}