summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-09-29 20:58:23 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-09-29 20:58:23 +0000
commit1598463a1531e5e3a274fe9f9726584bb475ab6d (patch)
tree19eb74213b3115e984304deb68e9f536aca0470f /sci-libs
parentMask net-voip/cohoba for removal. (diff)
downloadgentoo-2-1598463a1531e5e3a274fe9f9726584bb475ab6d.tar.gz
gentoo-2-1598463a1531e5e3a274fe9f9726584bb475ab6d.tar.bz2
gentoo-2-1598463a1531e5e3a274fe9f9726584bb475ab6d.zip
Bump
(Portage version: 2.2_rc88/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog7
-rw-r--r--sci-libs/geos/geos-3.2.2.ebuild86
2 files changed, 92 insertions, 1 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index df9266d1d249..4d410da43631 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.47 2010/09/03 18:03:12 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.48 2010/09/29 20:58:23 patrick Exp $
+
+*geos-3.2.2 (29 Sep 2010)
+
+ 29 Sep 2010; Patrick Lauer <patrick@gentoo.org> +geos-3.2.2.ebuild:
+ Bump
03 Sep 2010; Fabian Groffen <grobian@gentoo.org>
+files/3.2.0-darwin.patch, geos-3.2.0-r1.ebuild:
diff --git a/sci-libs/geos/geos-3.2.2.ebuild b/sci-libs/geos/geos-3.2.2.ebuild
new file mode 100644
index 000000000000..9c475bbba425
--- /dev/null
+++ b/sci-libs/geos/geos-3.2.2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.2.ebuild,v 1.1 2010/09/29 20:58:23 patrick Exp $
+
+EAPI=3
+
+PYTHON_DEPEND="python? 2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit autotools eutils python
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://trac.osgeo.org/geos/"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris"
+IUSE="doc python ruby"
+
+RDEPEND="ruby? ( virtual/ruby )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+pkg_setup() {
+ if use python; then
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/3.2.0-multipy.patch \
+ "${FILESDIR}"/3.2.0-swig2.0.patch \
+ "${FILESDIR}"/3.2.0-python.patch \
+ "${FILESDIR}"/3.2.0-darwin.patch
+ eautoreconf
+ echo "#!${EPREFIX}/bin/bash" > py-compile
+}
+
+src_configure() {
+ econf $(use_enable python) $(use_enable ruby)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use python; then
+ python_copy_sources swig/python
+ building() {
+ emake \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ PYTHON_LDFLAGS="$(python_get_library -l)" \
+ SWIG_PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir swig/python building
+ fi
+ if use doc; then
+ cd "${S}/doc"
+ emake doxygen-html || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use python; then
+ python_copy_sources swig/python
+ installation() {
+ emake \
+ DESTDIR="${D}" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ install
+ }
+ python_execute_function -s --source-dir swig/python installation
+ python_clean_installation_image
+ fi
+ dodoc AUTHORS NEWS README TODO || die
+ if use doc; then
+ cd "${S}/doc"
+ dohtml -r doxygen_docs/html/* || die
+ fi
+}