summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-09-03 18:03:12 +0000
committerFabian Groffen <grobian@gentoo.org>2010-09-03 18:03:12 +0000
commit15218a0c30aff9cd7479218a262612b29b898bc5 (patch)
tree8b5468f5c3498df75d5ad9137fa2b0a712a65565 /sci-libs
parentMarked ~amd64-linux (diff)
downloadgentoo-2-15218a0c30aff9cd7479218a262612b29b898bc5.tar.gz
gentoo-2-15218a0c30aff9cd7479218a262612b29b898bc5.tar.bz2
gentoo-2-15218a0c30aff9cd7479218a262612b29b898bc5.zip
Fix for Prefix and Darwin, bug #335811 and bug #335814
(Portage version: 2.2.01.15553-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/geos/ChangeLog6
-rw-r--r--sci-libs/geos/files/3.2.0-darwin.patch13
-rw-r--r--sci-libs/geos/geos-3.2.0-r1.ebuild21
3 files changed, 29 insertions, 11 deletions
diff --git a/sci-libs/geos/ChangeLog b/sci-libs/geos/ChangeLog
index ca3fad54a421..df9266d1d249 100644
--- a/sci-libs/geos/ChangeLog
+++ b/sci-libs/geos/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/geos
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.46 2010/06/27 18:28:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/ChangeLog,v 1.47 2010/09/03 18:03:12 grobian Exp $
+
+ 03 Sep 2010; Fabian Groffen <grobian@gentoo.org>
+ +files/3.2.0-darwin.patch, geos-3.2.0-r1.ebuild:
+ Fix for Prefix and Darwin, bug #335811 and bug #335814
27 Jun 2010; Justin Lecher <jlec@gentoo.org> +files/3.2.0-python.patch,
geos-3.2.0-r1.ebuild:
diff --git a/sci-libs/geos/files/3.2.0-darwin.patch b/sci-libs/geos/files/3.2.0-darwin.patch
new file mode 100644
index 000000000000..2701b5906a7b
--- /dev/null
+++ b/sci-libs/geos/files/3.2.0-darwin.patch
@@ -0,0 +1,13 @@
+Also check for dylib before giving up, bug #335811
+
+--- macros/ac_python_devel.m4
++++ macros/ac_python_devel.m4
+@@ -42,7 +42,7 @@
+ # Check for Python library path
+ AC_MSG_CHECKING([for Python library path])
+ python_path=`python$PYTHON_VERSION -c 'import distutils.sysconfig; print(distutils.sysconfig.get_config_var("LIBDIR"))'`
+- if test ! -f "${python_path}"/libpython$PYTHON_VERSION.so ; then
++ if test ! -f "${python_path}"/libpython$PYTHON_VERSION.so && test ! -f "${python_path}"/libpython$PYTHON_VERSION.dylib ; then
+ python_path=""
+ fi
+ AC_MSG_RESULT([$python_path])
diff --git a/sci-libs/geos/geos-3.2.0-r1.ebuild b/sci-libs/geos/geos-3.2.0-r1.ebuild
index fc29ea6fa9fa..9330669b841b 100644
--- a/sci-libs/geos/geos-3.2.0-r1.ebuild
+++ b/sci-libs/geos/geos-3.2.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0-r1.ebuild,v 1.4 2010/06/27 18:28:03 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.2.0-r1.ebuild,v 1.5 2010/09/03 18:03:12 grobian Exp $
-EAPI=2
+EAPI=3
PYTHON_DEPEND="python? 2"
SUPPORT_PYTHON_ABIS="1"
@@ -34,9 +34,10 @@ pkg_setup() {
src_prepare() {
epatch "${FILESDIR}"/${PV}-multipy.patch \
"${FILESDIR}"/${PV}-swig2.0.patch \
- "${FILESDIR}"/${PV}-python.patch
+ "${FILESDIR}"/${PV}-python.patch \
+ "${FILESDIR}"/${PV}-darwin.patch
eautoreconf
- echo "#!/bin/bash" > py-compile
+ echo "#!${EPREFIX}/bin/bash" > py-compile
}
src_configure() {
@@ -49,11 +50,11 @@ src_compile() {
python_copy_sources swig/python
building() {
emake \
- PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
PYTHON_LDFLAGS="$(python_get_library -l)" \
- SWIG_PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
+ SWIG_PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)"
}
python_execute_function -s --source-dir swig/python building
fi
@@ -70,8 +71,8 @@ src_install() {
installation() {
emake \
DESTDIR="${D}" \
- pythondir="$(python_get_sitedir)" \
- pyexecdir="$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
install
}
python_execute_function -s --source-dir swig/python installation