summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-09 17:14:28 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-09 17:14:28 +0000
commit0117a211b2d4d9e2977a583ab4296fea900003b3 (patch)
tree14c6bf0fbb74a2628e8bdb86ac03c18d6126139e /sci-libs
parentVersion bump. Keyword amd64-linux, x86-linux (diff)
downloadgentoo-2-0117a211b2d4d9e2977a583ab4296fea900003b3.tar.gz
gentoo-2-0117a211b2d4d9e2977a583ab4296fea900003b3.tar.bz2
gentoo-2-0117a211b2d4d9e2977a583ab4296fea900003b3.zip
keyword amd64-linux and x86-linux
(Portage version: 2.2.01.20757-prefix/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/nlopt/ChangeLog5
-rw-r--r--sci-libs/nlopt/nlopt-2.2.4.ebuild22
2 files changed, 15 insertions, 12 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index 6bd846e9db6e..df5217035616 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.16 2012/04/04 08:07:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.17 2012/07/09 17:14:28 bicatali Exp $
+
+ 09 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> nlopt-2.2.4.ebuild:
+ keyword amd64-linux and x86-linux
04 Apr 2012; Justin Lecher <jlec@gentoo.org> nlopt-2.2.4.ebuild:
Correct handling of PYABI things, #405255
diff --git a/sci-libs/nlopt/nlopt-2.2.4.ebuild b/sci-libs/nlopt/nlopt-2.2.4.ebuild
index 7a89ca74130c..65e3b9664c71 100644
--- a/sci-libs/nlopt/nlopt-2.2.4.ebuild
+++ b/sci-libs/nlopt/nlopt-2.2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.8 2012/04/04 08:07:04 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-2.2.4.ebuild,v 1.9 2012/07/09 17:14:28 bicatali Exp $
EAPI=4
@@ -15,7 +15,7 @@ HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
SRC_URI="${HOMEPAGE}/${P}.tar.gz"
LICENSE="LGPL-2.1 MIT"
-KEYWORDS="amd64 x86"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
SLOT="0"
IUSE="cxx guile octave python static-libs"
@@ -61,13 +61,13 @@ src_compile() {
python_copy_sources swig
compilation() {
autotools-utils_src_compile \
- PYTHON_CPPFLAGS="-I$(python_get_includedir)" \
- PYTHON_LDFLAGS="$(python_get_library -l)" \
- PYTHON_SITE_PKG="$(python_get_sitedir)" \
- PYTHON_VERSION="$(python_get_version)" \
- PYTHON_INCLUDES="$(python_get_includedir)" \
- pythondir="$(python_get_sitedir)" \
- pyexecdir="$(python_get_sitedir)"
+ PYTHON_CPPFLAGS="-I${EPREFIX}$(python_get_includedir)" \
+ PYTHON_LDFLAGS="${EPREFIX}$(python_get_library -l)" \
+ PYTHON_SITE_PKG="${EPREFIX}$(python_get_sitedir)" \
+ PYTHON_VERSION="${EPREFIX}$(python_get_version)" \
+ PYTHON_INCLUDES="${EPREFIX}$(python_get_includedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)" \
+ pyexecdir="${EPREFIX}$(python_get_sitedir)"
}
python_execute_function -s --source-dir swig compilation
fi
@@ -79,8 +79,8 @@ src_install() {
installation() {
rm *.la
emake DESTDIR=${D} install \
- pyexecdir="$(python_get_sitedir)" \
- pythondir="$(python_get_sitedir)"
+ pyexecdir="${EPREFIX}$(python_get_sitedir)" \
+ pythondir="${EPREFIX}$(python_get_sitedir)"
}
python_execute_function -s --source-dir swig installation
python_clean_installation_image