summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-04-25 10:00:50 +0000
committerJustin Lecher <jlec@gentoo.org>2010-04-25 10:00:50 +0000
commitdbd0f42e5b12887e60b5a3b8371dcf30544a6a31 (patch)
treec84febef20f19093c6d8d89313905101d187b0ac /sci-libs/vtk
parentVersion bump to ruby-gnome 0.19.4. (diff)
downloadgentoo-2-dbd0f42e5b12887e60b5a3b8371dcf30544a6a31.tar.gz
gentoo-2-dbd0f42e5b12887e60b5a3b8371dcf30544a6a31.tar.bz2
gentoo-2-dbd0f42e5b12887e60b5a3b8371dcf30544a6a31.zip
Python ABI fixes, #316229
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog5
-rw-r--r--sci-libs/vtk/vtk-5.4.2-r1.ebuild15
2 files changed, 12 insertions, 8 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index a608155efcdf..4db9bd46991c 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.64 2010/03/26 12:40:16 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.65 2010/04/25 10:00:50 jlec Exp $
+
+ 25 Apr 2010; Justin Lecher <jlec@gentoo.org> vtk-5.4.2-r1.ebuild:
+ Python ABI fixes, #316229
26 Mar 2010; Ben de Groot <yngwin@gentoo.org> vtk-5.4.2.ebuild,
vtk-5.4.2-r1.ebuild:
diff --git a/sci-libs/vtk/vtk-5.4.2-r1.ebuild b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
index 9bb17d79f8a7..673901bf49be 100644
--- a/sci-libs/vtk/vtk-5.4.2-r1.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.6 2010/03/26 12:40:16 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.7 2010/04/25 10:00:50 jlec Exp $
EAPI="2"
-inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt4 cmake-utils
+
+PYTHON_DEPEND="python? 2"
+inherit cmake-utils eutils flag-o-matic java-pkg-opt-2 python qt4 versionator toolchain-funcs
# Short package version
SPV="$(get_version_component_range 1-2)"
@@ -17,7 +19,7 @@ SRC_URI="http://www.${PN}.org/files/release/${SPV}/${P}.tar.gz
LICENSE="BSD LGPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="boost cg doc examples mpi patented python tcl tk threads qt4"
+IUSE="boost cg doc examples mpi patented python qt4 tcl tk threads"
RDEPEND="mpi? ( || (
sys-cluster/openmpi
sys-cluster/lam-mpi
@@ -58,9 +60,8 @@ pkg_setup() {
java-pkg-opt-2_pkg_setup
- if use qt4; then
- qt4_pkg_setup
- fi
+ use python && python_set_active_version 2
+ use qt4 && qt4_pkg_setup
}
src_prepare() {
@@ -129,7 +130,7 @@ src_configure() {
fi
if use python; then
- python_version
+ PYVER="$(python_get_version)"
mycmakeargs+=(
-DVTK_WRAP_PYTHON=ON
-DPYTHON_INCLUDE_PATH=/usr/include/python${PYVER}