summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-28 20:05:22 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-28 20:05:22 +0000
commit8d49f31f9766f6699227c65f6b7e889297426738 (patch)
tree409ab759185c4bebe61efad1d47fa5e435677401 /sci-libs/vtk
parentAdded missed dependenices, disabled automagic hesiod, bug 292147, thank Dusti... (diff)
downloadgentoo-2-8d49f31f9766f6699227c65f6b7e889297426738.tar.gz
gentoo-2-8d49f31f9766f6699227c65f6b7e889297426738.tar.bz2
gentoo-2-8d49f31f9766f6699227c65f6b7e889297426738.zip
Fixed correct detection R libs
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog10
-rw-r--r--sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch178
-rw-r--r--sci-libs/vtk/files/vtk-5.6.0-R.patch57
-rw-r--r--sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch13
-rw-r--r--sci-libs/vtk/vtk-5.4.2.ebuild4
-rw-r--r--sci-libs/vtk/vtk-5.6.0-r1.ebuild (renamed from sci-libs/vtk/vtk-5.6.0.ebuild)3
6 files changed, 220 insertions, 45 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index f1e227c77737..904f8b74de1f 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.68 2010/05/28 11:51:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.69 2010/05/28 20:05:21 jlec Exp $
+
+*vtk-5.6.0-r1 (28 May 2010)
+
+ 28 May 2010; Justin Lecher <jlec@gentoo.org> vtk-5.4.2.ebuild,
+ files/vtk-5.4.2-boost-property_map.patch, -vtk-5.6.0.ebuild,
+ +vtk-5.6.0-r1.ebuild, +files/vtk-5.6.0-R.patch,
+ files/vtk-5.6.0-boost-property_map.patch:
+ Fixed correct detection R libs
*vtk-5.6.0 (28 May 2010)
diff --git a/sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch b/sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch
index abba0d2ff5ae..90c6d6a1fed3 100644
--- a/sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch
+++ b/sci-libs/vtk/files/vtk-5.4.2-boost-property_map.patch
@@ -1,66 +1,188 @@
-diff -Naur VTK/Infovis/Testing/Cxx/TestBoostAdapter.cxx VTK.new/Infovis/Testing/Cxx/TestBoostAdapter.cxx
---- VTK/Infovis/Testing/Cxx/TestBoostAdapter.cxx 2008-11-01 15:22:38.000000000 -0400
-+++ VTK.new/Infovis/Testing/Cxx/TestBoostAdapter.cxx 2010-01-21 17:53:23.000000000 -0500
-@@ -36,7 +36,7 @@
+diff --git a/Infovis/Testing/Cxx/TestBoostAdapter.cxx b/Infovis/Testing/Cxx/TestBoostAdapter.cxx
+index 6af2855..484a9e0 100644
+--- a/Infovis/Testing/Cxx/TestBoostAdapter.cxx
++++ b/Infovis/Testing/Cxx/TestBoostAdapter.cxx
+@@ -36,8 +36,8 @@
#include <boost/graph/strong_components.hpp>
#include <boost/graph/dijkstra_shortest_paths.hpp>
#include <boost/graph/transitive_closure.hpp>
-#include <boost/property_map.hpp>
+-#include <boost/vector_property_map.hpp>
+#include <boost/property_map/property_map.hpp>
- #include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
#include "vtkGraph.h"
-diff -Naur VTK/Infovis/vtkBoostBreadthFirstSearch.cxx VTK.new/Infovis/vtkBoostBreadthFirstSearch.cxx
---- VTK/Infovis/vtkBoostBreadthFirstSearch.cxx 2008-12-02 11:42:38.000000000 -0500
-+++ VTK.new/Infovis/vtkBoostBreadthFirstSearch.cxx 2010-01-21 17:52:56.000000000 -0500
-@@ -46,7 +46,7 @@
+ #include "vtkBoostGraphAdapter.h"
+diff --git a/Infovis/vtkBoostBiconnectedComponents.cxx b/Infovis/vtkBoostBiconnectedComponents.cxx
+index 6799dd0..dd759d5 100644
+--- a/Infovis/vtkBoostBiconnectedComponents.cxx
++++ b/Infovis/vtkBoostBiconnectedComponents.cxx
+@@ -32,7 +32,7 @@
+ #include "vtkGraph.h"
+ #include "vtkBoostGraphAdapter.h"
+ #include <boost/graph/biconnected_components.hpp>
+-#include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
+ #include <boost/version.hpp>
+ #include <vtksys/stl/vector>
+ #include <vtksys/stl/utility>
+diff --git a/Infovis/vtkBoostBrandesCentrality.cxx b/Infovis/vtkBoostBrandesCentrality.cxx
+index e214a72..443c039 100644
+--- a/Infovis/vtkBoostBrandesCentrality.cxx
++++ b/Infovis/vtkBoostBrandesCentrality.cxx
+@@ -36,7 +36,7 @@
+
+ #include <boost/graph/adjacency_list.hpp>
+ #include <boost/graph/betweenness_centrality.hpp>
+-#include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
+
+ using namespace boost;
+
+diff --git a/Infovis/vtkBoostBreadthFirstSearch.cxx b/Infovis/vtkBoostBreadthFirstSearch.cxx
+index 7fab585..6e56a7c 100644
+--- a/Infovis/vtkBoostBreadthFirstSearch.cxx
++++ b/Infovis/vtkBoostBreadthFirstSearch.cxx
+@@ -46,8 +46,8 @@
#include <boost/graph/visitors.hpp>
#include <boost/graph/breadth_first_search.hpp>
-#include <boost/property_map.hpp>
+-#include <boost/vector_property_map.hpp>
+#include <boost/property_map/property_map.hpp>
- #include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
#include <boost/pending/queue.hpp>
-diff -Naur VTK/Parallel/vtkPBGLBreadthFirstSearch.cxx VTK.new/Parallel/vtkPBGLBreadthFirstSearch.cxx
---- VTK/Parallel/vtkPBGLBreadthFirstSearch.cxx 2008-12-04 16:17:46.000000000 -0500
-+++ VTK.new/Parallel/vtkPBGLBreadthFirstSearch.cxx 2010-01-21 17:53:58.000000000 -0500
-@@ -50,7 +50,7 @@
+ #include <vtksys/stl/utility> // for pair
+diff --git a/Infovis/vtkBoostBreadthFirstSearchTree.cxx b/Infovis/vtkBoostBreadthFirstSearchTree.cxx
+index 5c64516..64ee7b5 100644
+--- a/Infovis/vtkBoostBreadthFirstSearchTree.cxx
++++ b/Infovis/vtkBoostBreadthFirstSearchTree.cxx
+@@ -39,7 +39,7 @@
+ #include "vtkTree.h"
+
+ #include <boost/graph/breadth_first_search.hpp>
+-#include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+ using namespace boost;
+diff --git a/Infovis/vtkBoostConnectedComponents.cxx b/Infovis/vtkBoostConnectedComponents.cxx
+index 69e9d8f..c88f4ab 100644
+--- a/Infovis/vtkBoostConnectedComponents.cxx
++++ b/Infovis/vtkBoostConnectedComponents.cxx
+@@ -33,7 +33,7 @@
+
+ #include "vtkBoostGraphAdapter.h"
+ #include <boost/graph/strong_components.hpp>
+-#include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
+
+ using namespace boost;
+
+diff --git a/Infovis/vtkBoostKruskalMinimumSpanningTree.cxx b/Infovis/vtkBoostKruskalMinimumSpanningTree.cxx
+index b0c89de..7ea3aa9 100644
+--- a/Infovis/vtkBoostKruskalMinimumSpanningTree.cxx
++++ b/Infovis/vtkBoostKruskalMinimumSpanningTree.cxx
+@@ -40,7 +40,7 @@ PURPOSE. See the above copyright notice for more information.
+ #include "vtkTree.h"
+
+ #include <boost/graph/kruskal_min_spanning_tree.hpp>
+-#include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+ using namespace boost;
+diff --git a/Infovis/vtkBoostPrimMinimumSpanningTree.cxx b/Infovis/vtkBoostPrimMinimumSpanningTree.cxx
+index 935d0f7..48716fd 100644
+--- a/Infovis/vtkBoostPrimMinimumSpanningTree.cxx
++++ b/Infovis/vtkBoostPrimMinimumSpanningTree.cxx
+@@ -39,7 +39,7 @@ PURPOSE. See the above copyright notice for more information.
+ #include "vtkTree.h"
+
+ #include <boost/graph/prim_minimum_spanning_tree.hpp>
+-#include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+ using namespace boost;
+diff --git a/Infovis/vtkTreeLayoutStrategy.cxx b/Infovis/vtkTreeLayoutStrategy.cxx
+index 6efa586..222afe9 100644
+--- a/Infovis/vtkTreeLayoutStrategy.cxx
++++ b/Infovis/vtkTreeLayoutStrategy.cxx
+@@ -375,8 +375,8 @@ void vtkTreeLayoutStrategy::PrintSelf(ostream& os, vtkIndent indent)
+ #include "vtkTreeToBoostAdapter.h"
+ #include <boost/graph/visitors.hpp>
+ #include <boost/graph/depth_first_search.hpp>
+-#include <boost/property_map.hpp>
+-#include <boost/vector_property_map.hpp>
++#include <boost/property_map/property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
+ #include <boost/pending/queue.hpp>
+
+ using namespace boost;
+diff --git a/Parallel/vtkPBGLBreadthFirstSearch.cxx b/Parallel/vtkPBGLBreadthFirstSearch.cxx
+index 2b4681b..eebeaa9 100644
+--- a/Parallel/vtkPBGLBreadthFirstSearch.cxx
++++ b/Parallel/vtkPBGLBreadthFirstSearch.cxx
+@@ -50,8 +50,8 @@
#include <boost/graph/distributed/breadth_first_search.hpp>
#include <boost/parallel/algorithm.hpp>
#include <boost/graph/visitors.hpp>
-#include <boost/property_map.hpp>
+-#include <boost/vector_property_map.hpp>
+#include <boost/property_map/property_map.hpp>
- #include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
#include <boost/pending/queue.hpp>
-diff -Naur VTK/Parallel/vtkPBGLMinimumSpanningTree.cxx VTK.new/Parallel/vtkPBGLMinimumSpanningTree.cxx
---- VTK/Parallel/vtkPBGLMinimumSpanningTree.cxx 2008-12-04 16:17:46.000000000 -0500
-+++ VTK.new/Parallel/vtkPBGLMinimumSpanningTree.cxx 2010-01-21 17:54:18.000000000 -0500
-@@ -48,7 +48,7 @@
+ #include <vtksys/stl/utility> // for pair
+diff --git a/Parallel/vtkPBGLGraphAdapter.h b/Parallel/vtkPBGLGraphAdapter.h
+index 7b467b0..bacfd3a 100644
+--- a/Parallel/vtkPBGLGraphAdapter.h
++++ b/Parallel/vtkPBGLGraphAdapter.h
+@@ -31,7 +31,7 @@
+ #include <boost/graph/distributed/mpi_process_group.hpp>
+ #include <boost/graph/properties.hpp>
+ #include <boost/graph/parallel/container_traits.hpp>
+-#include <boost/parallel/local_property_map.hpp>
++#include <boost/property_map/parallel/local_property_map.hpp>
+ #include <boost/serialization/base_object.hpp>
+ #include <boost/functional/hash.hpp>
+ //ETX
+diff --git a/Parallel/vtkPBGLMinimumSpanningTree.cxx b/Parallel/vtkPBGLMinimumSpanningTree.cxx
+index da4647e..f9c3229 100644
+--- a/Parallel/vtkPBGLMinimumSpanningTree.cxx
++++ b/Parallel/vtkPBGLMinimumSpanningTree.cxx
+@@ -48,8 +48,8 @@
#include <boost/graph/distributed/dehne_gotz_min_spanning_tree.hpp>
#include <boost/graph/distributed/vertex_list_adaptor.hpp>
#include <boost/parallel/global_index_map.hpp>
-#include <boost/property_map.hpp>
+-#include <boost/vector_property_map.hpp>
+#include <boost/property_map/property_map.hpp>
- #include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
#include <boost/pending/queue.hpp>
-diff -Naur VTK/Parallel/vtkPBGLShortestPaths.cxx VTK.new/Parallel/vtkPBGLShortestPaths.cxx
---- VTK/Parallel/vtkPBGLShortestPaths.cxx 2009-02-23 16:08:57.000000000 -0500
-+++ VTK.new/Parallel/vtkPBGLShortestPaths.cxx 2010-01-21 17:54:36.000000000 -0500
-@@ -49,7 +49,7 @@
+ #include <vtksys/stl/utility> // for pair
+diff --git a/Parallel/vtkPBGLShortestPaths.cxx b/Parallel/vtkPBGLShortestPaths.cxx
+index 074143f..8517304 100644
+--- a/Parallel/vtkPBGLShortestPaths.cxx
++++ b/Parallel/vtkPBGLShortestPaths.cxx
+@@ -49,8 +49,8 @@
#include <boost/graph/distributed/delta_stepping_shortest_paths.hpp>
#include <boost/parallel/algorithm.hpp>
-#include <boost/property_map.hpp>
+-#include <boost/vector_property_map.hpp>
+#include <boost/property_map/property_map.hpp>
- #include <boost/vector_property_map.hpp>
++#include <boost/property_map/vector_property_map.hpp>
#include <vtksys/stl/utility> // for pair
-diff -Naur VTK/Parallel/vtkPBGLVertexColoring.cxx VTK.new/Parallel/vtkPBGLVertexColoring.cxx
---- VTK/Parallel/vtkPBGLVertexColoring.cxx 2008-07-31 13:56:53.000000000 -0400
-+++ VTK.new/Parallel/vtkPBGLVertexColoring.cxx 2010-01-21 17:53:40.000000000 -0500
+
+diff --git a/Parallel/vtkPBGLVertexColoring.cxx b/Parallel/vtkPBGLVertexColoring.cxx
+index 9aa87a0..301a245 100644
+--- a/Parallel/vtkPBGLVertexColoring.cxx
++++ b/Parallel/vtkPBGLVertexColoring.cxx
@@ -47,7 +47,7 @@
#include <boost/graph/distributed/boman_et_al_graph_coloring.hpp>
diff --git a/sci-libs/vtk/files/vtk-5.6.0-R.patch b/sci-libs/vtk/files/vtk-5.6.0-R.patch
new file mode 100644
index 000000000000..1327121c20c6
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.6.0-R.patch
@@ -0,0 +1,57 @@
+diff --git a/CMake/FindR.cmake b/CMake/FindR.cmake
+index ee49570..c830db0 100644
+--- a/CMake/FindR.cmake
++++ b/CMake/FindR.cmake
+@@ -18,13 +18,12 @@ IF (R_COMMAND)
+ ENDIF (R_COMMAND)
+ SET(CMAKE_FIND_APPBUNDLE ${TEMP_CMAKE_FIND_APPBUNDLE})
+
+-FIND_PATH(R_INCLUDE_DIR R.h PATHS /usr/local/lib /usr/local/lib64 PATH_SUFFIXES R/include DOC "Path to file R.h")
++FIND_PATH(R_INCLUDE_DIR R.h PATHS /usr/lib /usr/lib64 PATH_SUFFIXES R/include DOC "Path to file R.h")
+ FIND_LIBRARY(R_LIBRARY_BASE R PATHS ${R_BASE_DIR} PATH_SUFFIXES /lib DOC "R library (example libR.a, libR.dylib, etc.).")
+-FIND_LIBRARY(R_LIBRARY_BLAS Rblas PATHS ${R_BASE_DIR} PATH_SUFFIXES /lib DOC "Rblas library (example libRblas.a, libRblas.dylib, etc.).")
+-FIND_LIBRARY(R_LIBRARY_LAPACK Rlapack PATHS ${R_BASE_DIR} PATH_SUFFIXES /lib DOC "Rlapack library (example libRlapack.a, libRlapack.dylib, etc.).")
++FIND_LIBRARY(R_LIBRARY_MATH Rmath PATHS ${R_BASE_DIR} PATH_SUFFIXES /lib DOC "Rmath library (example libRmath.a, libRmath.dylib, etc.).")
+ FIND_LIBRARY(R_LIBRARY_READLINE readline DOC "(Optional) system readline library. Only required if the R libraries were build with readline support.")
+
+-SET(R_LIBRARIES ${R_LIBRARY_BASE} ${R_LIBRARY_BLAS} ${R_LIBRARY_LAPACK} ${R_LIBRARY_BASE})
++SET(R_LIBRARIES ${R_LIBRARY_BASE} ${R_LIBRARY_MATH} ${R_LIBRARY_BASE})
+ IF (R_LIBRARY_READLINE)
+ SET(R_LIBRARIES ${R_LIBRARIES} ${R_LIBRARY_READLINE})
+ ENDIF (R_LIBRARY_READLINE)
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 9d4e881..1a828a4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -1054,8 +1054,18 @@ IF(VTK_WRAP_JAVA)
+ ENDIF(JAVA_AWT_LIBRARY)
+ ENDIF(VTK_WRAP_JAVA)
+
++IF(VTK_USE_GNU_R)
++ FIND_PACKAGE(R)
++ENDIF(VTK_USE_GNU_R)
+
+-
++IF(VTK_USE_BOOST)
++ if (VTK_USE_PARALLEL_BGL)
++ FIND_PACKAGE(Boost 1.39.0 REQUIRED
++ COMPONENTS mpi serialization filesystem system graph_parallel)
++ else (VTK_USE_PARALLEL_BGL)
++ FIND_PACKAGE(Boost REQUIRED)
++ endif (VTK_USE_PARALLEL_BGL)
++ENDIF(VTK_USE_BOOST)
+ #-----------------------------------------------------------------------------
+ # The entire VTK tree should use the same include path.
+
+diff --git a/Graphics/vtkRInterface.cxx b/Graphics/vtkRInterface.cxx
+index 324e845..56a4869 100644
+--- a/Graphics/vtkRInterface.cxx
++++ b/Graphics/vtkRInterface.cxx
+@@ -23,6 +23,7 @@
+ #undef HAVE_UINTPTR_T
+ #ifdef HAVE_VTK_UINTPTR_T
+ #define HAVE_UINTPTR_T HAVE_VTK_UINTPTR_T
++#include <stdint.h>
+ #endif
+
+ #include "vtkInformation.h"
diff --git a/sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch b/sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch
index d6b7bda88eb6..9319378acb1a 100644
--- a/sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch
+++ b/sci-libs/vtk/files/vtk-5.6.0-boost-property_map.patch
@@ -1,16 +1,3 @@
-diff --git a/Infovis/vtkBoostGraphAdapter.h b/Infovis/vtkBoostGraphAdapter.h
-index 5d113ac..d84cb98 100644
---- a/Infovis/vtkBoostGraphAdapter.h
-+++ b/Infovis/vtkBoostGraphAdapter.h
-@@ -50,7 +50,7 @@ namespace boost {
- // These need to be defined before including other boost stuff
-
- // Forward declarations are required here, so that we aren't forced
-- // to include boost/property_map.hpp.
-+ // to include boost/property_map/property_map.hpp.
- template<typename> class property_traits;
- class read_write_property_map_tag;
-
diff --git a/Infovis/vtkTreeLayoutStrategy.cxx b/Infovis/vtkTreeLayoutStrategy.cxx
index 4a764ea..74d0b53 100644
--- a/Infovis/vtkTreeLayoutStrategy.cxx
diff --git a/sci-libs/vtk/vtk-5.4.2.ebuild b/sci-libs/vtk/vtk-5.4.2.ebuild
index de617f47fa09..e95db885d3d1 100644
--- a/sci-libs/vtk/vtk-5.4.2.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2.ebuild,v 1.8 2010/05/22 09:19:22 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2.ebuild,v 1.9 2010/05/28 20:05:21 jlec Exp $
EAPI="2"
inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt4
@@ -44,7 +44,7 @@ RDEPEND="mpi? ( || (
DEPEND="${RDEPEND}
java? ( >=virtual/jdk-1.5 )
- boost? ( dev-libs/boost )
+ boost? ( >=dev-libs/boost-1.40 )
>=dev-util/cmake-2.6"
S="${WORKDIR}"/VTK
diff --git a/sci-libs/vtk/vtk-5.6.0.ebuild b/sci-libs/vtk/vtk-5.6.0-r1.ebuild
index 22242c165a3a..2a2e8ea97dc8 100644
--- a/sci-libs/vtk/vtk-5.6.0.ebuild
+++ b/sci-libs/vtk/vtk-5.6.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0.ebuild,v 1.1 2010/05/28 11:51:24 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.6.0-r1.ebuild,v 1.1 2010/05/28 20:05:21 jlec Exp $
EAPI="3"
PYTHON_DEPEND="python? 2"
@@ -70,6 +70,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-5.2.0-tcl-install.patch
epatch "${FILESDIR}"/${P}-boost-property_map.patch
epatch "${FILESDIR}"/${P}-libpng14.patch
+ epatch "${FILESDIR}"/${P}-R.patch
sed -e "s:@VTK_TCL_LIBRARY_DIR@:/usr/$(get_libdir):" \
-i Wrapping/Tcl/pkgIndex.tcl.in \
|| die "Failed to fix tcl pkgIndex file"