summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-09-24 16:47:49 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-09-24 16:47:49 +0000
commit4076d5bf8bf07d87943ffe3e03a1dc714ac682c7 (patch)
tree96e7b736ed3dcad55824406b142dc08daa50d225 /sci-libs/vtk
parentAdded to ~ppc (diff)
downloadgentoo-2-4076d5bf8bf07d87943ffe3e03a1dc714ac682c7.tar.gz
gentoo-2-4076d5bf8bf07d87943ffe3e03a1dc714ac682c7.tar.bz2
gentoo-2-4076d5bf8bf07d87943ffe3e03a1dc714ac682c7.zip
Added patch to fix compile problems with python-2.5 (see bug #148727).
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog7
-rw-r--r--sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch12
-rw-r--r--sci-libs/vtk/vtk-5.0.1.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index b380b6c75d6f..86366272de73 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.23 2006/09/08 15:15:13 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.24 2006/09/24 16:47:49 markusle Exp $
+
+ 23 Sep 2006; Markus Dittrich <markusle@gentoo.org>
+ +files/vtk-5.0.1-python2.5-gentoo.patch, vtk-5.0.1.ebuild:
+ Added patch to fix compile problems with python-2.5
+ (see bug #148727).
08 Sep 2006; Markus Dittrich <markusle@gentoo.org>
+files/vtk-qt-gentoo.patch, -files/vtk-qt3-qt4-gentoo.patch,
diff --git a/sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch b/sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch
new file mode 100644
index 000000000000..c1abcd7254ad
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.0.1-python2.5-gentoo.patch
@@ -0,0 +1,12 @@
+diff -Naur VTK/Common/vtkPythonUtil.cxx VTK-new/Common/vtkPythonUtil.cxx
+--- VTK/Common/vtkPythonUtil.cxx 2005-08-04 12:19:14.000000000 -0400
++++ VTK-new/Common/vtkPythonUtil.cxx 2006-09-23 11:16:06.000000000 -0400
+@@ -768,7 +768,7 @@
+ }
+ if (strcmp(name, "__doc__") == 0)
+ {
+- char *doc = t->tp_doc;
++ const char *doc = t->tp_doc;
+ if (doc != NULL)
+ {
+ return PyString_FromString(doc);
diff --git a/sci-libs/vtk/vtk-5.0.1.ebuild b/sci-libs/vtk/vtk-5.0.1.ebuild
index 90c6937ba214..7f1e75064621 100644
--- a/sci-libs/vtk/vtk-5.0.1.ebuild
+++ b/sci-libs/vtk/vtk-5.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.1.ebuild,v 1.3 2006/09/08 15:15:13 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.1.ebuild,v 1.4 2006/09/24 16:47:49 markusle Exp $
# TODO: need to fix Examples/CMakeLists.txt to build other examples
@@ -53,6 +53,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}"/${PN}-qt-gentoo.patch
+ epatch "${FILESDIR}"/${P}-python2.5-gentoo.patch
}
src_compile() {