summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-31 08:09:39 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-31 08:09:39 +0000
commit3985496e59ec08fc9f7744202f46299d657b6380 (patch)
tree89f40c0e64227b6e3a3ced10b189982e613a35d4 /sci-libs/vtk
parentVersion bump. (diff)
downloadgentoo-2-3985496e59ec08fc9f7744202f46299d657b6380.tar.gz
gentoo-2-3985496e59ec08fc9f7744202f46299d657b6380.tar.bz2
gentoo-2-3985496e59ec08fc9f7744202f46299d657b6380.zip
sci-libs/vtk: Backport upstream patch for tcl/tk-8.6.0, #454762
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog5
-rw-r--r--sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch37
2 files changed, 31 insertions, 11 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 0dd7f15f8744..111653011475 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.105 2013/01/17 21:15:03 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.106 2013/01/31 08:09:39 jlec Exp $
+
+ 31 Jan 2013; Justin Lecher <jlec@gentoo.org> files/vtk-5.10.1-tcl8.6.patch:
+ Backport upstream patch for tcl/tk-8.6.0, #454762
17 Jan 2013; Alexis Ballier <aballier@gentoo.org> vtk-5.10.1.ebuild,
+files/vtk-5.10.1-ffmpeg-1.patch:
diff --git a/sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch b/sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch
index 85ba2b197b7f..ed7ec08c2ea7 100644
--- a/sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch
+++ b/sci-libs/vtk/files/vtk-5.10.1-tcl8.6.patch
@@ -1,40 +1,57 @@
- Common/vtkTclUtil.cxx | 8 ++++----
- 1 file changed, 4 insertions(+), 4 deletions(-)
+ Common/vtkTclUtil.cxx | 19 ++++++++++++++-----
+ 1 file changed, 14 insertions(+), 5 deletions(-)
diff --git a/Common/vtkTclUtil.cxx b/Common/vtkTclUtil.cxx
-index 390b0a4..0a925ee 100644
+index 390b0a4..2b7bccb 100644
--- a/Common/vtkTclUtil.cxx
+++ b/Common/vtkTclUtil.cxx
-@@ -490,13 +490,13 @@ VTKTCL_EXPORT void vtkTclVoidFunc(void *arg)
+@@ -21,6 +21,12 @@
+ #include <string>
+ #include <vtksys/SystemTools.hxx>
+
++#if (TCL_MAJOR_VERSION == 8) && (TCL_MINOR_VERSION < 6)
++#define vtkTclGetErrorLine(m) (m->errorLine)
++#else
++#define vtkTclGetErrorLine(m) (Tcl_GetErrorLine(m))
++#endif
++
+ extern "C"
+ {
+ #if (TCL_MAJOR_VERSION == 8) && (TCL_MINOR_VERSION >= 4)
+@@ -490,13 +496,15 @@ VTKTCL_EXPORT void vtkTclVoidFunc(void *arg)
vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
arg2->command << endl <<
Tcl_GetVar(arg2->interp,(char *)("errorInfo"),0) <<
- " at line number " << arg2->interp->errorLine);
-+ " at line number " << Tcl_GetErrorLine(arg2->interp));
++ " at line number " <<
++ vtkTclGetErrorLine(arg2->interp));
}
else
{
vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
arg2->command << endl <<
- " at line number " << arg2->interp->errorLine);
-+ " at line number " << Tcl_GetErrorLine(arg2->interp));
++ " at line number " <<
++ vtkTclGetErrorLine(arg2->interp));
}
}
}
-@@ -723,14 +723,14 @@ void vtkTclCommand::Execute(vtkObject *, unsigned long, void *)
+@@ -723,14 +731,15 @@ void vtkTclCommand::Execute(vtkObject *, unsigned long, void *)
vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
this->StringCommand << endl <<
Tcl_GetVar(this->Interp,(char *)("errorInfo"),0) <<
- " at line number " << this->Interp->errorLine);
-+ " at line number " << Tcl_GetErrorLine(this->Interp));
++ " at line number " <<
++ vtkTclGetErrorLine(this->Interp));
}
else
{
vtkGenericWarningMacro("Error returned from vtk/tcl callback:\n" <<
this->StringCommand << endl <<
- " at line number " <<
+- " at line number " <<
- this->Interp->errorLine);
-+ Tcl_GetErrorLine(this->Interp));
++ " at line number " <<
++ vtkTclGetErrorLine(this->Interp));
}
}
else if (res == -1)