summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-04-04 19:56:40 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-04-04 19:56:40 +0000
commitd34ce1d88a6d54d22c5e1973db3d5cf2a7b51863 (patch)
treeb395eb12b047469d979043788144ba2d1afa60af /sci-libs/votca-tools
parentUpdate useflags to match reality. Update deps to avoid automagicness. (diff)
downloadgentoo-2-d34ce1d88a6d54d22c5e1973db3d5cf2a7b51863.tar.gz
gentoo-2-d34ce1d88a6d54d22c5e1973db3d5cf2a7b51863.tar.bz2
gentoo-2-d34ce1d88a6d54d22c5e1973db3d5cf2a7b51863.zip
[sci-libs/votca-tools] Version bump
(Portage version: 2.1.9.42/cvs/Linux i686)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/ChangeLog8
-rw-r--r--sci-libs/votca-tools/votca-tools-1.1.2.ebuild76
2 files changed, 83 insertions, 1 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index 719cc14a8fae..1032b4b7ef0f 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/votca-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.3 2011/03/09 22:10:05 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.4 2011/04/04 19:56:40 ottxor Exp $
+
+*votca-tools-1.1.2 (04 Apr 2011)
+
+ 04 Apr 2011; Christoph Junghans <ottxor@gentoo.org>
+ +votca-tools-1.1.2.ebuild:
+ Version bump
09 Mar 2011; Christoph Junghans <ottxor@gentoo.org> votca-tools-1.1.1.ebuild:
added ~amd64 (bug #357983)
diff --git a/sci-libs/votca-tools/votca-tools-1.1.2.ebuild b/sci-libs/votca-tools/votca-tools-1.1.2.ebuild
new file mode 100644
index 000000000000..22a9be4cfbe0
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.1.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.1.2.ebuild,v 1.1 2011/04/04 19:56:40 ottxor Exp $
+
+EAPI="3"
+
+inherit eutils autotools-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="boost? ( http://votca.googlecode.com/files/${PF}_pristine.tar.gz )
+ !boost? ( http://votca.googlecode.com/files/${PF}.tar.gz )"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://tools.votca.googlecode.com/hg"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="-boost doc +fftw +gsl static-libs"
+
+RDEPEND="fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/expat
+ gsl? ( sci-libs/gsl )
+ boost? ( dev-libs/boost )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[-nodot] )
+ >=app-text/txt2tags-2.5
+ dev-util/pkgconfig"
+
+src_prepare() {
+ use gsl || ewarn "Disabling gsl will lead to reduced functionality"
+ use fftw || ewarn "Disabling fftw will lead to reduced functionality"
+
+ #remove bundled libs
+ rm -rf src/libexpat
+ if use boost; then
+ rm -rf src/libboost
+ else
+ #fix a qa issue ../../config is not support as m4 dir
+ mkdir -p src/libboost/config || die
+ sed -i 's@\.\./\.\./config@config@' \
+ src/libboost/configure.ac \
+ src/libboost/Makefile.am || \
+ die "sed of libboost configure.ac and Makefile.am failed"
+ fi
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ local myconf
+ use boost && myconf="--disable-votca-boost" || myconf="--enable-votca-boost"
+
+ myeconfargs=( ${myconf} --disable-rc-files
+ $(use_with gsl)
+ $(use_with fftw)
+ )
+ autotools-utils_src_configure || die
+}
+
+src_install() {
+ DOCS=(${AUTOTOOLS_BUILD_DIR}/CHANGELOG NOTICE)
+ autotools-utils_src_install || die
+ if use doc; then
+ cd share/doc || die
+ doxygen || die
+ dohtml -r html/* || die
+ fi
+}