summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-06 19:01:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-06 19:01:37 +0000
commitcce4ef7cb5b1580ed55ab19e0dfa5f763d19da25 (patch)
treec33527bbce4c35727675626dee51822ff0e43276 /sci-libs/taucs
parentRecover bluetoothd init.d script to start it now that upstream has decided to... (diff)
downloadgentoo-2-cce4ef7cb5b1580ed55ab19e0dfa5f763d19da25.tar.gz
gentoo-2-cce4ef7cb5b1580ed55ab19e0dfa5f763d19da25.tar.bz2
gentoo-2-cce4ef7cb5b1580ed55ab19e0dfa5f763d19da25.zip
Remove buggy cilk from tests and cleanup shared library building
(Portage version: 2.1.11.5/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/taucs')
-rw-r--r--sci-libs/taucs/ChangeLog7
-rw-r--r--sci-libs/taucs/files/taucs-2.2-no-test-cilk.patch20
-rw-r--r--sci-libs/taucs/taucs-2.2.ebuild40
3 files changed, 45 insertions, 22 deletions
diff --git a/sci-libs/taucs/ChangeLog b/sci-libs/taucs/ChangeLog
index a46821b972e3..cc30dbeb9827 100644
--- a/sci-libs/taucs/ChangeLog
+++ b/sci-libs/taucs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/taucs
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/ChangeLog,v 1.7 2012/05/04 08:22:53 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/ChangeLog,v 1.8 2012/07/06 19:01:37 bicatali Exp $
+
+ 06 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/taucs-2.2-no-test-cilk.patch, taucs-2.2.ebuild:
+ Remove buggy cilk from tests and cleanup shared library building
04 May 2012; Jeff Horelick <jdhore@gentoo.org> taucs-2.2.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
@@ -25,4 +29,3 @@
27 Oct 2008; Sébastien Fabbro <bicatali@gentoo.org> +metadata.xml,
+taucs-2.2.ebuild:
Initial import
-
diff --git a/sci-libs/taucs/files/taucs-2.2-no-test-cilk.patch b/sci-libs/taucs/files/taucs-2.2-no-test-cilk.patch
new file mode 100644
index 000000000000..68ecc3bf94b6
--- /dev/null
+++ b/sci-libs/taucs/files/taucs-2.2-no-test-cilk.patch
@@ -0,0 +1,20 @@
+--- testscript.orig 2012-07-06 19:42:51.000000000 +0100
++++ testscript 2012-07-06 19:43:17.000000000 +0100
+@@ -12,17 +12,6 @@
+ ulimit -s >> testscript.log
+ echo '==============' >> testscript.log
+ echo =============== >> testscript.log
+-echo = test_cilk_snmf = >> testscript.log
+-. ./configure in=progs/test_cilk_snmf.c $*
+-echo last conf is $TAUCS_LASTCONF >> testscript.log
+-make -f build/${TAUCS_LASTCONF}/makefile
+-if bin/${TAUCS_LASTCONF}/test_cilk_snmf >> testscript.log ; then
+-echo = TEST PASSED test_cilk_snmf >> testscript.log
+-else
+-echo = TEST FAILED test_cilk_snmf >> testscript.log
+-fi
+-echo =============== >> testscript.log
+-echo =============== >> testscript.log
+ echo = test_complex = >> testscript.log
+ . ./configure in=progs/test_complex.c $*
+ echo last conf is $TAUCS_LASTCONF >> testscript.log
diff --git a/sci-libs/taucs/taucs-2.2.ebuild b/sci-libs/taucs/taucs-2.2.ebuild
index d3571ba4c89b..24de0aab169b 100644
--- a/sci-libs/taucs/taucs-2.2.ebuild
+++ b/sci-libs/taucs/taucs-2.2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/taucs-2.2.ebuild,v 1.7 2012/05/04 08:22:53 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/taucs/taucs-2.2.ebuild,v 1.8 2012/07/06 19:01:37 bicatali Exp $
EAPI=4
-inherit eutils flag-o-matic fortran-2 toolchain-funcs
+inherit eutils fortran-2 toolchain-funcs
DESCRIPTION="C library of sparse linear solvers"
HOMEPAGE="http://www.tau.ac.il/~stoledo/taucs/"
@@ -26,23 +26,28 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"
+src_prepare() {
+ # test with cilk has memory leaks
+ epatch "${FILESDIR}"/${P}-no-test-cilk.patch
+}
+
src_configure() {
cat > config/linux_shared.mk <<-EOF
- CFLAGS=${CFLAGS} -fPIC
FC=$(tc-getFC)
CC=$(tc-getCC)
+ CFLAGS=${CFLAGS} -fPIC
FFLAGS=${FFLAGS} -fPIC
LDFLAGS=${LDFLAGS} -fPIC
LIBBLAS=$(pkg-config --libs blas)
LIBLAPACK=$(pkg-config --libs lapack)
LIBF77=
EOF
- [[ $(tc-getFC) =~ fortran ]] && echo "LIBF77=-lgfortran" >> config/linux_shared.mk
+
echo "LIBMETIS=$(pkg-config --libs metis)" >> config/linux_shared.mk
# no cat <<EOF because -o has a trailing space
if use cilk; then
echo "CILKC=cilkc" >> config/linux_shared.mk
- echo "CILKFLAGS=-O2 -I/usr/include/cilk -fPIC" >> config/linux_shared.mk
+ echo "CILKFLAGS=-O2 -I${EPREFIX}/usr/include/cilk -fPIC" >> config/linux_shared.mk
echo "CILKOUTFLG=-o " >> config/linux_shared.mk
fi
sed -e 's/ -fPIC//g' \
@@ -60,17 +65,16 @@ src_compile() {
emake
cd lib/linux_shared
- $(tc-getAR) x libtaucs.a
- $(tc-getLD) $(raw-ldflags) *.o \
- -shared \
- -soname libtaucs.so.1 \
- -o libtaucs.so.1.0.0 \
+ $(tc-getFC) ${LDFLAGS} -shared -Wl,-soname=libtaucs.so.1 \
+ -Wl,--whole-archive libtaucs.a -Wl,--no-whole-archive \
$(pkg-config --libs blas lapack metis) \
+ -o libtaucs.so.1.0.0 \
|| die "shared lib linking failed"
}
src_test() {
- ./testscript variant=_static || die "compile test failed"
+ LD_LIBRARY_PATH=lib/linux_shared \
+ ./testscript variant=_shared || die "compile test failed"
if grep -q FAILED testscript.log; then
eerror "Test failed. See ${S}/testscript.log"
die "test failed"
@@ -78,17 +82,13 @@ src_test() {
}
src_install() {
- if use static-libs; then
- dolib.a lib/linux_static/libtaucs.a
- fi
- dolib.so lib/linux_shared/libtaucs.so.1.0.0
- dosym libtaucs.so.1.0.0 /usr/$(get_libdir)/libtaucs.so.1
- dosym libtaucs.so.1 /usr/$(get_libdir)/libtaucs.so
+ use static-libs && dolib.a lib/linux_static/libtaucs.a
+ ln -s libtaucs.so.1.0.0 lib/linux_shared/libtaucs.so.1
+ ln -s libtaucs.so.1 lib/linux_shared/libtaucs.so
+ dolib.so lib/linux_shared/libtaucs.so*
insinto /usr/include
doins build/*/*.h src/*.h
- use doc && \
- insinto /usr/share/doc/${PF} && \
- doins doc/*.pdf
+ use doc && dodoc doc/*.pdf
}