summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2009-01-13 06:24:14 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2009-01-13 06:24:14 +0000
commit3484776005bf535b34922494356d5b082df2d9f0 (patch)
tree7a4519d8041b59ff97cf3ef628ee7f1a286521f4 /sci-libs/starparse
parentFix Manifest (diff)
downloadgentoo-2-3484776005bf535b34922494356d5b082df2d9f0.tar.gz
gentoo-2-3484776005bf535b34922494356d5b082df2d9f0.tar.bz2
gentoo-2-3484776005bf535b34922494356d5b082df2d9f0.zip
New package: Library for parsing NMR star files (peak-list format) and CIF files. Dependency of sci-chemistry/burrow-owl.
(Portage version: 2.1.6.4/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'sci-libs/starparse')
-rw-r--r--sci-libs/starparse/ChangeLog11
-rw-r--r--sci-libs/starparse/metadata.xml5
-rw-r--r--sci-libs/starparse/starparse-0.9.ebuild31
3 files changed, 47 insertions, 0 deletions
diff --git a/sci-libs/starparse/ChangeLog b/sci-libs/starparse/ChangeLog
new file mode 100644
index 000000000000..8f1798803d4d
--- /dev/null
+++ b/sci-libs/starparse/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/starparse
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/starparse/ChangeLog,v 1.1 2009/01/13 06:24:14 dberkholz Exp $
+
+*starparse-0.9 (13 Jan 2009)
+
+ 13 Jan 2009; Donnie Berkholz <dberkholz@gentoo.org>; +metadata.xml,
+ +starparse-0.9.ebuild:
+ New package: Library for parsing NMR star files (peak-list format) and CIF
+ files. Dependency of sci-chemistry/burrow-owl.
+
diff --git a/sci-libs/starparse/metadata.xml b/sci-libs/starparse/metadata.xml
new file mode 100644
index 000000000000..e42d0af60f42
--- /dev/null
+++ b/sci-libs/starparse/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+</pkgmetadata>
diff --git a/sci-libs/starparse/starparse-0.9.ebuild b/sci-libs/starparse/starparse-0.9.ebuild
new file mode 100644
index 000000000000..6570f63dab26
--- /dev/null
+++ b/sci-libs/starparse/starparse-0.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/starparse/starparse-0.9.ebuild,v 1.1 2009/01/13 06:24:14 dberkholz Exp $
+
+if [[ ${PV} = 9999* ]]; then
+ EBZR_REPO_URI="http://oregonstate.edu/~benisong/software/projects/starparse/"
+ EBZR_BRANCH="releases/0.9"
+ EBZR_BOOTSTRAP="eautoreconf"
+ BZR="bzr"
+fi
+
+inherit autotools ${BZR}
+
+DESCRIPTION="Library for parsing NMR star files (peak-list format) and CIF files"
+HOMEPAGE="http://burrow-owl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="guile"
+RDEPEND="guile? ( dev-scheme/guile )"
+DEPEND="${RDEPEND}"
+
+src_compile() {
+ econf $(use_enable guile) || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}