summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-23 20:16:51 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-23 20:16:51 +0000
commitf6dc936bbe8cd591704cd2e079149ffa37fc4d92 (patch)
tree48ec0a6601e5742e7ef7b9ce9d21b1e371e04139 /sci-libs/spqr
parentRequest support for source highlighting in documentation building, fixing bug... (diff)
downloadgentoo-2-f6dc936bbe8cd591704cd2e079149ffa37fc4d92.tar.gz
gentoo-2-f6dc936bbe8cd591704cd2e079149ffa37fc4d92.tar.bz2
gentoo-2-f6dc936bbe8cd591704cd2e079149ffa37fc4d92.zip
Bump
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/spqr')
-rw-r--r--sci-libs/spqr/ChangeLog9
-rw-r--r--sci-libs/spqr/spqr-1.2.1.ebuild47
2 files changed, 54 insertions, 2 deletions
diff --git a/sci-libs/spqr/ChangeLog b/sci-libs/spqr/ChangeLog
index cc16fb3804e9..2d536d6ada5b 100644
--- a/sci-libs/spqr/ChangeLog
+++ b/sci-libs/spqr/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/spqr
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/ChangeLog,v 1.5 2010/12/25 18:51:56 bicatali Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/ChangeLog,v 1.6 2011/02/23 20:16:51 bicatali Exp $
+
+*spqr-1.2.1 (23 Feb 2011)
+
+ 23 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +spqr-1.2.1.ebuild:
+ Bump
25 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org> spqr-1.2.0.ebuild:
Added static-libs flag
diff --git a/sci-libs/spqr/spqr-1.2.1.ebuild b/sci-libs/spqr/spqr-1.2.1.ebuild
new file mode 100644
index 000000000000..8d1cb1556084
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/spqr-1.2.1.ebuild,v 1.1 2011/02/23 20:16:51 bicatali Exp $
+
+EAPI=2
+inherit eutils autotools
+
+MY_PN=SPQR
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc metis static-libs tbb"
+RDEPEND="sci-libs/cholmod[supernodal]
+ tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-1.7.0-r1[metis] )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ cd "${WORKDIR}"
+ epatch "${FILESDIR}"/${PN}-1.1.0-autotools.patch
+ epatch "${FILESDIR}"/${PN}-1.1.0-gcc43.patch
+ cd "${S}"
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ $(use_with metis) \
+ $(use_with tbb)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/*.pdf || die
+ fi
+}