summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2014-02-03 23:44:02 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2014-02-03 23:44:02 +0000
commitbd241ac13881f216246aba0c037caa902eac6c84 (patch)
tree3eb063587e15b2d7560de8433fd70cf897bc37fc /sci-libs/scotch
parentVersion bump. (diff)
downloadgentoo-2-bd241ac13881f216246aba0c037caa902eac6c84.tar.gz
gentoo-2-bd241ac13881f216246aba0c037caa902eac6c84.tar.bz2
gentoo-2-bd241ac13881f216246aba0c037caa902eac6c84.zip
Fixed bug #499168, thanks jer and getryx, add sub-slot
(Portage version: 2.2.8-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/scotch')
-rw-r--r--sci-libs/scotch/ChangeLog7
-rw-r--r--sci-libs/scotch/scotch-6.0.0.ebuild12
2 files changed, 13 insertions, 6 deletions
diff --git a/sci-libs/scotch/ChangeLog b/sci-libs/scotch/ChangeLog
index eb5038a54e68..89a9a80557c0 100644
--- a/sci-libs/scotch/ChangeLog
+++ b/sci-libs/scotch/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/scotch
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/ChangeLog,v 1.15 2013/07/02 02:07:22 jsbronder Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/ChangeLog,v 1.16 2014/02/03 23:44:02 bicatali Exp $
+
+ 03 Feb 2014; Sébastien Fabbro <bicatali@gentoo.org> scotch-6.0.0.ebuild:
+ Fixed bug #499168, thanks jer and getryx, add sub-slot
02 Jul 2013; Justin Bronder <jsbronder@gentoo.org> scotch-6.0.0.ebuild:
Remove fix for #462602. Handled in sys-cluster/openmpi now.
diff --git a/sci-libs/scotch/scotch-6.0.0.ebuild b/sci-libs/scotch/scotch-6.0.0.ebuild
index 98edb3071864..b05d56867d13 100644
--- a/sci-libs/scotch/scotch-6.0.0.ebuild
+++ b/sci-libs/scotch/scotch-6.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/scotch-6.0.0.ebuild,v 1.4 2013/07/02 02:07:22 jsbronder Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/scotch-6.0.0.ebuild,v 1.5 2014/02/03 23:44:02 bicatali Exp $
EAPI=5
@@ -10,13 +10,14 @@ inherit eutils toolchain-funcs versionator flag-o-matic multilib
MYP="${PN}_${PV}_esmumps"
# download id on gforge changes every goddamn release
DID=31832
+SOVER=$(get_major_version)
DESCRIPTION="Software for graph, mesh and hypergraph partitioning"
HOMEPAGE="http://www.labri.u-bordeaux.fr/perso/pelegrin/scotch/"
SRC_URI="http://gforge.inria.fr/frs/download.php/${DID}/${MYP}.tar.gz"
LICENSE="CeCILL-2"
-SLOT="0"
+SLOT="0/${SOVER}"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
IUSE="doc int64 mpi static-libs tools threads"
@@ -30,7 +31,7 @@ S="${WORKDIR}/${MYP/b}"
static_to_shared() {
local libstatic=${1}; shift
local libname=$(basename ${libstatic%.a})
- local soname=${libname}$(get_libname $(get_version_component_range 1-2))
+ local soname=${libname}$(get_libname ${SOVER})
local libdir=$(dirname ${libstatic})
einfo "Making ${soname} from ${libstatic}"
@@ -57,6 +58,9 @@ src_prepare() {
append-cflags "-DSCOTCH_PTHREAD_NUMBER=$(nproc)"
else
append-cflags "-DSCOTCH_PTHREAD_NUMBER=1"
+ sed -i \
+ -e e 's/ -DSCOTCH_PTHREAD//' \
+ src/Make.inc/Makefile.inc.i686_pc_linux3 || die
fi
sed -e "s/gcc/$(tc-getCC)/" \
-e "s/-O3/${CFLAGS} -pthread/" \