summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-26 10:08:23 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-26 10:08:23 +0000
commit6bf4af6061d2fbca429d48dcec0dc8ccc457b8e5 (patch)
treec1041689328255c3bf549cf9766644c80559af9f /sci-libs/scotch/scotch-5.1.7.ebuild
parentBumped EAPI and corrected structure (diff)
downloadgentoo-2-6bf4af6061d2fbca429d48dcec0dc8ccc457b8e5.tar.gz
gentoo-2-6bf4af6061d2fbca429d48dcec0dc8ccc457b8e5.tar.bz2
gentoo-2-6bf4af6061d2fbca429d48dcec0dc8ccc457b8e5.zip
Removed suspect RDEPEND
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/scotch/scotch-5.1.7.ebuild')
-rw-r--r--sci-libs/scotch/scotch-5.1.7.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/sci-libs/scotch/scotch-5.1.7.ebuild b/sci-libs/scotch/scotch-5.1.7.ebuild
index a2cb7475df72..d29b1aa5a872 100644
--- a/sci-libs/scotch/scotch-5.1.7.ebuild
+++ b/sci-libs/scotch/scotch-5.1.7.ebuild
@@ -1,12 +1,12 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/scotch-5.1.7.ebuild,v 1.1 2010/01/15 22:43:52 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scotch/scotch-5.1.7.ebuild,v 1.2 2011/06/26 10:08:23 jlec Exp $
-EAPI="2"
+EAPI=3
inherit eutils
-DESCRIPTION="Software package and libraries for graph partitioning, static mapping, and sparse matrix block ordering"
+DESCRIPTION="Software for graph, mesh and hypergraph partitioning"
HOMEPAGE="http://www.labri.u-bordeaux.fr/perso/pelegrin/scotch/"
SRC_URI="http://gforge.inria.fr/frs/download.php/23390/${PN}_${PV}.tgz"
@@ -15,15 +15,16 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="mpi"
-DEPEND="sys-devel/bison
- mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
+RDEPEND="mpi? ( virtual/mpi )"
+DEPEND="${RDEPEND}
+ sys-devel/bison"
S=${WORKDIR}"/scotch_5.1/src"
src_prepare() {
- epatch "${FILESDIR}"/shared-libs_${PV}.patch
- epatch "${FILESDIR}"/metis-header.patch
+ epatch \
+ "${FILESDIR}"/shared-libs_${PV}.patch \
+ "${FILESDIR}"/metis-header.patch
}
src_configure() {
@@ -32,7 +33,7 @@ src_configure() {
src_compile() {
emake -j1 || die "make failed"
- use mpi && (emake -j1 ptscotch || die "make failed")
+ use mpi && emake -j1 ptscotch || die "make failed"
}
src_install() {