summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-21 21:40:03 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-21 21:40:03 +0000
commite840988d33bbc69d39780fb8a2a55a4e1691b7f5 (patch)
treedd17c2f6e0bd9341ee5b8c6e85b8d051c0afcda5 /sci-libs/scipy
parentSparc stable, bug #277722. (diff)
downloadgentoo-2-e840988d33bbc69d39780fb8a2a55a4e1691b7f5.tar.gz
gentoo-2-e840988d33bbc69d39780fb8a2a55a4e1691b7f5.tar.bz2
gentoo-2-e840988d33bbc69d39780fb8a2a55a4e1691b7f5.zip
Version bump. Better compatibility with python-2.6.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/scipy-0.7.1.ebuild105
2 files changed, 111 insertions, 1 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index d238bb1c116b..24080ade952f 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.41 2009/02/20 10:29:30 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.42 2009/07/21 21:40:03 bicatali Exp $
+
+*scipy-0.7.1 (21 Jul 2009)
+
+ 21 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +scipy-0.7.1.ebuild:
+ Version bump. Better compatibility with python-2.6.
20 Feb 2009; Sébastien Fabbro <bicatali@gentoo.org>
scipy-0.6.0-r6.ebuild, scipy-0.7.0.ebuild:
diff --git a/sci-libs/scipy/scipy-0.7.1.ebuild b/sci-libs/scipy/scipy-0.7.1.ebuild
new file mode 100644
index 000000000000..e78e77718bd0
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.7.1.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.7.1.ebuild,v 1.1 2009/07/21 21:40:03 bicatali Exp $
+
+EAPI=2
+NEED_PYTHON=2.4
+
+inherit eutils distutils toolchain-funcs flag-o-matic
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Scientific algorithms library for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="test umfpack"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+CDEPEND=">=dev-python/numpy-1.2
+ virtual/cblas
+ virtual/lapack
+ umfpack? ( sci-libs/umfpack )"
+
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig
+ test? ( dev-python/nose )
+ umfpack? ( dev-lang/swig )"
+
+RDEPEND="${CDEPEND}
+ dev-python/imaging"
+
+# buggy tests
+RESTRICT="test"
+
+DOCS="THANKS.txt LATEST.txt TOCHANGE.txt"
+
+pkg_setup() {
+ # scipy automatically detects libraries by default
+ export {FFTW,FFTW3,UMFPACK}=None
+ use umfpack && unset UMFPACK
+ append-ldflags -shared
+ [[ -z ${FC} ]] && FC=$(tc-getFC)
+ export SCIPY_FCONFIG="config_fc --noopt --noarch"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.7.0_beta1-implicit.patch
+ epatch "${FILESDIR}"/${PN}-0.6.0-stsci.patch
+ cat > site.cfg <<-EOF
+ [DEFAULT]
+ library_dirs = /usr/$(get_libdir)
+ include_dirs = /usr/include
+ [atlas]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas blas lapack| sed -e \
+ 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):/usr/$(get_libdir)
+ atlas_libs = $(pkg-config --libs-only-l \
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ lapack_libs = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ [blas_opt]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):/usr/$(get_libdir)
+ libraries = $(pkg-config --libs-only-l \
+ cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ [lapack_opt]
+ library_dirs = $(pkg-config --libs-only-L \
+ lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):/usr/$(get_libdir)
+ libraries = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ EOF
+}
+
+src_compile() {
+ [[ -n ${FFLAGS} ]] && FFLAGS="${FFLAGS} -fPIC"
+ distutils_src_compile ${SCIPY_FCONFIG}
+}
+
+src_test() {
+ "${python}" setup.py install \
+ --home="${S}"/test \
+ --no-compile \
+ ${SCIPY_FCONFIG} || die "install test failed"
+ pushd "${S}"/test/lib*/python
+ PYTHONPATH=. "${python}" -c "import scipy; scipy.test('full')" 2>&1 | tee test.log
+ grep -q ^ERROR test.log && die "test failed"
+ popd
+ rm -rf test
+}
+
+src_install() {
+ distutils_src_install ${SCIPY_FCONFIG}
+}
+
+pkg_postinst() {
+ elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
+ elog "to your prefered image viewer if you don't like the default one. Ex:"
+ elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
+}