summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-09-28 21:39:43 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-09-28 21:39:43 +0000
commit210803b7b6157f4afa4a55a81ec10628d01c6eb2 (patch)
tree88d10a553b2835fe8f056dd38f955839ce82104d /sci-libs/scipy
parentFixed again blas/lapack configuration to be compatible with the available gen... (diff)
downloadgentoo-2-210803b7b6157f4afa4a55a81ec10628d01c6eb2.tar.gz
gentoo-2-210803b7b6157f4afa4a55a81ec10628d01c6eb2.tar.bz2
gentoo-2-210803b7b6157f4afa4a55a81ec10628d01c6eb2.zip
Fixed again blas/lapack configuration to be compatible with the available gentoo implementations
(Portage version: 2.2_rc9/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/scipy-0.6.0-r4.ebuild34
2 files changed, 29 insertions, 12 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 1a3a5ed1bcbe..ce596dd57570 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.33 2008/09/26 20:09:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.34 2008/09/28 21:39:43 bicatali Exp $
+
+ 28 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ scipy-0.6.0-r4.ebuild:
+ Fixed again blas/lapack configuration to be compatible with the available
+ gentoo implementations
26 Sep 2008; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
scipy-0.6.0-r4.ebuild:
diff --git a/sci-libs/scipy/scipy-0.6.0-r4.ebuild b/sci-libs/scipy/scipy-0.6.0-r4.ebuild
index 58e25b60ae4a..7b18fee7efa4 100644
--- a/sci-libs/scipy/scipy-0.6.0-r4.ebuild
+++ b/sci-libs/scipy/scipy-0.6.0-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r4.ebuild,v 1.6 2008/09/26 20:09:59 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.6.0-r4.ebuild,v 1.7 2008/09/28 21:39:43 bicatali Exp $
EAPI=1
NEED_PYTHON=2.3
@@ -89,18 +89,30 @@ src_unpack() {
[DEFAULT]
library_dirs = /usr/$(get_libdir)
include_dirs = /usr/include
+ [atlas]
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas lapack | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas lapack | sed -e \
+ 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):/usr/$(get_libdir)
+ atlas_libs = $(pkg-config --libs-only-l \
+ cblas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ lapack_libs = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
[blas_opt]
- include_dirs = $(pkg-config --cflags-only-I cblas \
- | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L cblas \
- | sed -e 's/^-L//' -e 's/ -L/:/g')
- libraries = $(pkg-config --libs-only-l cblas \
- | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ include_dirs = $(pkg-config --cflags-only-I \
+ cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
+ library_dirs = $(pkg-config --libs-only-L \
+ cblas | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):/usr/$(get_libdir)
+ libraries = $(pkg-config --libs-only-l \
+ cblas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
[lapack_opt]
- library_dirs = $(pkg-config --libs-only-L lapack \
- | sed -e 's/^-L//' -e 's/ -L/:/g')
- libraries = $(pkg-config --libs-only-l lapack \
- | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
+ library_dirs = $(pkg-config --libs-only-L \
+ lapack | sed -e 's/^-L//' -e 's/ -L/:/g' \
+ -e 's/ //g'):/usr/$(get_libdir)
+ libraries = $(pkg-config --libs-only-l \
+ lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
EOF
if use sandbox; then
cd scipy/sandbox