summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-07 12:56:54 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-07 12:56:54 +0000
commita0138fbe0b08eb18887479f16b9ac75e58198802 (patch)
tree4464a987f54e41d1672695c70fe084f435187278 /sci-libs/pgplot
parentAdd as-is and X11 to LICENSE for oldXMenu und etc/rgb.txt, respectively. (diff)
downloadgentoo-2-a0138fbe0b08eb18887479f16b9ac75e58198802.tar.gz
gentoo-2-a0138fbe0b08eb18887479f16b9ac75e58198802.tar.bz2
gentoo-2-a0138fbe0b08eb18887479f16b9ac75e58198802.zip
Fixed for parallel build
(Portage version: 2.2_rc12/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-libs/pgplot')
-rw-r--r--sci-libs/pgplot/ChangeLog6
-rw-r--r--sci-libs/pgplot/files/pgplot-makemake.patch66
-rw-r--r--sci-libs/pgplot/pgplot-5.2.2-r3.ebuild21
3 files changed, 71 insertions, 22 deletions
diff --git a/sci-libs/pgplot/ChangeLog b/sci-libs/pgplot/ChangeLog
index d3c019b8c78f..b4672be95a3c 100644
--- a/sci-libs/pgplot/ChangeLog
+++ b/sci-libs/pgplot/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/pgplot
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.14 2008/11/05 21:50:18 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/ChangeLog,v 1.15 2008/11/07 12:56:54 bicatali Exp $
+
+ 07 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/pgplot-makemake.patch, pgplot-5.2.2-r3.ebuild:
+ Fixed for parallel build
*pgplot-5.2.2-r3 (05 Nov 2008)
diff --git a/sci-libs/pgplot/files/pgplot-makemake.patch b/sci-libs/pgplot/files/pgplot-makemake.patch
index 9ee0d6168e21..667ce2f1ee86 100644
--- a/sci-libs/pgplot/files/pgplot-makemake.patch
+++ b/sci-libs/pgplot/files/pgplot-makemake.patch
@@ -1,5 +1,35 @@
---- makemake.orig 2008-10-29 15:32:12.000000000 +0000
-+++ makemake 2008-10-29 20:08:59.000000000 +0000
+--- makemake.orig 2008-11-07 12:53:03.000000000 +0000
++++ makemake 2008-11-07 12:52:33.000000000 +0000
+@@ -73,7 +73,7 @@
+
+ # List the default make targets.
+
+-DEFAULT_TARGETS="lib grfont.dat prog pgplot.doc"
++DEFAULT_TARGETS="lib grfont.dat pgplot.doc"
+
+ # Get the configuration variables.
+
+@@ -199,17 +199,17 @@
+ fi
+
+ if (echo $DRIV_LIST | grep -s xmdriv 2>&1 1>/dev/null); then
+- DEFAULT_TARGETS="$DEFAULT_TARGETS libXmPgplot.a pgmdemo"
++ DEFAULT_TARGETS="$DEFAULT_TARGETS libXmPgplot.a"
+ INSTALL_LIST="$INSTALL_LIST libXmPgplot.a XmPgplot.h"
+ fi
+
+ if (echo $DRIV_LIST | grep -s xadriv 2>&1 1>/dev/null); then
+- DEFAULT_TARGETS="$DEFAULT_TARGETS libXaPgplot.a pgawdemo"
++ DEFAULT_TARGETS="$DEFAULT_TARGETS libXaPgplot.a"
+ INSTALL_LIST="$INSTALL_LIST libXaPgplot.a XaPgplot.h"
+ fi
+
+ if (echo $DRIV_LIST | grep -s tkdriv 2>&1 1>/dev/null); then
+- DEFAULT_TARGETS="$DEFAULT_TARGETS libtkpgplot.a pgtkdemo pgtkdemo.tcl"
++ DEFAULT_TARGETS="$DEFAULT_TARGETS libtkpgplot.a"
+ INSTALL_LIST="$INSTALL_LIST libtkpgplot.a tkpgplot.h"
+ fi
+
@@ -622,7 +622,7 @@
# Fortran compiler and compilation flags
#
@@ -18,16 +48,18 @@
CFLAGD=$CFLAGD
MCOMPL=$MCOMPL
MFLAGC=$MFLAGC
-@@ -658,6 +658,8 @@
+@@ -657,7 +657,10 @@
+ # Shared library creation.
#
SHARED_LIB=$SHARED_LIB
++SHARED_CLIB=$SHARED_CLIB
SHARED_LD=$SHARED_LD
+SHARED_LD_PGPLOT_OPTS=$SHARED_LD_PGPLOT_OPTS
+SHARED_LD_CPGPLOT_OPTS=$SHARED_LD_CPGPLOT_OPTS
#
# The libraries that the shared PGPLOT library depends upon.
# This is for systems that allow one to specify what libraries
-@@ -806,7 +808,8 @@
+@@ -806,7 +809,8 @@
# libraries.
#-----------------------------------------------------------------------
@@ -37,7 +69,7 @@
libpgplot.a : $(PG_ROUTINES) $(PG_NON_STANDARD) $(GR_ROUTINES) \
$(DISPATCH_ROUTINE) $(DRIVERS) $(SYSTEM_ROUTINES)
-@@ -816,6 +819,16 @@
+@@ -816,6 +820,16 @@
$(DRIVERS) $(SYSTEM_ROUTINES) | sort | uniq`
$(RANLIB) libpgplot.a
@@ -50,11 +82,11 @@
+ $(SHARED_LD) $(SHARED_LD_PGPLOT_OPTS) `ls $(PG_ROUTINES) \
+ $(PG_NON_STANDARD) $(GR_ROUTINES) $(DISPATCH_ROUTINE) \
+ $(DRIVERS) $(SYSTEM_ROUTINES) | sort | uniq` $(SHARED_LIB_LIBS)
-+
++ ln -s $(SHARED_LIB) libpgplot.so
EOD
# Emit the shared library dependency if requested.
-@@ -824,7 +837,7 @@
+@@ -824,7 +838,7 @@
cat >> makefile << \EOD
$(SHARED_LIB): $(PG_ROUTINES) $(PG_NON_STANDARD) \
$(GR_ROUTINES) $(DISPATCH_ROUTINE) $(DRIVERS) $(SYSTEM_ROUTINES)
@@ -63,7 +95,7 @@
$(PG_NON_STANDARD) $(GR_ROUTINES) $(DISPATCH_ROUTINE) \
$(DRIVERS) $(SYSTEM_ROUTINES) | sort | uniq` $(SHARED_LIB_LIBS)
EOD
-@@ -1025,7 +1038,7 @@
+@@ -1025,12 +1039,12 @@
grivas.o : $(DRVDIR)/gadef.h
grtv00.o : $(DRVDIR)/imdef.h
pgxwin.o : $(DRVDIR)/pgxwin.h
@@ -72,7 +104,13 @@
x2driv.o figdisp_comm.o: $(DRVDIR)/commands.h
-@@ -1039,6 +1052,8 @@
+
+-cpg: libcpgplot.a cpgplot.h cpgdemo
++cpg: cpgplot.h libcpgplot.a
+ @echo ' '
+ @echo '*** Finished compilation of the C PGPLOT wrapper library ***'
+ @echo ' '
+@@ -1039,17 +1053,29 @@
@echo 'will be needed.'
@echo ' '
@@ -81,7 +119,14 @@
pgbind: $(SRC)/cpg/pgbind.c
$(CCOMPL) $(CFLAGC) $(SRC)/cpg/pgbind.c -o pgbind
-@@ -1050,6 +1065,13 @@
+-libcpgplot.a cpgplot.h: $(PG_SOURCE) pgbind
++cpgplot.h: $(PG_SOURCE) pgbind
+ ./pgbind $(PGBIND_FLAGS) -h -w $(PG_SOURCE)
++
++libcpgplot.a: cpgplot.h
+ $(CCOMPL) -c $(CFLAGC) cpg*.c
+ rm -f cpg*.c
+ ar ru libcpgplot.a cpg*.o
$(RANLIB) libcpgplot.a
rm -f cpg*.o
@@ -90,6 +135,7 @@
+ $(CCOMPL) -c $(CFLAGC) cpg*.c
+ rm -f cpg*.c
+ $(SHARED_LD) $(SHARED_LD_CPGPLOT_OPTS) cpg*.o -lpgplot $(SHARED_LIB_LIBS)
++ ln -s $(SHARED_CLIB) libcpgplot.so
+ rm -f cpg*.o
+
cpgdemo: cpgplot.h $(SRC)/cpg/cpgdemo.c libcpgplot.a
diff --git a/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild b/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild
index 6c57570df1bd..d2d62720f09b 100644
--- a/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild
+++ b/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild,v 1.1 2008/11/05 21:50:18 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/pgplot/pgplot-5.2.2-r3.ebuild,v 1.2 2008/11/07 12:56:54 bicatali Exp $
inherit eutils toolchain-funcs fortran
@@ -82,14 +82,15 @@ src_unpack() {
src_compile() {
./makemake . linux
-
- emake all cpg || die "emake failed"
+ einfo "Doing static libs and execs"
+ emake all cpg || die "emake static failed"
emake clean
- einfo "Doing "
+ einfo "Doing shared libs"
emake \
CFLAGS="${CFLAGS} -fPIC" \
FFLAGS="${FFLAGS} -fPIC" \
- shared cpg-shared || die "emake shared failed"
+ shared cpg-shared \
+ || die "emake shared failed"
if use doc; then
emake pgplot.html || die "make pgplot.html failed"
@@ -110,7 +111,7 @@ src_test() {
# j can also be LATEX CPS...
for j in NULL PNG PS CPS LATEX; do
local testexe=./test_${j}_${i}
- echo "./pgdemo${i} <<EOF" > ${testexe}
+ echo "LD_LIBRARY_PATH=. ./pgdemo${i} <<EOF" > ${testexe}
echo "/${j}" >> ${testexe}
echo "EOF" >> ${testexe}
sh ${testexe} || die "test ${i} failed"
@@ -120,20 +121,18 @@ src_test() {
src_install() {
insinto /usr/$(get_libdir)/pgplot
- doins grfont.dat grexec.f *.inc rgb.txt
+ doins grfont.dat grexec.f *.inc rgb.txt || die
# FORTRAN libs
dolib.a libpgplot.a || die "dolib.a failed"
- dolib.so libpgplot.so.5 || die "dolib.so failed"
- dosym libpgplot.so.5 /usr/$(get_libdir)/libpgplot.so || die
+ dolib.so libpgplot.so* || die "dolib.so failed"
dobin pgxwin_server pgdisp || die "dobin failed"
# C binding
insinto /usr/include
doins cpgplot.h || die "doins C binding failed"
dolib.a libcpgplot.a || die "dolib.a failed"
- dolib.so libcpgplot.so.5 || die "dolib C failed"
- dosym libcpgplot.so.5 /usr/$(get_libdir)/libcpgplot.so || die
+ dolib.so libcpgplot.so* || die "dolib C failed"
if use motif; then
doins XmPgplot.h || die "doins motif failed"