summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-11-20 22:12:29 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-11-20 22:12:29 +0000
commit28b1799505f9dd79ce4e3d40db9b0f7d7065cce6 (patch)
tree370b676adb480b19d66db69e684d348e0276ef77 /sci-libs/nlopt
parentAdding myself in metadata so that package doesn't go unmaintained (diff)
downloadgentoo-2-28b1799505f9dd79ce4e3d40db9b0f7d7065cce6.tar.gz
gentoo-2-28b1799505f9dd79ce4e3d40db9b0f7d7065cce6.tar.bz2
gentoo-2-28b1799505f9dd79ce4e3d40db9b0f7d7065cce6.zip
Version bump, thanks Jean-Francis Roy for his contribution
(Portage version: 2.2_rc50/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/nlopt')
-rw-r--r--sci-libs/nlopt/ChangeLog7
-rw-r--r--sci-libs/nlopt/nlopt-1.2.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/sci-libs/nlopt/ChangeLog b/sci-libs/nlopt/ChangeLog
index a803b9e2bf29..70da538ce229 100644
--- a/sci-libs/nlopt/ChangeLog
+++ b/sci-libs/nlopt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/nlopt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.1 2009/07/10 19:27:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/ChangeLog,v 1.2 2009/11/20 22:12:29 bicatali Exp $
+
+*nlopt-1.2 (20 Nov 2009)
+
+ 20 Nov 2009; Sébastien Fabbro <bicatali@gentoo.org> +nlopt-1.2.ebuild:
+ Version bump, thanks Jean-Francis Roy for his contribution
*nlopt-1.0.1 (10 Jul 2009)
diff --git a/sci-libs/nlopt/nlopt-1.2.ebuild b/sci-libs/nlopt/nlopt-1.2.ebuild
new file mode 100644
index 000000000000..ae1673e9df99
--- /dev/null
+++ b/sci-libs/nlopt/nlopt-1.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/nlopt/nlopt-1.2.ebuild,v 1.1 2009/11/20 22:12:29 bicatali Exp $
+
+EAPI=2
+inherit eutils
+
+DESCRIPTION="Non-linear optimization library"
+SRC_URI="http://ab-initio.mit.edu/nlopt/${P}.tar.gz"
+HOMEPAGE="http://ab-initio.mit.edu/nlopt/"
+
+LICENSE="LGPL-2.1 MIT"
+KEYWORDS="~amd64 ~x86"
+
+SLOT="0"
+IUSE="octave cxx"
+
+DEPEND="octave? ( sci-mathematics/octave )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ if use octave; then
+ export OCT_INSTALL_DIR=/usr/libexec/octave/site/oct/${CHOST}
+ export M_INSTALL_DIR=/usr/share/octave/site/m
+ else
+ export MKOCTFILE=None
+ fi
+ econf \
+ --enable-shared \
+ $(use_with cxx)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+ for r in */README; do newdoc ${r} README.$(dirname ${r}); done
+}