summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-02-19 16:03:02 +0000
committerThomas Kahle <tomka@gentoo.org>2013-02-19 16:03:02 +0000
commitb08052af8db9c983bbb6a8186a5d8e48c42a2421 (patch)
tree19c7c65c2df17aa55785fd250ddb5af3501bb9c8 /sci-libs/mpir
parent[bump] dev-perl/Net-OpenSSH-0.600.0 (diff)
downloadgentoo-2-b08052af8db9c983bbb6a8186a5d8e48c42a2421.tar.gz
gentoo-2-b08052af8db9c983bbb6a8186a5d8e48c42a2421.tar.bz2
gentoo-2-b08052af8db9c983bbb6a8186a5d8e48c42a2421.zip
use systems CC instead of gcc (bug 457912)
(Portage version: 2.1.11.52/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'sci-libs/mpir')
-rw-r--r--sci-libs/mpir/ChangeLog7
-rw-r--r--sci-libs/mpir/mpir-2.6.0-r1.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/sci-libs/mpir/ChangeLog b/sci-libs/mpir/ChangeLog
index d0abe3cae914..11f0c5565b79 100644
--- a/sci-libs/mpir/ChangeLog
+++ b/sci-libs/mpir/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/mpir
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/ChangeLog,v 1.17 2013/02/18 20:34:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/ChangeLog,v 1.18 2013/02/19 16:03:02 tomka Exp $
+
+*mpir-2.6.0-r1 (19 Feb 2013)
+
+ 19 Feb 2013; Thomas Kahle <tomka@gentoo.org> +mpir-2.6.0-r1.ebuild:
+ use systems CC instead of gcc (bug 457912)
18 Feb 2013; Agostino Sarubbo <ago@gentoo.org> mpir-2.6.0.ebuild:
Stable for ppc, wrt bug #457822
diff --git a/sci-libs/mpir/mpir-2.6.0-r1.ebuild b/sci-libs/mpir/mpir-2.6.0-r1.ebuild
new file mode 100644
index 000000000000..f18e6567c1f8
--- /dev/null
+++ b/sci-libs/mpir/mpir-2.6.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mpir/mpir-2.6.0-r1.ebuild,v 1.1 2013/02/19 16:03:02 tomka Exp $
+
+EAPI=4
+
+inherit autotools-utils eutils toolchain-funcs
+
+DESCRIPTION="Library for arbitrary precision integer arithmetic (fork of gmp)"
+HOMEPAGE="http://www.mpir.org/"
+SRC_URI="http://www.mpir.org/${P}.tar.lzma"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+cxx cpudetection static-libs"
+
+DEPEND="x86? ( dev-lang/yasm )
+ amd64? ( dev-lang/yasm )"
+RDEPEND=""
+
+src_prepare() {
+ tc-export CC
+ epatch \
+ "${FILESDIR}"/${PN}-2.6.0-yasm.patch \
+ "${FILESDIR}"/${PN}-1.3.0-ABI-multilib.patch \
+ "${FILESDIR}"/${PN}-2.5.1-automake-1.12.patch
+
+ # In the same way there was QA regarding executable stacks
+ # with GMP we have some here as well. We cannot apply the
+ # GMP solution as yasm is used, at least on x86/amd64.
+ # Furthermore we are able to patch config.ac.
+ ebegin "Patching assembler files to remove executable sections"
+ local i
+ for i in $(find . -type f -name '*.asm') ; do
+ cat >> $i <<-EOF
+ #if defined(__linux__) && defined(__ELF__)
+ .section .note.GNU-stack,"",%progbits
+ #endif
+ EOF
+ done
+
+ for i in $(find . -type f -name '*.as') ; do
+ cat >> $i <<-EOF
+ %ifidn __OUTPUT_FORMAT__,elf
+ section .note.GNU-stack noalloc noexec nowrite progbits
+ %endif
+ EOF
+ done
+ eend
+ eautoreconf
+}
+
+src_configure() {
+ # beware that cpudetection aka fat binaries is x86/amd64 only.
+ # Place mpir in profiles/arch/$arch/package.use.mask
+ # when making it available on $arch.
+ myeconfargs+=(
+ $(use_enable cxx)
+ $(use_enable cpudetection fat)
+ )
+ autotools-utils_src_configure
+}