summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2013-01-16 10:14:00 +0000
committerThomas Kahle <tomka@gentoo.org>2013-01-16 10:14:00 +0000
commit7a54de573ace887930cd9ada03d8d2b900140db5 (patch)
tree53e5b65f70d0aadff29def814ad10f6da06e802c /sci-libs/mpir/files
parentMigrate to distutils-r1. (diff)
downloadgentoo-2-7a54de573ace887930cd9ada03d8d2b900140db5.tar.gz
gentoo-2-7a54de573ace887930cd9ada03d8d2b900140db5.tar.bz2
gentoo-2-7a54de573ace887930cd9ada03d8d2b900140db5.zip
bump (bug 452340), remove old
(Portage version: 2.1.11.42/cvs/Linux x86_64, signed Manifest commit with key 0x89DEB219565C32BC)
Diffstat (limited to 'sci-libs/mpir/files')
-rw-r--r--sci-libs/mpir/files/mpir-2.6.0-yasm.patch52
1 files changed, 52 insertions, 0 deletions
diff --git a/sci-libs/mpir/files/mpir-2.6.0-yasm.patch b/sci-libs/mpir/files/mpir-2.6.0-yasm.patch
new file mode 100644
index 000000000000..3c6b1881f170
--- /dev/null
+++ b/sci-libs/mpir/files/mpir-2.6.0-yasm.patch
@@ -0,0 +1,52 @@
+diff -U 3 -dHrN mpir-2.6.0.orig/configure.in mpir-2.6.0/configure.in
+--- mpir-2.6.0.orig/configure.in 2013-01-16 10:51:13.141047276 +0100
++++ mpir-2.6.0/configure.in 2013-01-16 10:51:52.437353115 +0100
+@@ -1295,8 +1295,6 @@
+ ;;
+ esac
+
+-AM_CONDITIONAL(BUILD_YASM, test "$want_yasm" = "yes")
+-
+ CFLAGS_or_unset=${CFLAGS-'(unset)'}
+ CPPFLAGS_or_unset=${CPPFLAGS-'(unset)'}
+
+@@ -1681,7 +1679,7 @@
+ GMP_CHECK_LIBM_FOR_BUILD
+
+
+-MPIR_AS="/yasm/yasm"
++MPIR_AS="yasm"
+
+ # How to assemble, used with CFLAGS etc, see mpn/Makeasm.am.
+ # Using the compiler is a lot easier than figuring out how to invoke the
+@@ -2984,7 +2982,6 @@
+ # Right now automake isn't accepting the new AC_CONFIG_FILES scheme.
+
+ # allways configure all subdirectorys , even if there are not going to be built ,
+-AC_CONFIG_SUBDIRS([yasm])
+
+ case $host in
+ *-w64-mingw*)
+diff -U 3 -dHrN mpir-2.6.0.orig/Makefile.am mpir-2.6.0/Makefile.am
+--- mpir-2.6.0.orig/Makefile.am 2013-01-16 10:51:13.121047120 +0100
++++ mpir-2.6.0/Makefile.am 2013-01-16 10:52:25.675611816 +0100
+@@ -98,10 +98,6 @@
+
+ SUBDIRS = tests
+
+-if BUILD_YASM
+-SUBDIRS += yasm
+-endif
+-
+ SUBDIRS += mpn fft mpz mpq mpf printf scanf cxx tune doc
+
+ EXTRA_DIST = configfsf.guess configfsf.sub .gdbinit INSTALL.autoconf
+diff -U 3 -dHrN mpir-2.6.0.orig/mpn/Makeasm.am mpir-2.6.0/mpn/Makeasm.am
+--- mpir-2.6.0.orig/mpn/Makeasm.am 2013-01-16 10:51:13.045046528 +0100
++++ mpir-2.6.0/mpn/Makeasm.am 2013-01-16 10:53:25.333076126 +0100
+@@ -119,4 +119,4 @@
+ # .as assembler, assembled with Yasm
+
+ .as.lo:
+- $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(top_builddir)$(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
++ $(LIBTOOL) --mode=compile --tag=CC $(top_srcdir)/strip_fPIC.sh $(MPIR_AS) -I $(top_builddir) $(OBJECT_FORMAT) $(GSYM_FLAG) -o $@ `test -f '$<' || echo '$(srcdir)/'`$<