summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-23 21:21:28 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-23 21:21:28 +0000
commit6879c87076554e6f01759a16c1ae6eb85b133d4f (patch)
tree1f13e35d192ad9247ff3bca0156ae3c4503ff14e /sci-libs/mkl
parentRemove redudant depend which was used to force 32bit and 64bit libpng match. (diff)
downloadgentoo-2-6879c87076554e6f01759a16c1ae6eb85b133d4f.tar.gz
gentoo-2-6879c87076554e6f01759a16c1ae6eb85b133d4f.tar.bz2
gentoo-2-6879c87076554e6f01759a16c1ae6eb85b133d4f.zip
Fixed check-reqs.eclass usage, #388237; cleaned old
(Portage version: 2.2.0_alpha70/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mkl')
-rw-r--r--sci-libs/mkl/ChangeLog6
-rw-r--r--sci-libs/mkl/metadata.xml14
-rw-r--r--sci-libs/mkl/mkl-10.0.2.018-r2.ebuild354
-rw-r--r--sci-libs/mkl/mkl-10.0.5.025.ebuild7
-rw-r--r--sci-libs/mkl/mkl-9.1.023.ebuild327
5 files changed, 16 insertions, 692 deletions
diff --git a/sci-libs/mkl/ChangeLog b/sci-libs/mkl/ChangeLog
index a077fc1bc05a..6c70ad9ee0ad 100644
--- a/sci-libs/mkl/ChangeLog
+++ b/sci-libs/mkl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/mkl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/ChangeLog,v 1.45 2011/10/21 16:40:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/ChangeLog,v 1.46 2011/10/23 21:21:28 jlec Exp $
+
+ 23 Oct 2011; Justin Lecher <jlec@gentoo.org> -mkl-10.0.2.018-r2.ebuild,
+ -mkl-9.1.023.ebuild, metadata.xml, mkl-10.0.5.025.ebuild:
+ Fixed check-reqs.eclass usage, #388237; cleaned old
21 Jun 2011; Justin Lecher <jlec@gentoo.org> mkl-9.1.023.ebuild,
mkl-10.0.2.018-r2.ebuild, mkl-10.0.5.025.ebuild:
diff --git a/sci-libs/mkl/metadata.xml b/sci-libs/mkl/metadata.xml
index ad6bce739874..adcf2aefe7f8 100644
--- a/sci-libs/mkl/metadata.xml
+++ b/sci-libs/mkl/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <longdescription lang="en">
The Intel(R) Math Kernel Library is a mathematical library mostly
optimized for Intel processors (also works on AMDs). It contains BLAS
and LAPACK implementations, Fast Fourier Transforms, a vector math
@@ -10,9 +10,9 @@
capacities. The package is installed as binary and has a restrictive
license. Please see license terms and home page for proper use.
</longdescription>
-<use>
- <flag name='fortran95'>Installs the BLAS/LAPACK FORTRAN95 static libraries</flag>
- <flag name='int64'>Installs the 64 bits integer libraries</flag>
- <flag name='serial'>Installs the serial (as non-threaded) libraries</flag>
-</use>
+ <use>
+ <flag name="fortran95">Installs the BLAS/LAPACK FORTRAN95 static libraries</flag>
+ <flag name="int64">Installs the 64 bits integer libraries</flag>
+ <flag name="serial">Installs the serial (as non-threaded) libraries</flag>
+ </use>
</pkgmetadata>
diff --git a/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild b/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild
deleted file mode 100644
index 8c359de42299..000000000000
--- a/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild
+++ /dev/null
@@ -1,354 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.2.018-r2.ebuild,v 1.10 2011/06/21 15:12:15 jlec Exp $
-
-inherit eutils fortran-2 toolchain-funcs check-reqs
-
-PID=967
-PB=${PN}
-DESCRIPTION="Intel(R) Math Kernel Library: linear algebra, fft, math functions"
-HOMEPAGE="http://developer.intel.com/software/products/mkl/"
-
-KEYWORDS="~amd64 ~ia64 ~x86"
-SRC_URI="http://registrationcenter-download.intel.com/irc_nas/${PID}/l_${PN}_p_${PV}.tgz"
-
-SLOT="0"
-LICENSE="Intel-SDP"
-
-IUSE="doc fftw fortran95 int64 mpi"
-RESTRICT="strip mirror"
-
-DEPEND="
- app-admin/eselect-blas
- app-admin/eselect-cblas
- app-admin/eselect-lapack
- virtual/fortran"
-
-RDEPEND="${DEPEND}
- doc? ( app-doc/blas-docs app-doc/lapack-docs )
- mpi? ( virtual/mpi )"
-
-MKL_DIR=/opt/intel/${PN}/${PV}
-INTEL_LIC_DIR=/opt/intel/licenses
-
-get_fcomp() {
- case $(tc-getFC) in
- *gfortran* )
- FCOMP="gfortran" ;;
- ifort )
- FCOMP="ifc" ;;
- * )
- FCOMP=$(tc-getFC) ;;
- esac
-}
-
-pkg_setup() {
- fortran-2_pkg_setup
- # Check the license
- if [[ -z ${MKL_LICENSE} ]]; then
- MKL_LICENSE="$(grep -ls MKern ${ROOT}${INTEL_LIC_DIR}/* | tail -n 1)"
- MKL_LICENSE=${MKL_LICENSE/${ROOT}/}
- fi
- if [[ -z ${MKL_LICENSE} ]]; then
- eerror "Did not find any valid mkl license."
- eerror "Register at ${HOMEPAGE} to receive a license"
- eerror "and place it in ${INTEL_LIC_DIR} or run:"
- eerror "export MKL_LICENSE=/my/license/file emerge mkl"
- die "license setup failed"
- fi
-
- # Check if we have enough free diskspace to install
- CHECKREQS_DISK_BUILD="1100"
- check_reqs
-
- # Check and setup fortran
- if use fortran95; then
- # blas95 and lapack95 don't compile with gfortran < 4.2
- [[ $(tc-getFC) =~ (gfortran|g77) ]] && [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] &&
- die "blas95 and lapack95 don't compile with gfortran < 4.2"
- fi
- MKL_FC="gnu"
- [[ $(tc-getFC) =~ if ]] && MKL_FC="intel"
-
- # build profiles according to what compiler is installed
- MKL_CC="gnu"
- [[ $(tc-getCC) == icc ]] && MKL_CC="intel"
-
- if has_version sys-cluster/mpich; then
- MKL_MPI=mpich
- elif has_version sys-cluster/mpich2; then
- MKL_MPI=mpich2
- elif has_version sys-cluster/openmpi; then
- MKL_MPI=openmpi
- else
- MKL_MPI=intelmpi
- fi
- get_fcomp
-}
-
-src_unpack() {
-
- unpack ${A}
- cd l_${PN}_*_${PV}/install
-
- cp ${MKL_LICENSE} "${WORKDIR}"/
- MKL_LIC="$(basename ${MKL_LICENSE})"
-
- # binary blob extractor installs rpm leftovers in /opt/intel
- addwrite /opt/intel
- # undocumented features: INSTALLMODE_mkl=NONRPM
-
- # We need to install mkl non-interactively.
- # If things change between versions, first do it interactively:
- # tar xf l_*; ./install.sh --duplicate mkl.ini;
- # The file will be instman/mkl.ini
- # Then check it and modify the ebuild-created one below
- # --norpm is required to be able to install 10.x
- cat > mkl.ini <<-EOF
- [MKL]
- EULA_ACCEPT_REJECT=ACCEPT
- FLEXLM_LICENSE_LOCATION=${WORKDIR}/${MKL_LIC}
- INSTALLMODE_mkl=NONRPM
- INSTALL_DESTINATION=${S}
- EOF
- einfo "Extracting ..."
- ./install \
- --silent ./mkl.ini \
- --installpath "${S}" \
- --log log.txt &> /dev/null
-
- if [[ -z $(find "${S}" -name libmkl.so) ]]; then
- eerror "Could not find extracted files"
- eerror "See ${PWD}/log.txt to see why"
- die "extracting failed"
- fi
- # remove left over
- rm -f /opt/intel/.*mkl*.log /opt/intel/intel_sdp_products.db
-
- # remove unused stuff and set up intel names
- rm -rf "${WORKDIR}"/l_*
-
- cd "${S}"
- # allow openmpi to work
- epatch "${FILESDIR}"/${P}-openmpi.patch
- # make scalapack tests work for gfortran
- epatch "${FILESDIR}"/${P}-tests.patch
- case ${ARCH} in
- x86) MKL_ARCH=32
- MKL_KERN=ia32
- rm -rf lib*/{em64t,64}
- ;;
-
- amd64) MKL_ARCH=em64t
- MKL_KERN=em64t
- rm -rf lib*/{32,64}
- ;;
-
- ia64) MKL_ARCH=64
- MKL_KERN=ipf
- rm -rf lib*/{32,em64t}
- ;;
- esac
- MKL_LIBDIR=${MKL_DIR}/lib/${MKL_ARCH}
-}
-
-src_compile() {
- cd "${S}"/interfaces
- if use fortran95; then
- einfo "Compiling fortan95 static lib wrappers"
- local myconf="lib${MKL_ARCH}"
- [[ $(tc-getFC) =~ gfortran ]] && \
- myconf="${myconf} FC=gfortran"
- if use int64; then
- myconf="${myconf} interface=ilp64"
- [[ $(tc-getFC) =~ gfortran ]] && \
- myconf="${myconf} FOPTS=-fdefault-integer-8"
- fi
- for x in blas95 lapack95; do
- pushd ${x}
- emake ${myconf} || die "emake ${x} failed"
- popd
- done
- fi
-
- if use fftw; then
- local fftwdirs="fftw2xc fftw2xf fftw3xc fftw3xf"
- local myconf="lib${MKL_ARCH} compiler=${MKL_CC}"
- if use mpi; then
- fftwdirs="${fftwdirs} fftw2x_cdft"
- myconf="${myconf} mpi=${MKL_MPI}"
- fi
- einfo "Compiling fftw static lib wrappers"
- for x in ${fftwdirs}; do
- pushd ${x}
- emake ${myconf} || die "emake ${x} failed"
- popd
- done
- fi
-}
-
-src_test() {
- cd "${S}"/tests
- local myconf
- local testdirs="blas cblas"
- use int64 && myconf="${myconf} interface=ilp64"
- if use mpi; then
- testdirs="${testdirs} scalapack"
- myconf="${myconf} mpi=${MKL_MPI}"
- fi
- for x in ${testdirs}; do
- pushd ${x}
- einfo "Testing ${x}"
- emake \
- compiler=${MKL_FC} \
- ${myconf} \
- so${MKL_ARCH} \
- || die "emake ${x} failed"
- popd
- done
-}
-
-mkl_make_generic_profile() {
- cd "${S}"
- # produce eselect files
- # don't make them in FILESDIR, it changes every major version
- cat > eselect.blas <<-EOF
- ${MKL_LIBDIR}/libmkl_${MKL_KERN}.a /usr/@LIBDIR@/libblas.a
- ${MKL_LIBDIR}/libmkl.so /usr/@LIBDIR@/libblas.so
- ${MKL_LIBDIR}/libmkl.so /usr/@LIBDIR@/libblas.so.0
- EOF
- cat > eselect.cblas <<-EOF
- ${MKL_LIBDIR}/libmkl_${MKL_KERN}.a /usr/@LIBDIR@/libcblas.a
- ${MKL_LIBDIR}/libmkl.so /usr/@LIBDIR@/libcblas.so
- ${MKL_LIBDIR}/libmkl.so /usr/@LIBDIR@/libcblas.so.0
- ${MKL_DIR}/include/mkl_cblas.h /usr/include/cblas.h
- EOF
- cat > eselect.lapack <<-EOF
- ${MKL_LIBDIR}/libmkl_lapack.a /usr/@LIBDIR@/liblapack.a
- ${MKL_LIBDIR}/libmkl_lapack.so /usr/@LIBDIR@/liblapack.so
- ${MKL_LIBDIR}/libmkl_lapack.so /usr/@LIBDIR@/liblapack.so.0
- EOF
-}
-
-# usage: mkl_add_profile <profile> <interface_lib> <thread_lib> <rtl_lib>
-mkl_add_profile() {
- cd "${S}"
- local prof=${1}
- for x in blas cblas lapack; do
- cat > ${x}-${prof}.pc <<-EOF
- prefix=${MKL_DIR}
- libdir=${MKL_LIBDIR}
- includedir=\${prefix}/include
- Name: ${x}
- Description: Intel(R) Math Kernel Library implementation of ${x}
- Version: ${PV}
- URL: ${HOMEPAGE}
- EOF
- done
- cat >> blas-${prof}.pc <<-EOF
- Libs: -Wl,--no-as-needed -L\${libdir} ${2} ${3} -lmkl_core ${4} -lpthread
- EOF
- cat >> cblas-${prof}.pc <<-EOF
- Requires: blas
- Libs: -Wl,--no-as-needed -L\${libdir} ${2} ${3} -lmkl_core ${4} -lpthread
- Cflags: -I\${includedir}
- EOF
- cat >> lapack-${prof}.pc <<-EOF
- Requires: blas
- Libs: -Wl,--no-as-needed -L\${libdir} ${2} ${3} -lmkl_core -lmkl_lapack ${4} -lpthread
- EOF
- insinto ${MKL_LIBDIR}
- for x in blas cblas lapack; do
- doins ${x}-${prof}.pc
- cp eselect.${x} eselect.${x}.${prof}
- echo "${MKL_LIBDIR}/${x}-${prof}.pc /usr/@LIBDIR@/pkgconfig/${x}.pc" \
- >> eselect.${x}.${prof}
- eselect ${x} add $(get_libdir) eselect.${x}.${prof} ${prof}
- done
-}
-
-mkl_make_profiles() {
- local clib
- has_version 'dev-lang/ifc' && clib="intel"
- built_with_use sys-devel/gcc fortran && clib="${clib} gf"
- local slib="-lmkl_sequential"
- local rlib="-liomp5"
- local pbase=${PN}
- for c in ${clib}; do
- local ilib="-lmkl_${c}_lp64"
- use x86 && ilib="-lmkl_${c}"
- local tlib="-lmkl_${c/gf/gnu}_thread"
- local comp="${c/gf/gfortran}"
- comp="${comp/intel/ifort}"
- mkl_add_profile ${pbase}-${comp} ${ilib} ${slib}
- mkl_add_profile ${pbase}-${comp}-threads ${ilib} ${tlib} ${rlib}
- if use int64; then
- ilib="-lmkl_${c}_ilp64"
- mkl_add_profile ${pbase}-${comp}-int64 ${ilib} ${slib}
- mkl_add_profile ${pbase}-${comp}-threads-int64 ${ilib} ${tlib} ${rlib}
- fi
- done
-}
-
-src_install() {
- dodir ${MKL_DIR}
- # upstream installs a link, no idea why
- dosym ${MKL_DIR} ${MKL_DIR/mkl/cmkl}
-
- # install license
- if [[ ! -f ${INTEL_LIC_DIR}/${MKL_LIC} ]]; then
- insinto ${INTEL_LIC_DIR}
- doins "${WORKDIR}"/${MKL_LIC} || die "install license failed"
- fi
-
- # install main stuff: cp faster than doins
- einfo "Installing files..."
- local cpdirs="benchmarks doc examples include interfaces lib man tests"
- local doinsdirs="tools"
- cp -pPR ${cpdirs} "${D}"${MKL_DIR} \
- || die "installing mkl failed"
- insinto ${MKL_DIR}
- doins -r ${doinsdirs} || die "doins ${doinsdirs} failed"
- dosym mkl_cblas.h ${MKL_DIR}/include/cblas.h
-
- # install blas/lapack profiles
- mkl_make_generic_profile
- mkl_make_profiles
-
- # install env variables
- local env_file=35mkl
- echo "LDPATH=${MKL_LIBDIR}" > ${env_file}
- echo "MANPATH=${MKL_DIR}/man" >> ${env_file}
- doenvd ${env_file} || die "doenvd failed"
-}
-
-pkg_postinst() {
- # if blas profile is mkl, set lapack and cblas profiles as mkl
- local blas_prof=$(eselect blas show | cut -d' ' -f2)
- local def_prof="mkl-gfortran-threads"
- has_version 'dev-lang/ifc' && def_prof="mkl-ifort-threads"
- use int64 && def_prof="${def_prof}-int64"
- for x in blas cblas lapack; do
- local cur_prof=$(eselect ${x} show | cut -d' ' -f2)
- if [[ -z ${cur_prof} || ${cur_prof} == ${def_prof} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${x}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${x} set ${def_prof}
- elog "${x} has been eselected to ${def_prof}"
- else
- elog "Current eselected ${x} is ${current_lib}"
- elog "To use one of mkl profiles, issue (as root):"
- elog "\t eselect ${x} set <profile>"
- fi
- if [[ ${blas_prof} == mkl* && ${cur_prof} != ${blas_prof} ]]; then
- eselect blas set ${def_prof}
- elog "${x} is now set to ${def_prof} for consistency"
- fi
- done
- if [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]]; then
- elog "Multi-threading OpenMP for GNU compilers only available"
- elog "with gcc >= 4.2. Make sure you have a compatible version"
- elog "and select it with gcc-config before selecting gnu profiles"
- fi
-}
diff --git a/sci-libs/mkl/mkl-10.0.5.025.ebuild b/sci-libs/mkl/mkl-10.0.5.025.ebuild
index 0ff2e5381b6d..8f408f67a669 100644
--- a/sci-libs/mkl/mkl-10.0.5.025.ebuild
+++ b/sci-libs/mkl/mkl-10.0.5.025.ebuild
@@ -1,11 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.14 2011/10/21 16:40:44 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-10.0.5.025.ebuild,v 1.15 2011/10/23 21:21:28 jlec Exp $
inherit eutils fortran-2 toolchain-funcs check-reqs
PID=1232
PB=${PN}
+
DESCRIPTION="Intel(R) Math Kernel Library: linear algebra, fft, math functions"
HOMEPAGE="http://developer.intel.com/software/products/mkl/"
SRC_URI="http://registrationcenter-download.intel.com/irc_nas/${PID}/l_${PN}_p_${PV}.tgz"
@@ -58,8 +59,8 @@ pkg_setup() {
fi
# Check if we have enough free diskspace to install
- CHECKREQS_DISK_BUILD="1100"
- check_reqs
+ CHECKREQS_DISK_BUILD="1100M"
+ check_reqs_pkg_setup
# Check and setup fortran
if use fortran95; then
diff --git a/sci-libs/mkl/mkl-9.1.023.ebuild b/sci-libs/mkl/mkl-9.1.023.ebuild
deleted file mode 100644
index c2d9f3e633bd..000000000000
--- a/sci-libs/mkl/mkl-9.1.023.ebuild
+++ /dev/null
@@ -1,327 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mkl/mkl-9.1.023.ebuild,v 1.16 2011/06/21 15:12:15 jlec Exp $
-
-inherit eutils fortran-2 versionator toolchain-funcs
-
-PID=779
-PB=${PN}
-DESCRIPTION="Intel(R) Math Kernel Library: linear algebra, fft, random number generators."
-HOMEPAGE="http://developer.intel.com/software/products/mkl/"
-
-KEYWORDS="~x86 ~amd64 ~ia64"
-SRC_URI="!int64? ( !serial? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/l_${PN}_p_${PV}.tgz ) )
- int64? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/l_${PN}_enh_p_${PV}.tgz )
- serial? ( http://registrationcenter-download.intel.com/irc_nas/${PID}/l_${PN}_enh_p_${PV}.tgz )"
-
-MAJOR=$(get_major_version ${PV})
-MINOR=$(get_version_component_range 2 ${PV})
-
-#slotting not yet supported
-#SLOT="${MAJOR}.${MINOR}"
-SLOT="0"
-LICENSE="Intel-SDP"
-
-IUSE="serial int64 fortran95 fftw doc examples"
-RESTRICT="strip mirror"
-
-DEPEND="
- app-admin/eselect-blas
- app-admin/eselect-cblas
- app-admin/eselect-lapack
- virtual/fortran"
-
-RDEPEND="${DEPEND}
- doc? ( app-doc/blas-docs app-doc/lapack-docs )"
-
-MKL_DIR=/opt/intel/${PN}/${MAJOR}.${MINOR}
-
-get_fcomp() {
- case $(tc-getFC) in
- *gfortran* )
- FCOMP="gfortran" ;;
- ifort )
- FCOMP="ifc" ;;
- * )
- FCOMP=$(tc-getFC) ;;
- esac
-}
-
-pkg_setup() {
- fortran-2_pkg_setup
- # setting up license
- [[ -z ${MKL_LICENSE} && -d /opt/intel/licenses ]] && \
- MKL_LICENSE=$(find /opt/intel/licenses -name *MKL*.lic)
-
- if [[ -z ${MKL_LICENSE} ]]; then
- eerror "Did not find any valid mkl license."
- eerror "Please locate your license file and run:"
- eerror "\t MKL_LICENSE=/my/license/dir emerge ${PN}"
- eerror "or place your license in /opt/intel/licenses"
- eerror "Hint: the license file is in the email Intel sent you"
- die "setup mkl license failed"
- fi
-
- # setting up compilers
- MKL_CC=gnu
- [[ $(tc-getCC) == icc ]] && MKL_CC=icc
- get_fcomp
-}
-
-src_unpack() {
-
- ewarn
- local dp=950
- ! use serial && ! use int64 && dp=400
- ewarn "Intel ${PN} requires ${dp}Mb of disk space"
- ewarn "Make sure you have enough in ${PORTAGE_TMPDIR}, /tmp and in /opt"
- ewarn
- unpack ${A}
-
- cd l_${PN}_*_${PV}/install
-
- # need to make a file to install non-interactively.
- # to produce such a file, first do it interactively
- # tar xf l_*; ./install.sh --duplicate mkl.ini;
- # the file will be instman/mkl.ini
-
- # binary blob extractor installs rpm leftovers in /opt/intel
- addwrite /opt/intel
- cp ${MKL_LICENSE} "${WORKDIR}"/
- MKL_LIC="$(basename ${MKL_LICENSE})"
- cat > mkl.ini <<- EOF
- [MKL]
- EULA_ACCEPT_REJECT=ACCEPT
- FLEXLM_LICENSE_LOCATION=${WORKDIR}/${MKL_LIC}
- INSTALLMODE=NONRPM
- INSTALL_DESTINATION=${S}
- EOF
- einfo "Extracting ..."
- ./install \
- --silent ${PWD}/mkl.ini \
- --log log.txt &> /dev/null
-
- if [[ -z $(find "${S}" -name libmkl.so) ]]; then
- eerror "could not find extracted files"
- eerror "see ${PWD}/log.txt to see why"
- die "extracting failed"
- fi
-
- # remove unused stuff and set up intel names
- rm -rf "${WORKDIR}"/l_*
- case ${ARCH} in
- x86) MKL_ARCH=32
- MKL_KERN=ia32
- rm -rf "${S}"/lib*/*64*
- ;;
- amd64) MKL_ARCH=em64t
- MKL_KERN=em64t
- rm -rf "${S}"/lib*/32 "${S}"/lib*/64
- ;;
- ia64) MKL_ARCH=64
- MKL_KERN=ipf
- rm -rf "${S}"/lib*/32 "${S}"/lib*/em64t
- ;;
- esac
-
- cd "${S}"
-
- # default profile regular is threaded
- MKL_PROF="regular"
- if use serial; then
- MKL_PROF="${MKL_PROF} serial"
- else
- [[ -d lib_serial ]] && rm -rf lib_serial
- fi
- if use int64; then
- MKL_PROF="${MKL_PROF} ilp64"
- else
- [[ -d lib_ilp64 ]] && rm -rf lib_ilp64
- fi
-
- # fix a bad makefile in the test
- if [[ $(tc-getFC) =~ gfortran ]] || [[ $(tc-getFC) =~ if ]]; then
- sed -i \
- -e "s/g77/$(tc-getFC)/" \
- -e 's/-DGNU_USE//' \
- tests/fftf/makefile || die "sed fftf test failed"
- fi
- # fix bad permissions on tools
- find tools -type f -perm /a+w ! -perm /a+x -exec chmod 644 '{}' \; \
- || die "permissions fix failed"
-}
-
-src_compile() {
-
- if use fortran95; then
- for p in ${MKL_PROF}; do
- einfo "Compiling fortan95 static lib wrappers for ${p}"
- for x in blas95 lapack95; do
- cd "${S}"/interfaces/${x}
- emake \
- FC=$(tc-getFC) \
- MKL_SUBVERS=${p} \
- lib${MKL_ARCH} \
- || die "emake $(basename ${x}) failed"
- done
- done
- fi
-
- if use fftw; then
- for p in ${MKL_PROF}; do
- einfo "Compiling fftw static lib wrappers for ${p}"
- for x in "${S}"/interfaces/fft*; do
- cd "${x}"
- emake -j1 \
- F=${MKL_CC} \
- MKL_SUBVERS=${p} \
- lib${MKL_ARCH} \
- || die "emake $(basename ${x}) failed"
- done
- done
- fi
-}
-
-src_test() {
- local usegnu
- [[ $(tc-getFC) =~ (gfortran|g77) ]] && usegnu=gnu
- # restrict tests for blas and cblas for now.
- # for t in blas cblas fft*; do
- for t in blas lapack; do
- cd "${S}"/tests/${t}
- for p in ${MKL_PROF}; do
- einfo "Testing ${t} for ${p}"
- emake -j1 \
- F=${usegnu} \
- FC=$(tc-getFC) \
- MKL_SUBVERS=${p} \
- lib${MKL_ARCH} \
- || die "emake ${t} failed"
- done
- done
-}
-
-# usage: mkl_install_lib <serial|regular|ilp64>
-mkl_install_lib() {
-
- local proflib=lib_${1}
- local prof=${PN}-${1}
- [[ "${1}" == "regular" ]] && proflib=lib && prof=${PN}-threads
- local libdir="${MKL_DIR}/${proflib}/${MKL_ARCH}"
- local extlibs="-L${libdir} -lguide -lpthread"
- [[ "${1}" == "serial" ]] && extlibs=""
-
- [[ $(tc-getFC) =~ gfortran ]] && \
- gfortranlibs="-L${libdir} -lmkl_gfortran"
-
- cp -pPR "${S}"/${proflib} "${D}"${MKL_DIR}
-
- for x in blas cblas; do
- cat > eselect.${x}.${prof} <<- EOF
- ${libdir}/libmkl_${MKL_KERN}.a /usr/@LIBDIR@/lib${x}.a
- ${libdir}/libmkl.so /usr/@LIBDIR@/lib${x}.so
- ${libdir}/libmkl.so /usr/@LIBDIR@/lib${x}.so.0
- ${libdir}/${x}.pc /usr/@LIBDIR@/pkgconfig/${x}.pc
- EOF
-
- [[ ${x} == cblas ]] && \
- echo "${MKL_DIR}/include/mkl_cblas.h /usr/include/cblas.h" \
- >> eselect.${x}.${prof}
- eselect ${x} add $(get_libdir) eselect.${x}.${prof} ${prof}
- sed -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@INCDIR@:${MKL_DIR}/include:" \
- -e "s:@PV@:${PV}:" \
- -e "s:@EXTLIBS@:${extlibs}:g" \
- -e "s:@GFORTRANLIBS@:${gfortranlibs}:g" \
- "${FILESDIR}"/${x}.pc.in > ${x}.pc || die "sed ${x}.pc failed"
- insinto ${libdir}
- doins ${x}.pc
- done
-
- cat > eselect.lapack.${prof} <<- EOF
- ${libdir}/libmkl_lapack.a /usr/@LIBDIR@/liblapack.a
- ${libdir}/libmkl_lapack.so /usr/@LIBDIR@/liblapack.so
- ${libdir}/libmkl_lapack.so /usr/@LIBDIR@/liblapack.so.0
- ${libdir}/lapack.pc /usr/@LIBDIR@/pkgconfig/lapack.pc
- EOF
- sed -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@PV@:${PV}:" \
- -e "s:@EXTLIBS@:${extlibs}:g" \
- -e "s:@GFORTRANLIBS@:${gfortranlibs}:g" \
- "${FILESDIR}"/lapack.pc.in > lapack.pc || die "sed lapack.pc failed"
- insinto ${libdir}
- doins lapack.pc
-
- eselect lapack add $(get_libdir) eselect.lapack.${prof} ${prof}
- echo "LDPATH=${libdir}"
-}
-
-src_install() {
-
- # install license
- if [[ ! -f /opt/intel/licenses/${MKL_LIC} ]]; then
- insinto /opt/intel/licenses
- doins "${WORKDIR}"/${MKL_LIC} || die "install license failed"
- fi
-
- dodir ${MKL_DIR}
- # keep intel dir in /opt as default install
- einfo "Installing headers, man pages and tools"
- # use cp, too slow with doins
- cp -pPR include man tools "${D}"${MKL_DIR} || die "install include|man|tools failed"
-
- if use examples; then
- einfo "Installing examples"
- cp -pPR examples "${D}"${MKL_DIR} || die "install examples failed"
- fi
-
- insinto ${MKL_DIR}/doc
- doins doc/*.txt || die "basic doc install failed"
- if use doc; then
- einfo "Installing documentation"
- cp -pPR doc/*.pdf doc/*.htm "${D}"${MKL_DIR}/doc || die "doc failed"
- fi
-
- # take care of lib and eselect files
- local env_file=35mkl
- for p in ${MKL_PROF}; do
- einfo "Installing profile: ${p}"
- mkl_install_lib ${p} > ${env_file}
- done
-
- echo "MANPATH=${MKL_DIR}/man" >> ${env_file}
- doenvd ${env_file} || die "doenvd failed"
-}
-
-pkg_postinst() {
- # set default profile according to upstream
- local ext=threads
- if use int64; then
- ext=int64
- elif use serial; then
- ext=serial
- fi
- ESELECT_PROF="${PN}-${FCOMP}-${ext}"
- # if blas profile is mkl, set lapack and cblas profiles as mkl
- local blas_lib=$(eselect blas show | cut -d' ' -f2)
- for p in blas cblas lapack; do
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ -z ${current_lib} || \
- ${current_lib} == ${ESELECT_PROF} || \
- ${blas_lib} == ${ESELECT_PROF} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- if [[ ${current_lib} != ${blas_lib} ]]; then
- eselect blas set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF} for consistency"
- fi
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
- done
-}