summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-02-28 12:57:17 +0000
committerJustin Lecher <jlec@gentoo.org>2012-02-28 12:57:17 +0000
commit384092055471b2699530eb3aedf1941df48e2ad9 (patch)
tree177225f5362099bb9680b9fd7d6b8cb6ca6963d0 /sci-libs/mc
parentRestricting jython (diff)
downloadgentoo-2-384092055471b2699530eb3aedf1941df48e2ad9.tar.gz
gentoo-2-384092055471b2699530eb3aedf1941df48e2ad9.tar.bz2
gentoo-2-384092055471b2699530eb3aedf1941df48e2ad9.zip
Moved to autotools-utils, EAPI=4, fix blas/lapack detection and add USE=static-libs
(Portage version: 2.2.0_alpha89/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mc')
-rw-r--r--sci-libs/mc/ChangeLog9
-rw-r--r--sci-libs/mc/files/mc-1.5-unbundle.patch58
-rw-r--r--sci-libs/mc/mc-1.5.ebuild52
-rw-r--r--sci-libs/mc/metadata.xml8
4 files changed, 97 insertions, 30 deletions
diff --git a/sci-libs/mc/ChangeLog b/sci-libs/mc/ChangeLog
index bc7d34a6fc48..a9ad59fdcc91 100644
--- a/sci-libs/mc/ChangeLog
+++ b/sci-libs/mc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/mc
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/ChangeLog,v 1.5 2011/06/21 15:12:17 jlec Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/ChangeLog,v 1.6 2012/02/28 12:57:17 jlec Exp $
+
+ 28 Feb 2012; Justin Lecher <jlec@gentoo.org> mc-1.5.ebuild,
+ +files/mc-1.5-unbundle.patch, metadata.xml:
+ Moved to autotools-utils, EAPI=4, fix blas/lapack detection and add
+ USE=static-libs
21 Jun 2011; Justin Lecher <jlec@gentoo.org> mc-1.4.ebuild, mc-1.5.ebuild:
Add dependency on virtual/fortran
diff --git a/sci-libs/mc/files/mc-1.5-unbundle.patch b/sci-libs/mc/files/mc-1.5-unbundle.patch
new file mode 100644
index 000000000000..5a9a97241980
--- /dev/null
+++ b/sci-libs/mc/files/mc-1.5-unbundle.patch
@@ -0,0 +1,58 @@
+ configure.ac | 38 ++++++--------------------------------
+ 1 files changed, 6 insertions(+), 32 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index 6198ac0..4b1b169 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -191,44 +191,18 @@ dnl # -----------------------
+ dnl # HANDLE THE BLAS LIBRARY
+ dnl # -----------------------
+ blas_lib="";
+-AC_MSG_CHECKING([whether your environment defines FETK_BLAS_LIBRARY])
+-if test -n "${FETK_BLAS_LIBRARY}"; then
+- AC_MSG_RESULT([yes])
+- blas_lib_path="-L${FETK_BLAS_LIBRARY} ";
+-else
+- AC_MSG_RESULT([no])
+- blas_lib_path="-L${FETK_LIBRARY} ";
+-fi
+-LDFLAGS_SAVE=${LDFLAGS};
+-LDFLAGS=${blas_lib_path};
+-blas_use="";
+-AC_CHECK_LIB(blas,dscal_,
+- [blas_use="yes";blas_lib="${blas_lib_path}-lblas";AC_DEFINE(HAVE_BLAS)],
+- [blas_use="";blas_lib=""],
+- [${blas_lib_path}-lblas ${vf2c_lib}])
+-LDFLAGS=${LDFLAGS_SAVE};
++blas_lib_path="";
++PKG_CHECK_MODULES([BLAS], [blas])
++blas_lib="${BLAS_LIBS}";
+ AC_SUBST(blas_lib)
+
+ dnl # -------------------------
+ dnl # HANDLE THE LAPACK LIBRARY
+ dnl # -------------------------
+ lapack_lib="";
+-AC_MSG_CHECKING([whether your environment defines FETK_LAPACK_LIBRARY])
+-if test -n "${FETK_LAPACK_LIBRARY}"; then
+- AC_MSG_RESULT([yes])
+- lapack_lib_path="-L${FETK_LAPACK_LIBRARY} ";
+-else
+- AC_MSG_RESULT([no])
+- lapack_lib_path="-L${FETK_LIBRARY} ";
+-fi
+-LDFLAGS_SAVE=${LDFLAGS};
+-LDFLAGS=${lapack_lib_path};
+-lapack_use="";
+-AC_CHECK_LIB(lapack,dsysv_,
+- [lapack_use="yes";lapack_lib="${lapack_lib_path}-llapack";AC_DEFINE(HAVE_LAPACK)],
+- [lapack_use="";lapack_lib=""],
+- [${lapack_lib_path}-llapack ${blas_lib} ${vf2c_lib}])
+-LDFLAGS=${LDFLAGS_SAVE};
++lapack_lib_path="";
++PKG_CHECK_MODULES([LAPACK], [lapack])
++lapack_lib="${LAPACK_LIBS}"
+ AC_SUBST(lapack_lib)
+
+ dnl # --------------------------
diff --git a/sci-libs/mc/mc-1.5.ebuild b/sci-libs/mc/mc-1.5.ebuild
index 722e00a4d8e7..0339acc531f3 100644
--- a/sci-libs/mc/mc-1.5.ebuild
+++ b/sci-libs/mc/mc-1.5.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/mc-1.5.ebuild,v 1.3 2011/06/21 15:12:17 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mc/mc-1.5.ebuild,v 1.4 2012/02/28 12:57:17 jlec Exp $
-EAPI="2"
+EAPI=4
-inherit autotools eutils fortran-2 multilib
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils fortran-2 multilib
DESCRIPTION="2D/3D AFEM code for nonlinear geometric PDE"
HOMEPAGE="http://fetk.org/codes/mc/index.html"
@@ -13,7 +15,7 @@ SRC_URI="http://www.fetk.org/codes/download/${P}.tar.gz"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
LICENSE="GPL-2"
-IUSE="debug doc"
+IUSE="debug doc static-libs"
RDEPEND="
virtual/fortran
@@ -24,7 +26,9 @@ RDEPEND="
sci-libs/gamer
sci-libs/punc
sci-libs/superlu
- sci-libs/umfpack"
+ sci-libs/umfpack
+ virtual/blas
+ virtual/lapack"
DEPEND="
${RDEPEND}
doc? (
@@ -33,26 +37,29 @@ DEPEND="
S="${WORKDIR}"/${PN}
+PATCHES=(
+ "${FILESDIR}"/1.4-superlu.patch
+ "${FILESDIR}"/1.4-overflow.patch
+ "${FILESDIR}"/1.4-multilib.patch
+ "${FILESDIR}"/1.4-doc.patch
+ "${FILESDIR}"/${P}-unbundle.patch
+ )
+
src_prepare() {
- epatch \
- "${FILESDIR}"/1.4-superlu.patch \
- "${FILESDIR}"/1.4-overflow.patch \
- "${FILESDIR}"/1.4-multilib.patch \
- "${FILESDIR}"/1.4-doc.patch
sed \
-e 's:AMD_order:amd_order:g' \
-e 's:UMFPACK_numeric:umfpack_di_numeric:g' \
-e 's:buildg_:matvec_:g' \
-i configure.ac || die
- eautoreconf
+ autotools-utils_src_prepare
}
src_configure() {
local fetk_include
local fetk_lib
- local myconf
+ local myeconfargs
- use doc || myconf="${myconf} --with-doxygen= --with-dot="
+ use doc || myeconfargs+=( --with-doxygen= --with-dot= )
fetk_include="${EPREFIX}"/usr/include
fetk_lib="${EPREFIX}"/usr/$(get_libdir)
@@ -69,14 +76,11 @@ src_configure() {
export FETK_CGCODE_LIBRARY="${fetk_lib}"
export FETK_PMG_LIBRARY="${fetk_lib}"
- econf \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- $(use_enable debug vdebug) \
- --disable-triplet \
- --enable-shared \
- ${myconf}
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
+ myeconfargs+=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable debug vdebug)
+ --disable-triplet
+ --enable-shared
+ )
+ autotools-utils_src_configure
}
diff --git a/sci-libs/mc/metadata.xml b/sci-libs/mc/metadata.xml
index c6856dc7f2cf..210ad0db014c 100644
--- a/sci-libs/mc/metadata.xml
+++ b/sci-libs/mc/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer>
- <email>jlec@gentoo.org</email>
-</maintainer>
+ <herd>sci</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
</pkgmetadata>