summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-30 22:14:20 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-30 22:14:20 +0000
commit53128deec3dc2622c464f5c3d334a4ea5af10598 (patch)
treecb2f23558280647783342e57fee1eb0267c042ec /sci-libs/mathgl
parentold (diff)
downloadgentoo-2-53128deec3dc2622c464f5c3d334a4ea5af10598.tar.gz
gentoo-2-53128deec3dc2622c464f5c3d334a4ea5af10598.tar.bz2
gentoo-2-53128deec3dc2622c464f5c3d334a4ea5af10598.zip
Version Bump, fixes for PYTHON multi ABI, #323605, no pointless la files, #313167
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/mathgl')
-rw-r--r--sci-libs/mathgl/ChangeLog12
-rw-r--r--sci-libs/mathgl/mathgl-1.10.1-r1.ebuild (renamed from sci-libs/mathgl/mathgl-1.10.1.ebuild)42
-rw-r--r--sci-libs/mathgl/mathgl-1.10.2-r1.ebuild (renamed from sci-libs/mathgl/mathgl-1.10.2.ebuild)40
-rw-r--r--sci-libs/mathgl/mathgl-1.10.2.1-r1.ebuild141
4 files changed, 218 insertions, 17 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index 0ac39c465f2e..9b7d89c11bf0 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.14 2010/03/29 21:10:08 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.15 2010/06/30 22:14:20 jlec Exp $
+
+*mathgl-1.10.2.1-r1 (30 Jun 2010)
+*mathgl-1.10.2-r1 (30 Jun 2010)
+*mathgl-1.10.1-r1 (30 Jun 2010)
+
+ 30 Jun 2010; Justin Lecher <jlec@gentoo.org> -mathgl-1.10.1.ebuild,
+ +mathgl-1.10.1-r1.ebuild, -mathgl-1.10.2.ebuild, +mathgl-1.10.2-r1.ebuild,
+ +mathgl-1.10.2.1-r1.ebuild:
+ Version Bump, fixes for PYTHON multi ABI, #323605, no pointless la files,
+ #313167
*mathgl-1.10.2 (30 Mar 2010)
diff --git a/sci-libs/mathgl/mathgl-1.10.1.ebuild b/sci-libs/mathgl/mathgl-1.10.1-r1.ebuild
index db749295ddd7..ec393c95b897 100644
--- a/sci-libs/mathgl/mathgl-1.10.1.ebuild
+++ b/sci-libs/mathgl/mathgl-1.10.1-r1.ebuild
@@ -1,9 +1,14 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.1.ebuild,v 1.1 2010/03/08 18:13:35 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.1-r1.ebuild,v 1.1 2010/06/30 22:14:20 jlec Exp $
+
+EAPI=3
-EAPI=2
WX_GTK_VER=2.8
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
inherit autotools wxwidgets python versionator toolchain-funcs
DESCRIPTION="Math Graphics Library"
@@ -57,13 +62,12 @@ src_prepare() {
# correct location of numpy/arrayobject.h
if use python; then
- local numpy_h
- numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
- einfo "fixing numpy.i"
- sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
- -i lang/numpy.i \
- || die "sed failed"
+ sed \
+ -e '/SUBDIRS/s:lang::g' \
+ -i Makefile.am || die
+ python_src_prepare
fi
+ echo "#!${EPREFIX}/bin/sh" > config/py-compile
eautoreconf
}
@@ -88,10 +92,30 @@ src_compile() {
local JOBS
use doc && JOBS=-j1
emake ${JOBS} || die "emake failed"
+ if use python; then
+ python_copy_sources lang
+ compilation() {
+ local numpy_h
+ numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
+ einfo "fixing numpy.i for Python-${PYTHON_ABI}"
+ sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
+ -i numpy.i \
+ || die "sed failed"
+ emake PYTHON_HEADERS="-I$(python_get_includedir)" pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir lang compilation
+ fi
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYTHON="$(PYTHON)" pyexecdir="$(python_get_sitedir)" pythondir="$(python_get_sitedir)" install
+ }
+ python_execute_function -s --source-dir lang installation
+ python_clean_installation_image
+ fi
dodoc README AUTHORS || die "dodoc failed"
}
@@ -101,6 +125,7 @@ pkg_postinst() {
pkg install /usr/share/${PN}/octave/${PN}.tar.gz
EOF
fi
+ use python && python_mod_optimize ${PN}.py
}
pkg_prerm() {
@@ -109,4 +134,5 @@ pkg_prerm() {
pkg uninstall ${PN}
EOF
fi
+ use python && python_mod_cleanup ${PN}.py
}
diff --git a/sci-libs/mathgl/mathgl-1.10.2.ebuild b/sci-libs/mathgl/mathgl-1.10.2-r1.ebuild
index 84e1931a7404..e18f21bd6bf8 100644
--- a/sci-libs/mathgl/mathgl-1.10.2.ebuild
+++ b/sci-libs/mathgl/mathgl-1.10.2-r1.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.2.ebuild,v 1.1 2010/03/29 21:10:08 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.2-r1.ebuild,v 1.1 2010/06/30 22:14:20 jlec Exp $
-EAPI=2
+EAPI=3
WX_GTK_VER=2.8
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit autotools wxwidgets python versionator toolchain-funcs
DESCRIPTION="Math Graphics Library"
@@ -57,13 +60,12 @@ src_prepare() {
# correct location of numpy/arrayobject.h
if use python; then
- local numpy_h
- numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
- einfo "fixing numpy.i"
- sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
- -i lang/numpy.i \
- || die "sed failed"
+ sed \
+ -e '/SUBDIRS/s:lang::g' \
+ -i Makefile.am || die
+ python_src_prepare
fi
+ echo "#!${EPREFIX}/bin/sh" > config/py-compile
eautoreconf
}
@@ -88,10 +90,30 @@ src_compile() {
local JOBS
use doc && JOBS=-j1
emake ${JOBS} || die "emake failed"
+ if use python; then
+ python_copy_sources lang
+ compilation() {
+ local numpy_h
+ numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
+ einfo "fixing numpy.i for Python-${PYTHON_ABI}"
+ sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
+ -i numpy.i \
+ || die "sed failed"
+ emake PYTHON_HEADERS="-I$(python_get_includedir)" pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir lang compilation
+ fi
}
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYTHON="$(PYTHON)" pyexecdir="$(python_get_sitedir)" pythondir="$(python_get_sitedir)" install
+ }
+ python_execute_function -s --source-dir lang installation
+ python_clean_installation_image
+ fi
dodoc README AUTHORS || die "dodoc failed"
}
@@ -101,6 +123,7 @@ pkg_postinst() {
pkg install /usr/share/${PN}/octave/${PN}.tar.gz
EOF
fi
+ use python && python_mod_optimize ${PN}.py
}
pkg_prerm() {
@@ -109,4 +132,5 @@ pkg_prerm() {
pkg uninstall ${PN}
EOF
fi
+ use python && python_mod_cleanup ${PN}.py
}
diff --git a/sci-libs/mathgl/mathgl-1.10.2.1-r1.ebuild b/sci-libs/mathgl/mathgl-1.10.2.1-r1.ebuild
new file mode 100644
index 000000000000..83732201b007
--- /dev/null
+++ b/sci-libs/mathgl/mathgl-1.10.2.1-r1.ebuild
@@ -0,0 +1,141 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.10.2.1-r1.ebuild,v 1.1 2010/06/30 22:14:20 jlec Exp $
+
+EAPI=3
+
+WX_GTK_VER=2.8
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit autotools wxwidgets python versionator toolchain-funcs
+
+DESCRIPTION="Math Graphics Library"
+HOMEPAGE="http://mathgl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tgz mirror://sourceforge/${PN}/STIX_font.tgz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc fltk gif glut gsl hdf5 jpeg octave python qt4 wxwidgets"
+
+RDEPEND="media-libs/libpng
+ virtual/glu
+ python? ( dev-python/numpy )
+ glut? ( virtual/glut )
+ fltk? ( x11-libs/fltk:1.1 )
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ hdf5? ( >=sci-libs/hdf5-1.8 )
+ gsl? ( sci-libs/gsl )
+ octave? ( sci-mathematics/octave )
+ qt4? ( x11-libs/qt-gui:4 )
+ wxwidgets? ( x11-libs/wxGTK:2.8 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/libtool-2.2.4
+ doc? ( app-text/texi2html virtual/texi2dvi )
+ python? ( dev-lang/swig )
+ octave? ( dev-lang/swig )"
+
+pkg_setup() {
+ if ! version_is_at_least "4.3.0" "$(gcc-version)"; then
+ eerror "You need >=gcc-4.3.0 to compile this package"
+ die "Wrong gcc version"
+ fi
+ if use hdf5 && has_version sci-libs/hdf5[mpi]; then
+ export CC=mpicc
+ export CXX=mpicxx
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ mkdir "${S}"/fonts
+ cd "${S}"/fonts
+ unpack STIX_font.tgz
+}
+
+src_prepare() {
+ # bug #267061
+ epatch "${FILESDIR}"/${PN}-1.10.2-gcc43.patch
+
+ # correct location of numpy/arrayobject.h
+ if use python; then
+ sed \
+ -e '/SUBDIRS/s:lang::g' \
+ -i Makefile.am || die
+ python_src_prepare
+ fi
+
+ echo "#!${EPREFIX}/bin/sh" > config/py-compile
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${ROOT}"usr/share/doc/${PF} \
+ $(use_enable glut) \
+ $(use_enable qt4 qt) \
+ $(use_enable wxwidgets wx) \
+ $(use_enable fltk) \
+ $(use_enable gif) \
+ $(use_enable jpeg) \
+ $(use_enable hdf5 hdf5_18) \
+ $(use_enable python) \
+ $(use_enable octave) \
+ $(use_enable gsl) \
+ $(use_enable doc docs)
+}
+
+src_compile() {
+ # see bug #249627
+ local JOBS
+ use doc && JOBS=-j1
+ emake ${JOBS} || die "emake failed"
+
+ if use python; then
+ python_copy_sources lang
+ compilation() {
+ local numpy_h
+ numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
+ einfo "fixing numpy.i for Python-${PYTHON_ABI}"
+ sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
+ -i numpy.i \
+ || die "sed failed"
+ emake PYTHON_HEADERS="-I$(python_get_includedir)" pyexecdir="$(python_get_sitedir)"
+ }
+ python_execute_function -s --source-dir lang compilation
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ if use python; then
+ installation() {
+ emake DESTDIR="${D}" PYTHON="$(PYTHON)" pyexecdir="$(python_get_sitedir)" pythondir="$(python_get_sitedir)" install
+ }
+ python_execute_function -s --source-dir lang installation
+ python_clean_installation_image
+ fi
+ dodoc README AUTHORS || die "dodoc failed"
+}
+
+pkg_postinst() {
+ if use octave; then
+ octave <<-EOF
+ pkg install /usr/share/${PN}/octave/${PN}.tar.gz
+ EOF
+ fi
+ use python && python_mod_optimize ${PN}.py
+}
+
+pkg_prerm() {
+ if use octave; then
+ octave <<-EOF
+ pkg uninstall ${PN}
+ EOF
+ fi
+ use python && python_mod_cleanup ${PN}.py
+}