summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2008-12-06 16:26:11 +0000
committerAndrey Grozin <grozin@gentoo.org>2008-12-06 16:26:11 +0000
commit21bcb1540e468bbdaabbad8ca745064c54b0f2b4 (patch)
tree15caf86a8b94191c0fb866ee56fc9950f0e6c837 /sci-libs/mathgl/files
parentRespect CC and LDFLAGS, bug #244098 (diff)
downloadgentoo-2-21bcb1540e468bbdaabbad8ca745064c54b0f2b4.tar.gz
gentoo-2-21bcb1540e468bbdaabbad8ca745064c54b0f2b4.tar.bz2
gentoo-2-21bcb1540e468bbdaabbad8ca745064c54b0f2b4.zip
Fixing bug #249627; new USE flag octave.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-tuxonice i686)
Diffstat (limited to 'sci-libs/mathgl/files')
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8-fltk.patch20
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8-octave.patch21
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/mathgl/files/mathgl-1.8-fltk.patch b/sci-libs/mathgl/files/mathgl-1.8-fltk.patch
new file mode 100644
index 000000000000..102e13583136
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-1.8-fltk.patch
@@ -0,0 +1,20 @@
+Index: mathgl-1.8/examples/Makefile.am
+===================================================================
+--- mathgl-1.8.orig/examples/Makefile.am
++++ mathgl-1.8/examples/Makefile.am
+@@ -9,11 +9,13 @@ mgl_example_LDADD = $(top_builddir)/mgl/
+ if USE_FLTK
+ bin_PROGRAMS += mgl_fltk_example
+ mgl_fltk_example_SOURCES = fltk_example.cpp
+-mgl_fltk_example_LDADD = $(top_builddir)/widgets/libmgl-fltk.la
++mgl_fltk_example_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la
++mgl_fltk_example_CXXFLAGS = $(FLTK_FLAGS) $(AM_CXXFLAGS)
+
+ check_PROGRAMS += test
+ test_SOURCES = main.cpp
+-test_LDADD = $(top_builddir)/widgets/libmgl-fltk.la
++test_LDADD = $(FLTK_LIBS) $(top_builddir)/widgets/libmgl-fltk.la
++test_CXXFLAGS = $(FLTK_FLAGS) $(AM_CXXFLAGS)
+ endif
+
+ if USE_GLUT
diff --git a/sci-libs/mathgl/files/mathgl-1.8-octave.patch b/sci-libs/mathgl/files/mathgl-1.8-octave.patch
new file mode 100644
index 000000000000..0ee821b99682
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-1.8-octave.patch
@@ -0,0 +1,21 @@
+Index: mathgl-1.8/configure.ac
+===================================================================
+--- mathgl-1.8.orig/configure.ac
++++ mathgl-1.8/configure.ac
+@@ -231,12 +231,14 @@ AC_ARG_ENABLE(octave,
+ *) AC_MSG_ERROR(bad value ${enableval} for --enable-octave) ;;
+ esac],[octave=false])
+ if (test x$langall = xtrue || test x$octave = xtrue) ;then
++ AC_CHECK_PROG([OCTAVE],[octave-config],[octave-config])
+ # find Octave arch
+- OCTAVE=octave
+ AC_MSG_CHECKING([for Octave arch])
+- OCTAVE_ARCH=`$OCTAVE -q --eval 'strcat(octave_config_info("canonical_host_type"), "-", octave_config_info("api_version"))'|sed -e 's/ans = //'`
++ OCTAVE_ARCH=`$OCTAVE -p CANONICAL_HOST_TYPE`-`$OCTAVE -p API_VERSION`
++ OCTAVE_INCFLAGS="-I`$OCTAVE -p OCTINCLUDEDIR`"
+ AC_MSG_RESULT([$OCTAVE_ARCH])
+ AC_SUBST(OCTAVE_ARCH,[$OCTAVE_ARCH])
++ AC_SUBST(OCTAVE_INCFLAGS,[$OCTAVE_INCFLAGS])
+ test_octave=true
+ fi
+ AM_CONDITIONAL(USE_OCTAVE, test x$test_octave = xtrue )