summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2011-09-25 16:55:32 +0000
committerThomas Kahle <tomka@gentoo.org>2011-09-25 16:55:32 +0000
commit498eaf6d9c0bedd29635167825d1abe20e90ae2b (patch)
tree5ea7c8c2b91b9c2e1ec162674dffeb42be6f6f6d /sci-libs/lrslib
parentMarked stable on AMD64 based on arch testing by Agostino "ago" Sarubbo & Elij... (diff)
downloadgentoo-2-498eaf6d9c0bedd29635167825d1abe20e90ae2b.tar.gz
gentoo-2-498eaf6d9c0bedd29635167825d1abe20e90ae2b.tar.bz2
gentoo-2-498eaf6d9c0bedd29635167825d1abe20e90ae2b.zip
convert to EAPI=4, fix bugs 384195, 383811.
(Portage version: 2.1.10.19/cvs/Linux i686)
Diffstat (limited to 'sci-libs/lrslib')
-rw-r--r--sci-libs/lrslib/ChangeLog8
-rw-r--r--sci-libs/lrslib/lrslib-042c-r2.ebuild61
2 files changed, 68 insertions, 1 deletions
diff --git a/sci-libs/lrslib/ChangeLog b/sci-libs/lrslib/ChangeLog
index 0e5823a6d735..55595a92ba65 100644
--- a/sci-libs/lrslib/ChangeLog
+++ b/sci-libs/lrslib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/lrslib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/ChangeLog,v 1.6 2011/05/07 18:17:48 tomka Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/ChangeLog,v 1.7 2011/09/25 16:55:32 tomka Exp $
+
+*lrslib-042c-r2 (25 Sep 2011)
+
+ 25 Sep 2011; Thomas Kahle <tomka@gentoo.org> +lrslib-042c-r2.ebuild:
+ Convert to EAPI=4, don't link gmp statically (bug 383811)
+ use -DB64 on amd64 (bug 384195).
07 May 2011; Thomas Kahle <tomka@gentoo.org> -lrslib-042c.ebuild:
Remove old
diff --git a/sci-libs/lrslib/lrslib-042c-r2.ebuild b/sci-libs/lrslib/lrslib-042c-r2.ebuild
new file mode 100644
index 000000000000..6a34513bdad7
--- /dev/null
+++ b/sci-libs/lrslib/lrslib-042c-r2.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lrslib/lrslib-042c-r2.ebuild,v 1.1 2011/09/25 16:55:31 tomka Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="self-contained ANSI C implementation of the reverse search algorithm"
+HOMEPAGE="http://cgm.cs.mcgill.ca/~avis/C/lrs.html"
+SRC_URI="http://cgm.cs.mcgill.ca/~avis/C/lrslib/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gmp"
+
+DEPEND="gmp? ( dev-libs/gmp )"
+RDEPEND="${DEPEND}"
+
+src_prepare(){
+ sed -i "s/gcc/$(tc-getCC)/g" makefile || die
+ sed -i "s/-O3/${CFLAGS} ${LDFLAGS}/g" makefile || die
+ # We don't like static linking to gmp or anywhere.
+ if use amd64 ; then
+ # This macro may only change messages that the
+ # binary outputs, but just in case... (Bug 384195)
+ sed -i "s/-static/-DB64/g" makefile || die
+ else
+ sed -i "s/-static//g" makefile || die
+ fi
+}
+
+src_compile () {
+ if use amd64 ; then
+ emake all64
+ else
+ emake
+ fi
+ if use gmp ; then
+ emake gmp
+ fi
+}
+
+src_install() {
+ dobin lrs redund redund1
+ # Collides with sys-block/buffer
+ newbin buffer lrsbuffer
+ if use x86; then
+ dobin nash setupnash setupnash2 2nash
+ # Prevent clash with cddlib:
+ newbin fourier lrsfourier
+ fi
+ if use gmp; then
+ dobin glrs gredund gfourier
+ # Clash with www-plugins/gnash
+ newbin gnash lrsgnash
+ fi
+ dodoc readme
+ dohtml lrslib.html
+}