summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-06-13 13:48:15 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-06-13 13:48:15 +0000
commit3c1b88d0b768b7b7685bf38263636cfcbe657e9d (patch)
tree56c2c9fd030908720941c569437c7386047109ca /sci-libs/libsvm
parentFinally the libcdio version bump. This also fixes building of examples that w... (diff)
downloadgentoo-2-3c1b88d0b768b7b7685bf38263636cfcbe657e9d.tar.gz
gentoo-2-3c1b88d0b768b7b7685bf38263636cfcbe657e9d.tar.bz2
gentoo-2-3c1b88d0b768b7b7685bf38263636cfcbe657e9d.zip
Version bump (see bug #226167).
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs/libsvm')
-rw-r--r--sci-libs/libsvm/ChangeLog7
-rw-r--r--sci-libs/libsvm/libsvm-2.86.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/sci-libs/libsvm/ChangeLog b/sci-libs/libsvm/ChangeLog
index 1a5fa1444ba7..e76ebc3f53cf 100644
--- a/sci-libs/libsvm/ChangeLog
+++ b/sci-libs/libsvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libsvm
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/ChangeLog,v 1.11 2008/05/04 17:35:11 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/ChangeLog,v 1.12 2008/06/13 13:48:15 markusle Exp $
+
+*libsvm-2.86 (13 Jun 2008)
+
+ 13 Jun 2008; Markus Dittrich <markusle@gentoo.org> +libsvm-2.86.ebuild:
+ Version bump (see bug #226167).
04 May 2008; nixnut <nixnut@gentoo.org> libsvm-2.84.ebuild:
Stable on ppc wrt bug 217700
diff --git a/sci-libs/libsvm/libsvm-2.86.ebuild b/sci-libs/libsvm/libsvm-2.86.ebuild
new file mode 100644
index 000000000000..149bfe6aed65
--- /dev/null
+++ b/sci-libs/libsvm/libsvm-2.86.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libsvm/libsvm-2.86.ebuild,v 1.1 2008/06/13 13:48:15 markusle Exp $
+
+inherit java-pkg-opt-2 python toolchain-funcs multilib
+
+DESCRIPTION="Library for Support Vector Machines"
+HOMEPAGE="http://www.csie.ntu.edu.tw/~cjlin/libsvm/"
+SRC_URI="http://www.csie.ntu.edu.tw/~cjlin/libsvm/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="java python tools"
+
+DEPEND="java? ( >=virtual/jdk-1.4 )"
+RDEPEND="${DEPEND}
+ tools? ( sci-visualization/gnuplot )"
+
+src_compile() {
+ emake \
+ CXXC="$(tc-getCXX)" \
+ CFLAGS="${CXXFLAGS}" \
+ || die "emake failed"
+
+ sed -i -e 's@\.\./@/usr/bin/@g' tools/*.py || die
+
+ if use python ; then
+ pushd python
+ python_version || die
+ emake \
+ CC="$(tc-getCXX)" \
+ CFLAGS="${CXXFLAGS} -I/usr/include/python${PYVER} -I.." \
+ all || die "emake for python modules failed"
+ popd
+ fi
+
+ if use java ; then
+ pushd java
+ local JAVAC_FLAGS="$(java-pkg_javac-args)"
+ sed -i \
+ -e "s/JAVAC_FLAGS =/JAVAC_FLAGS=${JAVAC_FLAGS}/g" \
+ Makefile || die
+ emake || die "emake for java modules failed"
+ popd
+ fi
+}
+
+src_install() {
+ dobin svm-train svm-predict svm-scale || die
+ dohtml FAQ.html
+ dodoc README
+
+ if use tools; then
+ pushd tools
+ insinto /usr/share/doc/${PF}/tools
+ doins easy.py grid.py subset.py
+ docinto tools
+ dodoc README
+ popd
+ fi
+
+ if use python ; then
+ pushd python
+ python_version || die
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins svmc.so svm.py || die
+ docinto python
+ dodoc README
+ popd
+ fi
+
+ if use java; then
+ pushd java
+ java-pkg_dojar libsvm.jar
+ docinto java
+ dohtml test_applet.html
+ popd
+ fi
+}