summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-11-25 19:52:47 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-11-25 19:52:47 +0000
commit9c23de425e1356478535cabeb4ff9a414496ae4e (patch)
treece6ff3dc16bd5eea3040235b50b3c79851cb9761 /sci-libs/libnova
parentExport correct directories for libgtkembedmoz. (diff)
downloadgentoo-2-9c23de425e1356478535cabeb4ff9a414496ae4e.tar.gz
gentoo-2-9c23de425e1356478535cabeb4ff9a414496ae4e.tar.bz2
gentoo-2-9c23de425e1356478535cabeb4ff9a414496ae4e.zip
Version bump, added src_test, doc use flag, and modernized the ebuild. Closing bug #150774.
(Portage version: 2.1.3.19)
Diffstat (limited to 'sci-libs/libnova')
-rw-r--r--sci-libs/libnova/ChangeLog9
-rw-r--r--sci-libs/libnova/files/digest-libnova-0.12.13
-rw-r--r--sci-libs/libnova/files/libnova-0.12.1-configure.patch17
-rw-r--r--sci-libs/libnova/libnova-0.12.1.ebuild53
4 files changed, 81 insertions, 1 deletions
diff --git a/sci-libs/libnova/ChangeLog b/sci-libs/libnova/ChangeLog
index 7c857735b5c3..4df61622bf0e 100644
--- a/sci-libs/libnova/ChangeLog
+++ b/sci-libs/libnova/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/libnova
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/ChangeLog,v 1.3 2007/02/09 05:23:10 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/ChangeLog,v 1.4 2007/11/25 19:52:46 bicatali Exp $
+
+*libnova-0.12.1 (25 Nov 2007)
+
+ 25 Nov 2007; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/libnova-0.12.1-configure.patch, +libnova-0.12.1.ebuild:
+ Version bump, added src_test, doc use flag, and modernized the ebuild.
+ Closing bug #150774.
09 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/sci-libs/libnova/files/digest-libnova-0.12.1 b/sci-libs/libnova/files/digest-libnova-0.12.1
new file mode 100644
index 000000000000..1ef6c5e61c7e
--- /dev/null
+++ b/sci-libs/libnova/files/digest-libnova-0.12.1
@@ -0,0 +1,3 @@
+MD5 f0bffb2eb0bfa041e4c4d9764aadd94d libnova-0.12.1.tar.gz 1498120
+RMD160 a93d8a860814f16e5440ae81a2675eac1ea33aa6 libnova-0.12.1.tar.gz 1498120
+SHA256 8053445e862413a8e042264290da7d70bfa2ed46b4596c86b67962820b61462f libnova-0.12.1.tar.gz 1498120
diff --git a/sci-libs/libnova/files/libnova-0.12.1-configure.patch b/sci-libs/libnova/files/libnova-0.12.1-configure.patch
new file mode 100644
index 000000000000..b87b27d75dc9
--- /dev/null
+++ b/sci-libs/libnova/files/libnova-0.12.1-configure.patch
@@ -0,0 +1,17 @@
+--- configure.in.orig 2007-11-25 19:24:54.503391146 +0000
++++ configure.in 2007-11-25 19:26:16.736077320 +0000
+@@ -54,7 +54,6 @@
+ AC_STRUCT_TM
+
+ LIBS="$LIBS -lm"
+-CFLAGS=-Wall
+
+ # Checks for header files.
+ AC_HEADER_STDC
+@@ -74,5 +73,6 @@
+ src/libnova/Makefile
+ lntest/Makefile
+ doc/Makefile
++doc/doxyfile
+ examples/Makefile
+ ])
diff --git a/sci-libs/libnova/libnova-0.12.1.ebuild b/sci-libs/libnova/libnova-0.12.1.ebuild
new file mode 100644
index 000000000000..5c8b874739d5
--- /dev/null
+++ b/sci-libs/libnova/libnova-0.12.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnova/libnova-0.12.1.ebuild,v 1.1 2007/11/25 19:52:46 bicatali Exp $
+
+inherit eutils autotools flag-o-matic
+
+DESCRIPTION="Celestial Mechanics and Astronomical Calculation Library"
+HOMEPAGE="http://libnova.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? ( app-doc/doxygen )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # patch to use user's cflags and make doxygen working
+ epatch "${FILESDIR}"/${P}-configure.patch
+ eautoconf
+}
+
+src_compile() {
+ # 0.12.1 does not pass test with > -02
+ replace-flags -O? -O1
+
+ econf || die "econf failed"
+ emake || die "emake failed"
+ if use doc; then
+ cd doc
+ emake doc || die "emake in doc failed"
+ fi
+}
+
+src_test() {
+ emake check || die "emake check failed"
+ "${S}"/lntest/lntest || die "lntest failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die
+ if use doc; then
+ dohtml doc/html/* || die "dohtml failed"
+ make clean
+ rm -f examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}