summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-05-11 03:50:00 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-05-11 03:50:00 +0000
commite333b9b4a127e02566cdb0e9610aad6313ffc511 (patch)
tree4127e86d4b8ccb68db0f90f6f6991bdf818ae77b /sci-libs/libnc-dap
parentfix libtool issues, bug #265964. (diff)
downloadgentoo-2-e333b9b4a127e02566cdb0e9610aad6313ffc511.tar.gz
gentoo-2-e333b9b4a127e02566cdb0e9610aad6313ffc511.tar.bz2
gentoo-2-e333b9b4a127e02566cdb0e9610aad6313ffc511.zip
Updated to fix exported symbols with gfortran (one less underscore).
(Portage version: 2.2_rc32/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libnc-dap')
-rw-r--r--sci-libs/libnc-dap/ChangeLog6
-rw-r--r--sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild31
2 files changed, 35 insertions, 2 deletions
diff --git a/sci-libs/libnc-dap/ChangeLog b/sci-libs/libnc-dap/ChangeLog
index 2f2442820786..260fa5971eb0 100644
--- a/sci-libs/libnc-dap/ChangeLog
+++ b/sci-libs/libnc-dap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libnc-dap
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/ChangeLog,v 1.3 2009/04/27 01:54:33 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/ChangeLog,v 1.4 2009/05/11 03:50:00 nerdboy Exp $
+
+ 11 May 2009; Steve Arnold <nerdboy@gentoo.org> libnc-dap-3.7.3-r1.ebuild:
+ Updated to fix exported symbols with gfortran (one less underscore). Only
+ supports gfortran and g77 at the moment.
*libnc-dap-3.7.3-r1 (27 Apr 2009)
diff --git a/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild b/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild
index 04d7ececde23..7c53bb6caf71 100644
--- a/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild
+++ b/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild,v 1.1 2009/04/27 01:54:33 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libnc-dap/libnc-dap-3.7.3-r1.ebuild,v 1.2 2009/05/11 03:50:00 nerdboy Exp $
inherit eutils flag-o-matic fortran
@@ -23,6 +23,26 @@ DEPEND="${RDEPEND}
<=sci-libs/libdap-3.8.2"
pkg_setup() {
+ if use fortran; then
+ fortran_pkg_setup
+ case "${FORTRANC}" in
+ # probably needs more compilers here, of which I have
+ # none, so feel free to provide flags for others...
+ g77)
+ export FCLAGS+="-finit-local-zero -fno-automatic \
+ -fno-second-underscore -std=legacy -ff2c \
+ -fall-intrinsics -static-libgfortran"
+ ;;
+ *)
+ export FCLAGS+="-finit-local-zero -fno-automatic \
+ -fno-second-underscore -std=gnu \
+ -fall-intrinsics -static-libgfortran"
+ ;;
+ esac
+ else
+ export FC=""
+ fi
+
if use full-test; then
if [ -n "${DAP_TEST_OPTS}" ]; then
elog "User-specified test URL is ${DAP_TEST_OPTS}."
@@ -45,14 +65,23 @@ src_unpack() {
sed -i -e "s:MAX_NC_OPEN 32:MAX_NC_OPEN 128:g" \
lnetcdf/{lnetcdf.h,netcdf.h} \
|| die "sed headers failed"
+
# missing definition causes unknown symbol errors
epatch "${FILESDIR}"/${P}_template-fix.patch
+
+ # this is specific to GNU Fortran
+ if [[ ${FORTRANC} = gfortran ]] ; then
+ elog "updating for gfortran..."
+ sed -i -e "s/= -Df2cFortran/= -DgFortran/" Makefile.in \
+ || die "sed makefile.in failed"
+ fi
}
src_compile() {
local test_conf="${DAP_TEST_OPTS}"
local myconf="--disable-dependency-tracking --enable-largefile \
--enable-64bit"
+ use fortran || myconf="${myconf} --disable-f77"
# debug can be set to 2 for extra verbosity
use debug && myconf="${myconf} --enable-debug=1"