summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2012-11-08 09:09:17 +0000
committerJustin Lecher <jlec@gentoo.org>2012-11-08 09:09:17 +0000
commit5cdb51736b28237bdd28e9f09432c963a0ce83df (patch)
tree247d8c403ab9585992fc526ee17dcdfc7c76fc34 /sci-libs/libmems
parentResticted tests wrt Bug #430396 (diff)
downloadgentoo-2-5cdb51736b28237bdd28e9f09432c963a0ce83df.tar.gz
gentoo-2-5cdb51736b28237bdd28e9f09432c963a0ce83df.tar.bz2
gentoo-2-5cdb51736b28237bdd28e9f09432c963a0ce83df.zip
sci-libs/libmems: Version bump, which fixes gcc-4.7, respect for user env and boost-1.51 compatibility, #442300
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'sci-libs/libmems')
-rw-r--r--sci-libs/libmems/ChangeLog10
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-boost.patch120
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-build.patch19
-rw-r--r--sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch71
-rw-r--r--sci-libs/libmems/libmems-1.6_p1.ebuild32
5 files changed, 251 insertions, 1 deletions
diff --git a/sci-libs/libmems/ChangeLog b/sci-libs/libmems/ChangeLog
index 762eb2d784b8..e2d5880fd243 100644
--- a/sci-libs/libmems/ChangeLog
+++ b/sci-libs/libmems/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/libmems
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libmems/ChangeLog,v 1.3 2012/10/31 20:40:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libmems/ChangeLog,v 1.4 2012/11/08 09:09:17 jlec Exp $
+
+*libmems-1.6_p1 (08 Nov 2012)
+
+ 08 Nov 2012; Justin Lecher <jlec@gentoo.org> +libmems-1.6_p1.ebuild,
+ +files/libmems-1.6_p1-boost.patch, +files/libmems-1.6_p1-build.patch,
+ +files/libmems-1.6_p1-gcc-4.7.patch:
+ Version bump, which fixes gcc-4.7, respect for user env and boost-1.51
+ compatibility, #442300
31 Oct 2012; Diego E. Pettenò <flameeyes@gentoo.org> libmems-1.6.ebuild:
QA: drop maximum boost version dep; if it fails to build, it has to be fixed.
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-boost.patch b/sci-libs/libmems/files/libmems-1.6_p1-boost.patch
new file mode 100644
index 000000000000..4f0c775a6d9c
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-boost.patch
@@ -0,0 +1,120 @@
+ libMems/Backbone.cpp | 2 +-
+ libMems/Files.h | 64 +++++++++++++++++++++---------------------
+ libMems/ProgressiveAligner.cpp | 2 +-
+ 3 files changed, 34 insertions(+), 34 deletions(-)
+
+diff --git a/libMems/Backbone.cpp b/libMems/Backbone.cpp
+index 86698a9..0025cd8 100644
+--- a/libMems/Backbone.cpp
++++ b/libMems/Backbone.cpp
+@@ -15,7 +15,7 @@
+ #include "libMems/Islands.h"
+ #include "libMems/CompactGappedAlignment.h"
+
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/graph/graph_traits.hpp>
+ #include <boost/graph/adjacency_list.hpp>
+ #include <boost/graph/topological_sort.hpp>
+diff --git a/libMems/Files.h b/libMems/Files.h
+index 8d6e9be..8191065 100644
+--- a/libMems/Files.h
++++ b/libMems/Files.h
+@@ -22,44 +22,44 @@
+
+ #include "boost/filesystem/operations.hpp"
+ #include "boost/filesystem/exception.hpp"
+-#include "boost/algorithm/string.hpp"
++#include "boost/algorithm/string.hpp"
+ #include <string>
+ #include <sstream>
+ #include <iostream>
+ #include <iomanip>
+
+
+-/**
+- * Register a file name to be deleted before the process exits
+- * When passed an empty string, it does not add to the list of files to delete
+- * @param fname The name of a file to delete, empty strings are ignored
+- * @return A vector of file names registered for deletion
+- */
+-std::vector< std::string >& registerFileToDelete( std::string fname = "" );
+-
+-inline
+-std::vector< std::string >& registerFileToDelete( std::string fname ) {
+- // since this vector is needed when atexit() is called we allocate it
+- // on the heap so its destructor won't get called
+- static std::vector< std::string >* files = new std::vector< std::string >();
+-#pragma omp critical
+-{
+- if( fname != "" )
+- files->push_back( fname );
+-}
+- return *files;
+-}
++/**
++ * Register a file name to be deleted before the process exits
++ * When passed an empty string, it does not add to the list of files to delete
++ * @param fname The name of a file to delete, empty strings are ignored
++ * @return A vector of file names registered for deletion
++ */
++std::vector< std::string >& registerFileToDelete( std::string fname = "" );
+
+-void deleteRegisteredFiles();
+-inline
+-void deleteRegisteredFiles() {
+- // don't be a slob, clean up after yourself:
+- // delete any files that are laying around
+- std::vector< std::string >& del_files = registerFileToDelete();
+- for( int fileI = 0; fileI < del_files.size(); fileI++ )
+- boost::filesystem::remove( del_files[ fileI ] );
+- del_files.clear(); // clear the deleted files from the list
+-}
++inline
++std::vector< std::string >& registerFileToDelete( std::string fname ) {
++ // since this vector is needed when atexit() is called we allocate it
++ // on the heap so its destructor won't get called
++ static std::vector< std::string >* files = new std::vector< std::string >();
++#pragma omp critical
++{
++ if( fname != "" )
++ files->push_back( fname );
++}
++ return *files;
++}
++
++void deleteRegisteredFiles();
++inline
++void deleteRegisteredFiles() {
++ // don't be a slob, clean up after yourself:
++ // delete any files that are laying around
++ std::vector< std::string >& del_files = registerFileToDelete();
++ for( int fileI = 0; fileI < del_files.size(); fileI++ )
++ boost::filesystem::remove( del_files[ fileI ] );
++ del_files.clear(); // clear the deleted files from the list
++}
+
+
+ /**
+@@ -80,7 +80,7 @@ std::string CreateTempFileName(const std::string& prefix)
+ #endif
+ boost::filesystem::path path( prefix );
+ dir = path.branch_path().string();
+- name = path.leaf();
++ name = path.filename().string();
+ if( name == "/" )
+ {
+ dir += name;
+diff --git a/libMems/ProgressiveAligner.cpp b/libMems/ProgressiveAligner.cpp
+index 3be5fe0..5667a9e 100644
+--- a/libMems/ProgressiveAligner.cpp
++++ b/libMems/ProgressiveAligner.cpp
+@@ -27,7 +27,7 @@
+
+ #include <boost/dynamic_bitset.hpp>
+ #include <boost/tuple/tuple.hpp>
+-#include <boost/property_map.hpp>
++#include <boost/property_map/property_map.hpp>
+ #include <boost/graph/graph_traits.hpp>
+ #include <boost/graph/adjacency_list.hpp>
+ #include <boost/graph/johnson_all_pairs_shortest.hpp>
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-build.patch b/sci-libs/libmems/files/libmems-1.6_p1-build.patch
new file mode 100644
index 000000000000..63e5f1216756
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-build.patch
@@ -0,0 +1,19 @@
+ libMems/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/libMems/Makefile.am b/libMems/Makefile.am
+index 6101f71..d66053d 100644
+--- a/libMems/Makefile.am
++++ b/libMems/Makefile.am
+@@ -2,10 +2,10 @@
+ if DEBUG
+ D_CXXFLAGS = -Wall -g -D__GNDEBUG__
+ endif
+-OPTIMIZATION = -O2 -Wall -funroll-loops -fomit-frame-pointer -ftree-vectorize
+ AM_CFLAGS = $(OPTIMIZATION) @DEPS_CFLAGS@ -DUSE_POSIX_AIO @OPENMP_CFLAGS@
+ AM_CXXFLAGS = $(OPTIMIZATION) @DEPS_CFLAGS@ @BOOST_CPPFLAGS@ $(D_CXXFLAGS) @EXTRA_CXX_FLAGS@ @OPENMP_CXXFLAGS@
+ AM_LDFLAGS = $(OPTIMIZATION)
++AM_CPPFLAGS=-I$(top_srcdir)
+
+ LIBMEMS_H = \
+ RepeatHash.h MatchHashEntry.h \
diff --git a/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch b/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch
new file mode 100644
index 000000000000..ec620ebb35aa
--- /dev/null
+++ b/sci-libs/libmems/files/libmems-1.6_p1-gcc-4.7.patch
@@ -0,0 +1,71 @@
+ libMems/CompactGappedAlignment.h | 36 ++++++++++++++++++------------------
+ 1 file changed, 18 insertions(+), 18 deletions(-)
+
+diff --git a/libMems/CompactGappedAlignment.h b/libMems/CompactGappedAlignment.h
+index bf78477..942d4aa 100644
+--- a/libMems/CompactGappedAlignment.h
++++ b/libMems/CompactGappedAlignment.h
+@@ -13,7 +13,7 @@
+ #include "config.h"
+ #endif
+
+-#include "libGenome/gnDebug.h"
++#include "libGenome/gnDebug.h"
+ #include "libGenome/gnFilter.h"
+ #include "libGenome/gnSequence.h"
+ #include "libMems/SparseAbstractMatch.h"
+@@ -103,15 +103,15 @@ public:
+ /** Eliminates any columns that contain only gap characters */
+ void CondenseGapColumns();
+
+- void swap( CompactGappedAlignment& other ){ swap(&other); }
+-
+-protected:
+- // for use by derived classes in order to swap contents
+- void swap( CompactGappedAlignment* other ){
+- std::swap( align_matrix, other->align_matrix );
+- std::swap( bcount, other->bcount );
+- BaseType::swap( other );
+- }
++ void swap( CompactGappedAlignment& other ){ swap(&other); }
++
++protected:
++ // for use by derived classes in order to swap contents
++ void swap( CompactGappedAlignment* other ){
++ std::swap( align_matrix, other->align_matrix );
++ std::swap( bcount, other->bcount );
++ BaseType::swap( other );
++ }
+
+ std::vector< bitset_t > align_matrix; /**< aligned positions have true values, gaps are false */
+ std::vector< std::vector< size_t > > bcount;
+@@ -572,7 +572,7 @@ void CompactGappedAlignment<BaseType>::CropEnd(gnSeqI crop_amount){
+ this->SetStart(i, 0);
+ }
+ }
+- SetAlignmentLength( this->AlignmentLength() - crop_amount );
++ this->SetAlignmentLength( this->AlignmentLength() - crop_amount );
+ this->create_bitcount();
+ if( !this->validate() )
+ std::cerr << "CropEnd error\n";
+@@ -806,13 +806,13 @@ void CompactGappedAlignment<BaseType>::CondenseGapColumns()
+
+ }
+
+-namespace std {
+-template<> inline
+-void swap( mems::CompactGappedAlignment<>& a, mems::CompactGappedAlignment<>& b )
+-{
+- a.swap(b);
+-}
+-}
++namespace std {
++template<> inline
++void swap( mems::CompactGappedAlignment<>& a, mems::CompactGappedAlignment<>& b )
++{
++ a.swap(b);
++}
++}
+
+
+ #endif // __CompactGappedAlignment_h__
diff --git a/sci-libs/libmems/libmems-1.6_p1.ebuild b/sci-libs/libmems/libmems-1.6_p1.ebuild
new file mode 100644
index 000000000000..bd469ded1072
--- /dev/null
+++ b/sci-libs/libmems/libmems-1.6_p1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libmems/libmems-1.6_p1.ebuild,v 1.1 2012/11/08 09:09:17 jlec Exp $
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=yes
+
+inherit autotools-utils
+
+DESCRIPTION="Library for sci-biology/mauve"
+HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
+SRC_URI="mirror://dev.gentoo.org/~jlec/${P}.tar.xz"
+
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="doc"
+KEYWORDS="~amd64 ~x86"
+
+CDEPEND="
+ dev-libs/boost
+ sci-libs/libgenome
+ sci-libs/libmuscle"
+DEPEND="${CDEPEND}
+ doc? ( app-doc/doxygen )"
+RDEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-build.patch
+ "${FILESDIR}"/${P}-boost.patch
+ "${FILESDIR}"/${P}-gcc-4.7.patch
+ )