summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-06-21 08:31:23 +0000
committerJustin Lecher <jlec@gentoo.org>2011-06-21 08:31:23 +0000
commit9a08e2c1547c17d764f9a28f59d36ee403e8a867 (patch)
tree95f6b3fd29731021a7ba2ea147b92a959f61c827 /sci-libs/libint
parentAdded fortran-2.eclass support (diff)
downloadgentoo-2-9a08e2c1547c17d764f9a28f59d36ee403e8a867.tar.gz
gentoo-2-9a08e2c1547c17d764f9a28f59d36ee403e8a867.tar.bz2
gentoo-2-9a08e2c1547c17d764f9a28f59d36ee403e8a867.zip
Added fortran-2.eclass support
(Portage version: 2.2.0_alpha41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libint')
-rw-r--r--sci-libs/libint/ChangeLog8
-rw-r--r--sci-libs/libint/libint-1.1.2.ebuild16
-rw-r--r--sci-libs/libint/libint-1.1.4-r1.ebuild12
-rw-r--r--sci-libs/libint/libint-1.1.4.ebuild15
4 files changed, 26 insertions, 25 deletions
diff --git a/sci-libs/libint/ChangeLog b/sci-libs/libint/ChangeLog
index db3053537761..24718e923603 100644
--- a/sci-libs/libint/ChangeLog
+++ b/sci-libs/libint/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/libint
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/ChangeLog,v 1.7 2010/02/13 18:27:00 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/ChangeLog,v 1.8 2011/06/21 08:31:23 jlec Exp $
+
+ 21 Jun 2011; Justin Lecher <jlec@gentoo.org> libint-1.1.2.ebuild,
+ libint-1.1.4.ebuild, libint-1.1.4-r1.ebuild:
+ Added fortran-2.eclass support
*libint-1.1.4-r1 (13 Feb 2010)
diff --git a/sci-libs/libint/libint-1.1.2.ebuild b/sci-libs/libint/libint-1.1.2.ebuild
index c5da744cc7ba..345f22527ff6 100644
--- a/sci-libs/libint/libint-1.1.2.ebuild
+++ b/sci-libs/libint/libint-1.1.2.ebuild
@@ -1,18 +1,17 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.2.ebuild,v 1.2 2006/07/09 07:11:27 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.2.ebuild,v 1.3 2011/06/21 08:31:23 jlec Exp $
-inherit eutils
+inherit eutils fortran-2
-DESCRIPTION="Used to evaluate traditional and novel two-body matrix elements (integrals) over Cartesian Gaussian functions"
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
HOMEPAGE="http://www.ccmst.gatech.edu/evaleev/libint/"
SRC_URI="http://www.ccmst.gatech.edu/evaleev/libint/src/${P}.tar.gz"
-LICENSE="GPL-2"
+
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="x86"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}"
src_unpack() {
unpack ${A}
@@ -28,8 +27,7 @@ src_compile() {
econf \
--enable-shared \
--enable-deriv \
- --enable-r12 \
- || die "econf failed"
+ --enable-r12
emake || die "emake failed"
}
diff --git a/sci-libs/libint/libint-1.1.4-r1.ebuild b/sci-libs/libint/libint-1.1.4-r1.ebuild
index 4609b17bad9c..f5212cc3352f 100644
--- a/sci-libs/libint/libint-1.1.4-r1.ebuild
+++ b/sci-libs/libint/libint-1.1.4-r1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.4-r1.ebuild,v 1.1 2010/02/13 18:27:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.4-r1.ebuild,v 1.2 2011/06/21 08:31:23 jlec Exp $
-EAPI="3"
+EAPI=3
-inherit eutils toolchain-funcs
+inherit eutils fortran-2 toolchain-funcs
-DESCRIPTION="Used to evaluate traditional and novel two-body matrix elements (integrals) over Cartesian Gaussian functions"
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
HOMEPAGE="http://www.chem.vt.edu/chem-dept/valeev/software/libint/libint.html"
SRC_URI="http://www.chem.vt.edu/chem-dept/valeev/software/libint/src/${P}.tar.gz"
-LICENSE="GPL-2"
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64"
IUSE=""
diff --git a/sci-libs/libint/libint-1.1.4.ebuild b/sci-libs/libint/libint-1.1.4.ebuild
index fc5de514196c..d694f8e1a9e1 100644
--- a/sci-libs/libint/libint-1.1.4.ebuild
+++ b/sci-libs/libint/libint-1.1.4.ebuild
@@ -1,20 +1,19 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.4.ebuild,v 1.2 2010/02/13 18:27:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libint/libint-1.1.4.ebuild,v 1.3 2011/06/21 08:31:23 jlec Exp $
-EAPI="3"
+EAPI=3
-inherit toolchain-funcs
+inherit fortran-2 toolchain-funcs
-DESCRIPTION="Used to evaluate traditional and novel two-body matrix elements (integrals) over Cartesian Gaussian functions"
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
HOMEPAGE="http://www.chem.vt.edu/chem-dept/valeev/software/libint/libint.html"
SRC_URI="http://www.chem.vt.edu/chem-dept/valeev/software/libint/src/${P}.tar.gz"
-LICENSE="GPL-2"
+
SLOT="0"
+LICENSE="GPL-2"
KEYWORDS="~x86 ~amd64"
IUSE=""
-RDEPEND=""
-DEPEND="${RDEPEND}"
src_configure() {
econf \