summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2005-12-06 11:03:18 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2005-12-06 11:03:18 +0000
commitcd92b482e2ddc8ab70136152cf7b471febb30619 (patch)
treecd81554a6b3ec8a406710faa2448ac03ec033eca /sci-libs/libghemical
parentMinor fixes (diff)
downloadgentoo-2-cd92b482e2ddc8ab70136152cf7b471febb30619.tar.gz
gentoo-2-cd92b482e2ddc8ab70136152cf7b471febb30619.tar.bz2
gentoo-2-cd92b482e2ddc8ab70136152cf7b471febb30619.zip
Bump. Remove faulty libf2c dep; block on mpqc-2.3, pending upstream bug #237; Change openbabel dep to =1*, pending upstream bug #238; Add needed deps on virtual/blas and virtual/lapack.
(Portage version: 2.0.53)
Diffstat (limited to 'sci-libs/libghemical')
-rw-r--r--sci-libs/libghemical/ChangeLog10
-rw-r--r--sci-libs/libghemical/files/digest-libghemical-1.911
-rw-r--r--sci-libs/libghemical/libghemical-1.91.ebuild40
3 files changed, 50 insertions, 1 deletions
diff --git a/sci-libs/libghemical/ChangeLog b/sci-libs/libghemical/ChangeLog
index 3d822ab8c270..7609687a6b30 100644
--- a/sci-libs/libghemical/ChangeLog
+++ b/sci-libs/libghemical/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/libghemical
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.2 2005/12/05 17:13:08 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.3 2005/12/06 11:03:18 spyderous Exp $
+
+*libghemical-1.91 (06 Dec 2005)
+
+ 06 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>;
+ +libghemical-1.91.ebuild:
+ Bump. Remove faulty libf2c dep; block on mpqc-2.3, pending upstream bug
+ #237; Change openbabel dep to =1*, pending upstream bug #238; Add needed
+ deps on virtual/blas and virtual/lapack.
02 Dec 2005; Donnie Berkholz <spyderous@gentoo.org>; +metadata.xml,
+libghemical-1.90.ebuild:
diff --git a/sci-libs/libghemical/files/digest-libghemical-1.91 b/sci-libs/libghemical/files/digest-libghemical-1.91
new file mode 100644
index 000000000000..39035a6f7064
--- /dev/null
+++ b/sci-libs/libghemical/files/digest-libghemical-1.91
@@ -0,0 +1 @@
+MD5 6832615a8411c46c6f1b011a7354106e libghemical-1.91.tgz 1087881
diff --git a/sci-libs/libghemical/libghemical-1.91.ebuild b/sci-libs/libghemical/libghemical-1.91.ebuild
new file mode 100644
index 000000000000..850042bb5475
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-1.91.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-1.91.ebuild,v 1.1 2005/12/06 11:03:18 spyderous Exp $
+
+inherit eutils
+
+DESCRIPTION="Ghemical supports both quantum-mechanics (semi-empirical and ab initio) models and molecular mechanics models (there is an experimental Tripos 5.2-like force field for organic molecules). Also a tool for reduced protein models is included. Geometry optimization, molecular dynamics and a large set of visualization tools are currently available."
+HOMEPAGE="http://www.uku.fi/~thassine/ghemical/"
+SRC_URI="http://www.uku.fi/~thassine/ghemical/download/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE="mopac7 mpqc openbabel"
+
+RDEPEND="virtual/glut
+ mopac7? ( sci-chemistry/mopac7 )
+ openbabel? ( =sci-chemistry/openbabel-1.100.2 )
+ mpqc? ( sci-chemistry/mpqc )
+ !=sci-chemistry/mpqc-2.3.0
+ virtual/blas
+ virtual/lapack"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+
+src_compile() {
+ libtoolize --copy --force
+
+ ./configure \
+ --prefix=/usr \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ $(use_enable openbabel) || die "Configure failed"
+ emake || die "Make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Install failed"
+}