summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffrey Gardner <je_fro@gentoo.org>2008-11-30 01:00:00 +0000
committerJeffrey Gardner <je_fro@gentoo.org>2008-11-30 01:00:00 +0000
commit540098cc79681b367c329c42cb2d06899431c4a8 (patch)
tree5a6d0c56066a4e16d4b78e812f597ff5c89b836e /sci-libs/libghemical
parentPull in locale.h since defines from it are used #241322 by Diego E. Pettenò. (diff)
downloadgentoo-2-540098cc79681b367c329c42cb2d06899431c4a8.tar.gz
gentoo-2-540098cc79681b367c329c42cb2d06899431c4a8.tar.bz2
gentoo-2-540098cc79681b367c329c42cb2d06899431c4a8.zip
Fix compilation, thanks to Arch guy abhidg at http://www.bioinformatics.org/pipermail/ghemical-devel/2008-August/000752.html
(Portage version: 2.1.6_rc2/cvs/Linux 2.6.27-gentoo-r4 x86_64)
Diffstat (limited to 'sci-libs/libghemical')
-rw-r--r--sci-libs/libghemical/ChangeLog8
-rw-r--r--sci-libs/libghemical/files/libghemical-2.98-gcc43.patch43
-rw-r--r--sci-libs/libghemical/libghemical-2.98.ebuild4
3 files changed, 52 insertions, 3 deletions
diff --git a/sci-libs/libghemical/ChangeLog b/sci-libs/libghemical/ChangeLog
index e98a8fadd267..5f8058fa9a78 100644
--- a/sci-libs/libghemical/ChangeLog
+++ b/sci-libs/libghemical/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/libghemical
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.18 2008/11/27 19:19:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/ChangeLog,v 1.19 2008/11/30 01:00:00 je_fro Exp $
+
+ 30 Nov 2008; Jeff Gardner <je_fro@gentoo.org>
+ +files/libghemical-2.98-gcc43.patch, libghemical-2.98.ebuild:
+ Fix compilation, thanks to Arch guy abhidg at
+ http://www.bioinformatics.org/pipermail/ghemical-devel/2008-August/000752.
+ html
*libghemical-2.98 (27 Nov 2008)
diff --git a/sci-libs/libghemical/files/libghemical-2.98-gcc43.patch b/sci-libs/libghemical/files/libghemical-2.98-gcc43.patch
new file mode 100644
index 000000000000..d92d31d93b74
--- /dev/null
+++ b/sci-libs/libghemical/files/libghemical-2.98-gcc43.patch
@@ -0,0 +1,43 @@
+--- src/atom.h.orig 2008-06-09 03:59:34.262567972 -0500
++++ src/atom.h 2008-06-09 04:00:07.136698792 -0500
+@@ -10,6 +10,8 @@
+ #ifndef ATOM_H
+ #define ATOM_H
+
++#include <cstdlib>
++#include <cstring>
+ #include "libghemicaldefine.h"
+ #include "libghemicalconfig2.h"
+
+--- src/notice.h.orig 2008-06-09 04:00:24.472509840 -0500
++++ src/notice.h 2008-06-09 04:00:44.608265748 -0500
+@@ -10,6 +10,7 @@
+ #ifndef NOTICE_H
+ #define NOTICE_H
+
++#include <cstring>
+ #include "libghemicaldefine.h"
+ #include "libghemicalconfig2.h"
+
+--- src/sasaeval.cpp 2008-08-01 09:39:01.000000000 +0530
++++ src/sasaeval.cpp 2008-08-01 09:40:33.000000000 +0530
+@@ -21,6 +21,9 @@
+ #include "sasaeval.h"
+
+ #include "engine.h"
++#include <vector>
++#include <algorithm>
++using namespace std;
+
+ // the surface area code apparently contains some bugs, since it sometimes
+ // crashes. another possibility is that the surface area math contains some
+--- src/sasaeval.h 2008-07-31 00:40:08.000000000 +0530
++++ src/sasaeval.h 2008-08-01 09:40:04.000000000 +0530
+@@ -24,6 +24,7 @@
+ #define SASAEVAL_H
+
+ #include "typedef.h"
++#include <stdlib.h>
+
+ struct cg_nbt3_nl; // SASA neighbor list.
+
diff --git a/sci-libs/libghemical/libghemical-2.98.ebuild b/sci-libs/libghemical/libghemical-2.98.ebuild
index 52c2c6eab453..b35ef696e2bb 100644
--- a/sci-libs/libghemical/libghemical-2.98.ebuild
+++ b/sci-libs/libghemical/libghemical-2.98.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.98.ebuild,v 1.1 2008/11/27 19:19:26 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.98.ebuild,v 1.2 2008/11/30 01:00:00 je_fro Exp $
inherit autotools
@@ -23,7 +23,7 @@ RDEPEND="mopac7? ( >=sci-chemistry/mopac7-1.13-r1 )
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${PN}-gcc43.patch
+ epatch "${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}